[Tailscale-native] (updated info.) ATTENTION new 1.62.1 crash at start

Native port (no docker) of tailscale VPN client / server
A frustratingly simple VPN.
Tailscale lets you easily manage access to private resources, quickly SSH into devices on your network, and work securely from anywhere in the world.

Moderator: Lillian.W@AST

Post Reply
User avatar
father.mande
Posts: 1814
youtube meble na wymiar Warszawa
Joined: Sat Sep 12, 2015 2:55 am
Location: La Rochelle (France)

[Tailscale-native] (updated info.) ATTENTION new 1.62.1 crash at start

Post by father.mande »

Hi,

I just update tailscale internally (tailscale_mngt update)
ATTENTION

On some NAS after update ... tailscaled crash and it's not possible to restart it (crash at each start)
PROBLEM ... no coherency at this time
x86_64 with 4.2.7 works , some with oldest 4.0.6.RNS1 (AS5002 not ADM up-gradable) works
arm64 works fine
BUT some other
x86_64 with 4.2.7 fail (AS52002T)
armhf AS1002T ... fail also ...

I works on it and open a ticket in tailscale github.

WHAT YOU CAN DO ... if you have the problem ...
1 in a root terminal (or any admin and use sudo) do :
tailscale_mngt stop (2 times)
cd /usr/local/AppCentral/tailscale-native/bin
rename tailscale and tailscaled binary (or remove)
mv tailscale tailscale.bad
mv tailscaled tailscaled.bad

rename tailscale.prev to tailscale and tailscaled.prev to tailsclaed
mv tailscale.prev tailscale
mv tailscaled.prev tailscaled


then restart
tailscale_mngt start ... you go back to previous version REMEBER to suppress cron if you update using cron.

Philippe.
Last edited by father.mande on Sun Mar 31, 2024 10:35 pm, edited 1 time in total.
AS6602T / AS5202T /AS5002T / AS1002T / FS6706T
User avatar
father.mande
Posts: 1814
Joined: Sat Sep 12, 2015 2:55 am
Location: La Rochelle (France)

Re: [Tailscale-native] ATTENTION update 1.62.1 (internal shell script)

Post by father.mande »

Hi,

Some news ...

Tailscale team (for 1.62.1) have identified a problem when ipv6 is up (WebUI / Settings / Network / Enable IPv6 checked)
BUT no ip6tables (firewall) exist (this is bypassed prior to 1.62.1)
... this generate a Panic in tailscaled ...

SOLUTTIONS
1 ... if you don't use ipv6 uncheck it and restart tailscale
if you use IPV6 :
2 ... wait for the new version 1.63 that introduce a patch to bypass the error (this error exist on other Brand node than Asustor only)
... ... I have compiled a version based on github and this solve the problem ... so just wait or ask me (for a temporary build version) if it's urgent (x86_64 only at this time) ... I prepare other arch.
3 ... I have build kernel modules to add ip6tables (filter / nat / etc.), when using this kernel modules problem is solved with current stable 1.62.1
... ... I have it for x86_64 ADM 4.2.6+
... ... I generate it at this time for ADM 4.0.6+ (NAS not able to be updated to 4.2.6 (ex. AS5002T))
... ... I will generate for other platform arm64 first and if possible Armhf and x86 32 bits) ... if it's not possible tha patch created by tailscale team help you ... even using IPv6 don't get all the capabilities of tailscale.

A new APKG arrive soon (based on my free time) with iptables ipv6 support.

Philippe.
AS6602T / AS5202T /AS5002T / AS1002T / FS6706T
Post Reply

Return to “Tailscale-native”