It is currently Thu Oct 21, 2021 3:38 am
All times are UTC + 8 hours

Your connection is not private

New to the forum? Introduce yourself, chit chat and chew the fat.

Your connection is not private

Postby dwestenk » Mon Sep 13, 2021 9:00 pm

Newbie question. When I first connect to my NAS via my browser I get this Privacy Error.

help.jpg
help.jpg (18.02 KiB) Viewed 280 times


1. Do I need to worry about this?
2. If so, how do I make my connection private?
dwestenk
 
Posts: 3
Joined: Tue Dec 15, 2020 9:55 pm

Re: Your connection is not private

Postby father.mande » Mon Sep 13, 2021 9:05 pm

Hi,

It's due to the certificate, Asustor provide a certificate, but not signed by and authority for your own NAS
... bypass, check advanced and use the URL displayed

BUT better add a valid certificate ... use lets'encrypt to generate one (free), so after the certificate will be valid and you don't see again this .

at end don't forget to use only HTTPS for connection (Internet but also in your private LAN) to avoid problem with some browser (warning message for the moment)

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1235
Joined: Sat Sep 12, 2015 2:55 am

Re: Your connection is not private

Postby dwestenk » Tue Sep 14, 2021 12:12 am

If I only use my web browser to connect to my NAS while on the local network, i.e., not from anywhere outside, do I need a certificate?

The directions for how to set up a certificate using Let's Encrypt are somewhat cryptic. (https://www.asustor.com/online/College_topic?topic=324 and https://www.asustor.com/knowledge/detail/?group_id=1006). I use a non-ASUS router, namely an Orbi RBR50 router; when I enter my WAN IP and :80 in the browser address bar, I do not get the Congratulations page. I get an Access forbidden! Error 403 page. From there I'm not sure what to do despite the "*If you are not able to see the Congratulations page ..." instructions at the bottom of the https://www.asustor.com/knowledge/detail/?group_id=1006 page.

Any suggestions??
dwestenk
 
Posts: 3
Joined: Tue Dec 15, 2020 9:55 pm

Re: Your connection is not private

Postby orion » Tue Sep 14, 2021 10:22 am

It's just a warning from browser. If you are sure the server is good (ex: your own NAS), as father.mande suggested, select "Advance", select the URL.
User avatar
orion
 
Posts: 3198
Joined: Wed May 29, 2013 11:09 am

Re: Your connection is not private

Postby dwestenk » Wed Sep 15, 2021 7:36 pm

Let's say that I'm not sure.

Then... The directions for how to set up a certificate using Let's Encrypt are somewhat cryptic. (https://www.asustor.com/online/College_topic?topic=324 and https://www.asustor.com/knowledge/detail/?group_id=1006). I use a non-ASUS router, namely an Orbi RBR50 router; when I enter my WAN IP and :80 in the browser address bar, I do not get the Congratulations page. I get an Access forbidden! Error 403 page. From there I'm not sure what to do despite the "*If you are not able to see the Congratulations page ..." instructions at the bottom of the https://www.asustor.com/knowledge/detail/?group_id=1006 page.

Any suggestions??
dwestenk
 
Posts: 3
Joined: Tue Dec 15, 2020 9:55 pm

Re: Your connection is not private

Postby Nazar78 » Wed Sep 15, 2021 11:40 pm

The error 403 you're seeing is actually your router's admin page which is blocked when being accessed via the internet. You need to set up your router's port forwarding https://kb.netgear.com/31069/How-do-I-c ... rbi-system or use the Asustor EZ-Router (turn on UPnP on your router's settings) in the Settings->Manual Connect->EZ-Router. Activate it using the default ADM https port 8001.

Note you will still get the certificate error when you access using your WAN IP. It needs to be a domain whichever you had chose in the DDNS i.e. https://your-id.myasustor.com:8001.

Warning! Opening these access to the internet has its risks unless you're very sure what you're doing. Best to run and access them behind a reverse proxy or VPN. Locally you can actually use the DDNS and HTTPS to avoid the certificate error without opening access to the internet but provided your router is able to do a NAT loopback, or another way is to use host files on the clients pointing the hostname (FQDN) to the local IP.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 489
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Return to Meet and Greet

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest