It is currently Tue Nov 19, 2019 9:59 am
All times are UTC + 8 hours

Should I Expect MailSVR To Work For Me?

ASUSTOR’s Mail Server offers a comprehensive and cost-effective solution that allows any business to easily maintain their own dedicated mail server.

Should I Expect MailSVR To Work For Me?

Postby fgs » Sat Jul 22, 2017 3:49 am

Greetings. Thanks for reading that too. I just purchased my Asustor (AS6204r) and I must tell, the mail server official app was a tipping point on purchase making. I do have experience on setup of other open source mail server software, BTW.

I followed the Asustor white paper for mailserver ( https://www.asustor.com/en/online/Colle ... opic=269#1 ) and I noticed the whole context of the configuration is based on a third-party service called " No IP ", correct? I don't need that, I don't want that. Hence my subject question, should I still expect it to work?

My Asustor is sitting on a real IP, with a "MX"-type "DNS" record in place. If I "telnet" the mailserver at port 25 I get proper response. However, all mail sent to Asustor from mail client such as " ThunderBird " is stuck at the queue at the Asustor mail server with status "queued". From experience again, that kind of queue message stuck is result of some DNS configuration issue. Something I can't tell at this point. My Asustor also includes a "rDNS"-type record pointing to the same fully-qualified domain name used by the Asustor and mail server's main domain setting.

Where do you recommend to look at? Is Asustor liable for making an app work as should? I'm starting to wonder. Thank you.
fgs
 
Posts: 19
Joined: Sun Jul 16, 2017 9:46 pm
Location: Alcabideche, Portugal, EU.

Re: Should I Expect MailSVR To Work For Me?

Postby fgs » Wed Jul 26, 2017 10:58 pm

Me again. I obviously try to write honest assessment about anything and I must tell that I've made very good progress about this issue looking at my set of " DNS " records.

Still have work to do in terms of seeing the stability over a period of time but it seems the server is operational for now. :oops:

Nonetheless, I think the manufacturer should try to put together a few " wizard " type of initial screens checking the very ("DNS" setup) basics in place. Isn't that hard, is it?

Anyway. Thanks.
fgs
 
Posts: 19
Joined: Sun Jul 16, 2017 9:46 pm
Location: Alcabideche, Portugal, EU.

Re: Should I Expect MailSVR To Work For Me?

Postby Kapitein Haak » Thu Jul 27, 2017 4:06 pm

Hello fgs,

I just checked the white paper and it seems to be quite fine. The setting up of the DNS entries is something which differs a lot per ISP (where you can register your own domainname). It is not that hard to setup a MX record and to replace the asustor domain name with your own domainname.

Best regards,
Kapitein Haak.
"What would the world be like without Captain Hook?"
---
"Homo sapiens non urinat in ventum" (A wise man doesn't piss into the wind), only in Amsterdam:
https://www.google.nl/maps/@52.36289,4. ... 312!8i6656
User avatar
Kapitein Haak
 
Posts: 333
Joined: Tue Oct 15, 2013 2:40 pm
Location: Stranded on the Dutch coast.

Re: Should I Expect MailSVR To Work For Me?

Postby fgs » Tue Aug 01, 2017 1:23 am

Thanks for your comments. In the meanwhile, my remaining yet very important issue is to properly configure what they call " alias ", on that tab.

I'm seeing that " delivery failure notification " is being returned to the sender by my mailserver. Those failures refer to the " alias " addresses which, of course, don't have a local NAS user for it because they're " alias ", right? The " virtual " user for that mail domain is linked to a NAS local user instead.

Diagnostic-Code: X-Postfix; unknown user: " < alias username > "

Yet, the original message gets delivered to my IMAP, local NAS user box, somehow. Before I bother the manufacturer with something stupid, what should I expect by the " alias " feature? The " external mail box " field refers to what exactly? Nothing gets mentioned on that reference whitepaper...

I thank you for your online time and patience.
Last edited by fgs on Fri Aug 04, 2017 10:42 pm, edited 1 time in total.
fgs
 
Posts: 19
Joined: Sun Jul 16, 2017 9:46 pm
Location: Alcabideche, Portugal, EU.

Re: Should I Expect MailSVR To Work For Me?

Postby fgs » Fri Aug 04, 2017 10:40 pm

I moved forward with a support ticket with great Asustor people and the result is currently unacceptable.

They state the need for every " alias " E-Mail address one corresponding local NAS user. That's obviously not an "alias " feature proper implementation. A proper " alias " address is a "virtual " user that only exist for the purpose of accepting mail on behalf of a real local NAS user.

I'm currently urging them to reconsider this situation and I'll be glad to work with them on a few "PostFix" config files under the hood.

Thank you.
fgs
 
Posts: 19
Joined: Sun Jul 16, 2017 9:46 pm
Location: Alcabideche, Portugal, EU.

Re: Should I Expect MailSVR To Work For Me?

Postby fgs » Fri Sep 01, 2017 5:48 am

Greetings! Me yet again for a final update.

After some discussion within Asustor ticket system, the agent clarified what seems to have happened and confirmed the alias feature is supposed to work as an alias, tied up to a local NAS user.

I recently upgraded to OS v.3 stable and the "unknown user" that I was getting as delivery return receipts for my alias are now gone and I'm happy with it. As you can see from reading above, after some hassle, things are now in place the way I wanted.

Thank you.
fgs
 
Posts: 19
Joined: Sun Jul 16, 2017 9:46 pm
Location: Alcabideche, Portugal, EU.

Return to Mail Server

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest