It is currently Wed Nov 13, 2019 10:38 am
All times are UTC + 8 hours

Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Xorg is the public, open-source implementation of the X Window system. An installation of Xorg is required to run multimedia Apps such as Boxee, KODI and iTunes Server.

Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby Tarl Cabot » Mon Mar 13, 2017 2:30 pm

"Hory buggered betas, Batman!" I realize it's just a beta, but seriously Asustor? Your "engineers" published R29 without even checking if HDMI was still functional?

LOL! Nice job folks, keep up the great work!

As for any fellow users that got burned: If you lost HDMI after installing R29 and can't wait around for Asustor to fix their buggy code, you may want to try father.mande's roll-back instructions. But do so only if you are comfortable modifying critical root files. I tested the procedure on an AS5102T and it worked perfectly.

His instructions are here: viewtopic.php?f=72&t=8701&start=10#p27590

Cheers!
AS-5102T with Crucial 8GB RAM Kit (2x4GB) DDR3L 1600 PC3-12800 1.35V CL11
2x4TB Western Digital NAS Reds - RAID 1
BIOS: v1.21 ADM: 2.7.0.RF72 (March '17)
Asustor Remote - Logitech Wireless keyboard/mouse

"Any sufficiently advanced technology is indistinguishable from magic." Arthur C. Clarke
User avatar
Tarl Cabot
 
Posts: 12
Joined: Mon Sep 28, 2015 4:42 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby James.S@AST » Wed Mar 15, 2017 2:40 pm

Dear Tarl,

We just published the ASUSTOR Portal 2.0.3.R1227 for AS31/32/50/51/61/62/70 series to solve this issue.
Please update it via App Central--> Beta Apps section.
if the issue persists, please let me know.

Thank you,
JAMES
I dream of painting and then I paint my dream.

Storage: AS-604T
Network: Belkin N1 Wireless/F5D8231
Laptop: ASUS Windows 7 64-bit Ultimate
Media Player: HP NC6000& Wii & ASUSTOR NAS with Boxee App
Portable: HTC EVO 3D& The New iPad
User avatar
James.S@AST
 
Posts: 292
Joined: Wed May 23, 2012 8:18 pm

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby father.mande » Wed Mar 15, 2017 4:26 pm

Hi,
DELETED erroneous ...

Philippe.
Last edited by father.mande on Wed Mar 15, 2017 6:45 pm, edited 1 time in total.
AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 808
Joined: Sat Sep 12, 2015 2:55 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby orion » Wed Mar 15, 2017 4:44 pm

I think they solved this issue in Asustor Portal App, rather than xorg. (I cannot try it because my NAS is AS-304T whose xorg does not update.)
User avatar
orion
 
Posts: 2382
Joined: Wed May 29, 2013 11:09 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby father.mande » Wed Mar 15, 2017 7:17 pm

Hi,

After updating Asportal to R1227 ... that also update Xorg (even without warning) to R29
... icon stay visible EVEN applications are disabled
ex. Vbox, VM_vbox, Plexmediaplayer

... changing Application status to Enable ... some applications don't start ... black screen ???

Reboot :

... status stay incoherent
applications are enable in AppCentral but not visible in Asportal
... disable / enable ... display it in Asportal (but each time asportal restart xorg reset it ??? fortunatly only one time (each) so not as previous

some applications (but not from Asustor) refuse to start ... don't use PlexMediaPlayer for ex. (even working before)
some other "virtualbox" freeze just after displaying their interface on screen ???
... only solution stop Virtualbox (or restart) (because no action possible (but I don't test all keys))
... BUT even now Enable ... and after a manual restart of asportal (to see) ... the virtualbox icon is NOT displayed ????

?????

I will try to continue some test ... but I work using a VPN at 1000 Kms of my NAS ... so a little difficult ...

Philippe.
AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 808
Joined: Sat Sep 12, 2015 2:55 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby father.mande » Wed Mar 15, 2017 7:56 pm

Hi,
Xorg R29 :
Just a (big) thanks to developer that move libraries or link from one place (in Xorg) to another one without assuming compatibility

Is it possible to do this by inadvertence ? ... except if it's a new policy to restrict other Asportal application to exist ... I don't think so :roll:

New version of PlexMediaPlayer is needed to workaround this change ... so not usable with new beta Asportal / Xorg for the moment ...
Philippe.
AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 808
Joined: Sat Sep 12, 2015 2:55 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby James.S@AST » Thu Mar 16, 2017 2:54 pm

Hi Philippe,
Sorry for not letting you know in advance about our changes on xorg R29 beta.
The new Xorg R29 upgraded the ffmpeg library version from 2.8.7 to 3.1.7 for KODI 17.0 and also change some library path.

After change the PlexMediaPlayer app, the libselinux.so.1, libpcre.so.3 arenot able to link after our changes.
You may add /usr/local/AppCentral/xorg/lib path in run_pmp.sh and it should work.

Thank you once again for providing the great apps for ASUSTOR NAS user.

Cheers,
JAMES
I dream of painting and then I paint my dream.

Storage: AS-604T
Network: Belkin N1 Wireless/F5D8231
Laptop: ASUS Windows 7 64-bit Ultimate
Media Player: HP NC6000& Wii & ASUSTOR NAS with Boxee App
Portable: HTC EVO 3D& The New iPad
User avatar
James.S@AST
 
Posts: 292
Joined: Wed May 23, 2012 8:18 pm

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby father.mande » Thu Mar 16, 2017 4:10 pm

Hi James,

I know the problem and the solution (please don't lost time to solve my APKG, I don't require this :lol: , normally I know how debugging my own project ) ... but building new version only to a change due to position of lib ... I always try without adding personal libraries to don't add more library path to avoid race condition ... due to delay added ...

BUT you are master in your castle ...

Also if you add and update ffmpeg to 3.1.7 ... I can suppress my APKG requested for serviio, (armhf and x86_64) ... but remember (sorry it's not my problem but) I will do port of kodi17 on other NAS (on Asustor only a stop gap game) ... using external ffmpeg is not the best way (my opinion) ... having the ffmpeg integrated lost a small space in memory but are sure to be coherent for each new version without changing ffmpeg each time (same for my own with plexmediaplayer where I don't use external ffmpeg but integrated (in pmp) version)

Philippe.
AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 808
Joined: Sat Sep 12, 2015 2:55 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby TheDoogy » Fri Mar 31, 2017 4:46 pm

Hi,

I can't save the screen resolution on my AS6204T with AS Portal 2.0.3.r1227 and X.Org 10.14.7.R29.
At each startup, the following screen resolution "std_1920x1080@60.00" is selected by default whereas I selected and saved ASUSTOR 4k during the previous session.

One more thing. It seems that this configuration is done for TVs that could have some problem of compatibility with asustor 4K resolution...
So, why no other regular 4K configuration is available ?

Thank you for your help.
Best regards,

Nicolas
TheDoogy
 
Posts: 9
Joined: Tue Feb 21, 2017 12:52 am

Re: Xorg 10.14.7.R29 a.k.a., Asustor's Busted Beta

Postby orion » Fri Mar 31, 2017 5:21 pm

TheDoogy wrote:Hi,

I can't save the screen resolution on my AS6204T with AS Portal 2.0.3.r1227 and X.Org 10.14.7.R29.
At each startup, the following screen resolution "std_1920x1080@60.00" is selected by default whereas I selected and saved ASUSTOR 4k during the previous session.

One more thing. It seems that this configuration is done for TVs that could have some problem of compatibility with asustor 4K resolution...
So, why no other regular 4K configuration is available ?

Thank you for your help.
Best regards,

Nicolas

I think you'd better to send a support request to check it. https://support.asustor.com/
User avatar
orion
 
Posts: 2382
Joined: Wed May 29, 2013 11:09 am

Return to xorg

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 0 guests

cron