It is currently Sat Nov 28, 2020 10:44 am
All times are UTC + 8 hours

AiVideos Host/IP stuck on loading

AiVideos brings you the smoothest mobile video viewing experience around. Browse through the video collection on your NAS without needing to wait for long downloads. Enjoy high-definition 1080p streaming video with just one click.
You can even select multilingual subtitles and different audio channels to enjoy films in different languages, bringing the movie theatre to your mobile device.

AiVideos Host/IP stuck on loading

Postby giostark » Mon Dec 03, 2018 9:43 am

Hi all,
As the title, seems to appear this issue just with AiVideos mobile App.
From my mobile phone (WiFi connection) I can connect via internal network (192.168.1.x) BUT NOT with the Host/IP.
All the other app AiData , AiFoto, Ai master, AiMusic ,Ai secure , ecc can connect fine via Host/IP.
Is mentioned that I should open some port in the EZ Settings , but there is no option as the guide show. Should this come automatically via EZ?
When I installed looksgood was checked " forwarding ..." so I suppose that should activate it automatically.

Any advice ?

Posts: 13
Joined: Mon Feb 05, 2018 11:22 pm

Re: AiVideos Host/IP stuck on loading

Postby Marco@ASUSTOR » Tue Dec 04, 2018 4:13 pm

Hi! Our technical support team suggested to try this.

First go to to check port 9900 to see if it is open and forwarded properly.

Check Settings > Manual Connect > EZ-router and see which ports have been forwarded successfully.

And also check and see if https is enabled or not in Settings > General > Manangement.

If so, try disabling https and try again.
Posts: 100
Joined: Mon Feb 12, 2018 4:40 pm

Re: AiVideos Host/IP stuck on loading

Postby giostark » Sun Dec 09, 2018 9:52 am

Hi Marco!
This is weird ... :geek:
After the last ADM update I cant even enter the looksgood app from desktop computer in local network !
I opened the port range 9900-9908 TCP in the router and it result opened using your checking app.
I tried to use or disable https and nothing change.

I tried to use Firefox and Opera.
With Firefox the looksgood app ask for credential and stay on login screen forever .
If I try to login in the control panel and enter in the looksgood app ,the tab blink and stay all black with just "login" on the top right and the lookgood icon on the top left. Re enter credential is useless , all stay black.

If I use opera same scenario. The app is stuck on the attempt to login. from the control center (so already logged in as administrator).
If I try to login directly in the app Opera report invalid username or password. Of course are right both.

From mbile same thing...stuck on the attemp to login (stay forever on "loading")

Also the attempt to reinstall the app didnt work.
Something seems corrupt or gone bad after the last update.


Many thanks for your time...
Posts: 13
Joined: Mon Feb 05, 2018 11:22 pm

Re: AiVideos Host/IP stuck on loading

Postby someone » Wed Oct 16, 2019 12:44 am

Had the same problem in Firefox.
Anyone who can't even login to Looksgood probably will have to follow these steps ... with-https
(or any other way to add and as Security Exception for https certificates in your browser, where xxx has to be the NAS IP of course)
Posts: 1
Joined: Wed Oct 16, 2019 12:29 am

Re: AiVideos Host/IP stuck on loading

Postby Jeremy Williams » Thu Jun 25, 2020 8:15 pm

Has your issue been resolved following the steps suggested by the guys who have responded? I am facing the same problem.
Jeremy Williams
Posts: 5
Joined: Wed Jun 17, 2020 6:52 pm

Return to AiVideos

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest