Page 1 of 1

Problem connecting to SMTP server

PostPosted: Wed Oct 05, 2016 11:14 am
by yield2ten
I'm having a problem getting the Mail Server to work. I have a domain name set up with a correct MX record. To make things simple I'm using Thunderbird on the same local network as my AS3202t. Server settings are simply the local IP address of the NAS / mail server. I if i check for mail, it's able to successfully log in and reports no new messages, which is correct. When I attempt to send an email, I get an error message that says "Mail server responded 4.7.1<email_address>:Relay access denied." I have get this same message with Mail Server SMTP port set to 25, with or without SSL Port 465 enabled. I also get this same message whether or not SMTP Relay Server is enabled or disabled. I've tried enabling the Relay server using smtp.live.com for the relay server, and then my appropriate hotmail.com email credentials. I've also tried using a gmail relay server with my gmail account credentials, and I get the same error messages no matter what settings I try.

If I try to connect to the mail server from outside my local network, using my domain name, I'm again able to connect to check mail without any error messages, but when I attempt to send an email, I get a message saying "Connection to the outgoing server (SMTP) timed out". Any suggestions? I have Comcast for my ISP and suspect they may be blocking port 25. Is the Mail Server able to use port 587? FWIW, I do have port 25 and 587 forwarded on my router. A port scan on my public IP does not show port 25 open, and port 587 shows that it's filtered. Any help would be greatly appreciated.

Re: Problem connecting to SMTP server

PostPosted: Sun Oct 09, 2016 6:13 am
by Igor_thedoberman
Hi

One easy fix for this is to use your smtp from your ISP, just put in their smtp in thunderbird and you will be sending mail in no time.

Re: Problem connecting to SMTP server

PostPosted: Tue Oct 11, 2016 11:45 am
by yield2ten
The mail server is not able to receive messages, inbound messages are returned with a message that the mail server could not be reached. Can anyone confirm if the mail server can be set to port 587? I assume not, since it doesn't seem to be working when I try it.

Re: Problem connecting to SMTP server

PostPosted: Tue Oct 11, 2016 2:59 pm
by Kapitein Haak
Hello yield2ten,

Port 587 is used for secure SMTP, almost all SMTP servers will try to deliver mail on port 25. Open up this port and forward it to your NAS. Then connect from an external computer to your ISP ip address on port 25 and see if you get a welcome prompt.

Best regards,
Kapitein Haak.

Re: Problem connecting to SMTP server

PostPosted: Fri Oct 14, 2016 10:11 am
by yield2ten
My ISP blocks port 25, so I believe that's why I'm having issues. I can't use my ISP's mail server as that will only connect on port 587. I was thinking I can maybe do something with IP tables on my router to get outbound to actually send on port 587, but that won't help incoming connections that are on port 25. I may just be out of luck...