Page 1 of 1

Setting up ownCloud with Asustor NAS and NoIP (HELP PLEASE)

PostPosted: Sat Jul 02, 2016 7:19 am
by Vizie
Hello! I've been running in to a problem with making my Asustor NAS's ownCloud go online with the use of NoIP. (Please move this thread if its in the wrong place.

Everything works like a charm on my local network, but after I got my NAS online with my domain the ownCloud app would not work. I've got some screenshot to try to show you guys what happens.

This is how it connects on my LAN. No problem at all:
https://gyazo.com/5995c4779bbf1733afbe8b5d2213033f
https://gyazo.com/ab882bc0dd01c404ba1ac80a51ba775f

This is how it screws up on the domain:
https://gyazo.com/ddf159c8ca07ced7f4890aac32600a9c
https://gyazo.com/98a6e835ce5ac691beb823bf89fa7e50


If anyone knows anything please reply. I've tried everything I could think of :(

Re: Setting up ownCloud with Asustor NAS and NoIP (HELP PLEASE)

PostPosted: Sun Jul 03, 2016 6:38 pm
by sksbir
Hello
This is a network configuration problem, not related to owncloud, but to every web page you want to give access from outside you local network.

problem in your case is that it seems that you have already mapped port 80 to ADM web server. So you can't map the same port to the web server.

Out of that, it is not safe to open a web server without mandatory https.


At a first try, you must get this page : https://gyazo.com/5995c4779bbf1733afbe8b5d2213033f
while using your domain name.

Re: Setting up ownCloud with Asustor NAS and NoIP (HELP PLEASE)

PostPosted: Tue Jul 05, 2016 12:37 am
by Vizie
Hi, thanks for the help!

I kind of solved the problem. Realised that owncloud was on port 80, and my Asustor on port 8000. I had configured all connections on port 80 on my router to be sent to the local IP of the NAS on port 8000. Hence, the requests to owncloud was sent to the wrong port on the NAS.

Even though I am now able to connect to owncloud outside of my local network, this solution means that I need to specify the port number in order to get access to owncloud. Is there any way to change the port of owncloud to the same as the NAS (8000).

Re: Setting up ownCloud with Asustor NAS and NoIP (HELP PLEASE)

PostPosted: Tue Jul 05, 2016 10:12 am
by orion
Vizie wrote:Hi, thanks for the help!

I kind of solved the problem. Realised that owncloud was on port 80, and my Asustor on port 8000. I had configured all connections on port 80 on my router to be sent to the local IP of the NAS on port 8000. Hence, the requests to owncloud was sent to the wrong port on the NAS.

Even though I am now able to connect to owncloud outside of my local network, this solution means that I need to specify the port number in order to get access to owncloud. Is there any way to change the port of owncloud to the same as the NAS (8000).

I don't think you can set ADM port the same as web server port. However you can redirect port 80 to web server, and redirect the other port to ADM one.