Page 1 of 1

outdated php version

PostPosted: Thu Dec 24, 2015 2:42 am
by myx
Hi there!

I am using a brandnew AS5004T with the actually updated ADM 2.5.1.RB62.
When I try to start ownCloud 8.1.4 (that was preinstalled) I receive the message "This version of ownCloud requires at least PHP 5.4.0
You are currently running 5.3.27. Please update your PHP version."

I see two ways of solving this issue: upgrading PHP or downgrading ownCloud.

I'm new on ADM, so I have no idea how to upgrade PHP on asustor or where to get an older version of ownCloud from.
Actually I did not find any hints on google or this forum.
(Usually I'm on centos - suse -ubuntu ...)


merry x-mas and thanks for the support!

myx

-------------------------------------
24.12.2015
(actually I'm "not allowed" to reply to posts in this forum ...)

Thank you for the hints!
After the Christmas days I will try to install 5.5 Beta of php that MikeG.6.5 suggested.
Maybe I do some research and install 2.5.2.RCG2 for testing. Actually there are no important data stored on the device.
I'll give feedback of how it worked. But this will take a few days!

Thank's
myx
----------------------------------------

----------------------------------------
25.12.2015

I just installed 5.5 Beta of php.
Seems to work fine.
-----------------------------------------

----------------------------------------
28.12.2015
I'm running PHP 5.5.13 and ownCloud 8.2.1 (stable) on 2.5.1.RB62 now. Works very well!
So I decided not to install ADM 2.5.2.RCG2.

Thank's for helping me.

@leecool: Would you please mark this Topic as solved

Myx
----------------------------------------------

Re: outdated php version

PostPosted: Thu Dec 24, 2015 9:41 am
by Vincent.T@AST
Hi myx,

We would suggest you to upgrade AS5004T with ADM 2.5.2 beta (http://www.asustor.com/betaProgram). In this new ADM, PHP 5.6 is integrated. So once you complete the ADM upgrade, you can start to use ownCloud.

Re: outdated php version

PostPosted: Thu Dec 24, 2015 10:18 am
by MikeG.6.5
I'm going to suggest that you go to the App Central application, and look in the Beta apps and install the 5.5 Beta of php that is there. If you have any data on your device you can't live without, that is. If it's brand new and still has the new computer smell on it, then it's worth a shot trying the beta upgrade.

Although I have already upgraded to 2.5.2.RCG2, and I did it without the issues others have had, I would be very leery of testing out the 2.5.2 beta until I heard reports form others here, in a production environment. So if you have any data on the NAS you can't move or don't want to lose, I would urge you to wait a bit.

Re: outdated php version

PostPosted: Thu Dec 24, 2015 4:32 pm
by sksbir
+1 with MikeG.6.5

I'm currently using owncloud 8.1.3 (updated with owncloud update tool ) with PHP 5.5 beta.
My AS5002T is still with ADM 2.5.1.RB62

Owncloud update tool suggests me to upgrade to 8.2.1, but I'm not in a hurry for that.

Re: outdated php version

PostPosted: Fri Dec 25, 2015 1:52 am
by MikeG.6.5
myx wrote:Hi there!

-------------------------------------
24.12.2015
(actually I'm "not allowed" to reply to posts in this forum ...)

Thank you for the hints!
After the Christmas days I will try to install 5.5 Beta of php that MikeG.6.5 suggested.
Maybe I do some research and install 2.5.2.RCG2 for testing. Actually there are no important data stored on the device.
I'll give feedback of how it worked. But this will take a few days!

Thank's
myx
----------------------------------------


Yeah, I think they are trying so hard to get rid of the spam, they are squashing real users by mistake. Send Shawn a PM or email and ask that they fix your account. I'm going to suggest anyone having problems do this, until Shawn asks me to stop... :)