It is currently Tue Dec 18, 2018 3:33 am
All times are UTC + 8 hours

[SOLVED] NAS needs SSL upgrade to get OC 8.1.1 working

ownCloud gives you universal access to your files through a web interface or WebDAV. It also provides a platform to easily view & sync your contacts, calendars and bookmarks across all your devices and enables basic editing right on the web. Installation has minimal server requirements, does not need special permissions and is quick. ownCloud is extendable via a simple but powerful API for applications and plugins.

Moderator: leecool

[SOLVED] NAS needs SSL upgrade to get OC 8.1.1 working

Postby sksbir » Sun Aug 30, 2015 8:26 am

hi
After installing OC APP from the APPstore, I've got Owncloud 8.0.3.
With this version , I was unable to activate OC applications, like contacts or calendar. Message log was : Invalid OCS content returned for app 166054
same with 166056/166053/166051.....

An update was available from within OC administration panel --> ok let's update. Update ran without problem

After that, I was unable to get OC application list from internet in the left pane of admin panel : just enabled/disabled list.
Message was : Could not get application: SSL CA bundle not found: /volume1/Web/owncloud/config/ca-bundle.crt
Ok, I have by chance an other OCserver installed on Ubuntu server, I copied ca-bundle.crt from that server.

Now I have the message
cURL error 60: SSL certificate problem: unable to get local issuer certificate

each time I try to activate an APP.

Taking a look on OC forum : my problem is already described here : https://forum.owncloud.org/viewtopic.php?f=31&t=29938 --> answer from RealRancor is here : https://forum.owncloud.org/viewtopic.php?f=17&t=29790

Problem

- The app page within your installation is just showing the "Not enabled" and "Enabled" categories and not any other like "Productivity".

- A "No internet connection" message is shown in your admin backend

Reasons

- A broken, outgoing connection to the appstore (https://apps.owncloud.com)
- Buggy versions of OpenSSL/NSS (oC 8.1.1 should show this in the admin backend)
- A missing config/ca-bundle.crt
- A disabled appstore ('appstoreenabled' => false, in your config.php)
- A wrong configured appstore URL (Remove 'appstoreurl' => from your config.php)
- Empty or wrong configured 'proxy' => '', in config.php


Ok, problem is here : while trying a wget from my NAS ( AS5002T ) :
Code: Select all
root@XXXX:/volume1/Web/owncloud/config # wget https://apps.owncloud.com
--2015-08-30 00:55:53--  https://apps.owncloud.com/
Resolving apps.owncloud.com (apps.owncloud.com)... 188.138.69.67
Connecting to apps.owncloud.com (apps.owncloud.com)|188.138.69.67|:443... connected.
ERROR: cannot verify apps.owncloud.com's certificate, issued by '/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certs.godaddy.com/repository//CN=Go Daddy Secure Certificate Authority - G2':
  Unable to locally verify the issuer's authority.
To connect to apps.owncloud.com insecurely, use `--no-check-certificate'.
root@XXXX:/volume1/Web/owncloud/config #


This same wget works well on my other owncloud 8.1.1 server installed on a updated ubutu ( 15.04 ) : I get index.html from the target URL.
Code: Select all
root@YYYY:/var/www/owncloud/config# wget https://apps.owncloud.com
--2015-08-30 01:56:44--  https://apps.owncloud.com/
Résolution de apps.owncloud.com (apps.owncloud.com)⦠188.138.69.67
Connexion à apps.owncloud.com (apps.owncloud.com)|188.138.69.67|:443⦠connecté.
requête HTTP transmise, en attente de la réponse⦠200 OK
Taille : non indiqué [text/html]
Enregistre : «index.html»

index.html                 [ <=>                         ]  37,68K  --.-KB/s   ds 0,02s

2015-08-30 01:56:44 (1,91 MB/s) - «index.html» enregistré [38585]

root@YYYY:/var/www/owncloud/config#


so the problem is nothing to do with owncloud but with obsoleted SSL libraries or something like that. Of course, my NAS is updated.
ADM 2.4.2.RIG1
bios 1.21
and all APP ar updated.

Same problem is decribed here when trying to install OC 8.1.1 on an old ubuntu release : https://forum.owncloud.org/viewtopic.php?f=31&t=29915
Last edited by sksbir on Wed Dec 23, 2015 11:42 pm, edited 1 time in total.
sksbir
 
Posts: 314
Joined: Tue Aug 25, 2015 9:23 pm

Re: NAS needs SSL upgrade to get OC 8.1.1 working

Postby slekk » Sun Aug 30, 2015 9:21 pm

did you already opened a ticket at support.asustor.com, that the asustor team know about this issue?
i think asustor is responsible to update SSL, i´am right?
AS-302T 2x4TB WD RED
HDD Config: Single
using XBMC
slekk
 
Posts: 40
Joined: Sun Jan 05, 2014 10:15 pm

Re: NAS needs SSL upgrade to get OC 8.1.1 working

Postby sksbir » Tue Sep 01, 2015 2:41 pm

slekk wrote:did you already opened a ticket at support.asustor.com, that the asustor team know about this issue?
i think asustor is responsible to update SSL, i´am right?

I think so.
And yes I opened a ticket. now let's wait and see 8-)
sksbir
 
Posts: 314
Joined: Tue Aug 25, 2015 9:23 pm

Re: NAS needs SSL upgrade to get OC 8.1.1 working

Postby MikeG.6.5 » Wed Sep 02, 2015 1:19 am

This is probably tied to the Python updates Asustor did that broke so many other apps. They made some changes to the SSL stuff within Python's libraries and just plain broke things.

Let's hope they get this all fixed, soon. I'm getting SSL errors with a few other apps as well. These errors never happened until Python was updated.
MikeG.6.5
 
Posts: 910
Joined: Fri May 15, 2015 1:56 am

Re: NAS needs SSL upgrade to get OC 8.1.1 working

Postby sksbir » Wed Sep 02, 2015 3:50 pm

I have a reply from support : they ask me to uninstall and reinstall owncloud.

This is a heavy operation, and on their side, they do not try the test with "wget", although it's just a simple command to test on one of their NAS.

So I ask here other users to try it.
sksbir
 
Posts: 314
Joined: Tue Aug 25, 2015 9:23 pm

Return to ownCloud

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest