Page 1 of 1


PostPosted: Tue Mar 31, 2015 12:20 am
by sdemills
I have an existing photo library folder on my NAS that for various reasons I don't want to move, yet I would like to be able to view it on my phone using AiFoto.

So I located where AiFoto was putting the libraries created and maintained/uploaded from my phone and, over a PuTTY session as admin, I created a symlink in there to my other folder of photos.

However AiFoto doesn't see it at all.

I set the owner and group the same as the other items in AiFoto's folder but to no avail.

Can anyone suggest how I might get AiFoto to show the photos from this other folder?

In case you're wondering why AiFoto?...

I can see the folder perfectly well in ES File Explorer for example but if I want to choose a photo to download then it takes forever to get a thumbnail view whereas I reckon AiFoto will do that for me with no problem.

Please don't suggest Plex. I do use Plex. Plex would do the job. But I refuse to pay a monthly subscription just to access my own files over the air when there are other good solutions that would do it without a subscription. I don't mind paying a once-off fee for a good app, but not a subscription.

Re: AiFoto

PostPosted: Tue Mar 31, 2015 1:22 am
by Elrique64
Don't use AiFoto at all, but I would guess that the problem you could be having is with the sym-link.... Make a folder inside and copy a couple photos to it, to see if they are there.

And Plex doesn't handle photos at all well, IMO... I actually use ownCloud for viewing photos on my desktop and tablet machines. As a more than amateur photographer, (OK, I've sold some, at any rate...) :) I don't think Plex is anywhere near prime time for displaying photos. With ownCloud I can use a couple of different viewing apps, depending on need, and get the view I want, when I want it.

Re: AiFoto

PostPosted: Wed Apr 01, 2015 4:42 pm
by sdemills
Thanks for recommending OwnCloud - I had looked at that in the past and rejected it, however the new Enterprise edition looks good and I have installed it and it is definitely going to be really useful. However it doesn't solve the issue for photos...

I use a 24 mpxl camera and the average size of a photo is between 6-9 mb. So to choose a particular photo it is essential to see thumbnails. If I view an OwnCloud folder on my phone then it doesn't show photo thumbnails - instead it shows a "pretend" thumbnail that looks like a photo with a flower in it - every photo looks like that. So I still cannot choose a photo to bring across onto my phone.

My wife is delighted with OwnCloud because she always struggles with figuring out how to transfer photos from her phone onto her laptop and now they appear automatically on her laptop within about 30 secs of having taken the photo on the phone.

I wanted to set up OwnCloud so that access from our phones would use SSL but I couldn't see how to do that. There are good guides as to how to set up Internet Explorer on a Windows PC to talk SSL to the ASUSTOR NAS - but that doesn't seem to help get the phones using SSL (apart from the fact that I don't use IE at all).

So once again - thanks for recommending OwnCloud - it's a good Open Source solution well worth having.

By the way, regarding Plex - I do use Plex as my media server of choice within my home and on my smart TV where it does a great job of music, video and photos. I particularly like the way it pimps my collection with artwork and other details from the web and how it transcodes on the fly various video formats to suit my TV's capabilities. It also works well with apps like Avia to Chromecast my media to other not so smart TVs in the house. I really like Plex, I would be more than happy to pay for it (but they don't offer a purchase option) but no way would I consider the subscription route for a Plex Pass because it works out way too expensive just to access your own media whilst away from home - there are better solutions out there for that.

Re: Owncloud

PostPosted: Sun Apr 05, 2015 4:51 am
by raksabi
Hi Steve,

I don't personally know anything about AiFoto however I do believe I understand what your end goal is here. You should be able to achieve that using the following:

1. Using the ownCloud app on your phone to browse though images using thumbnails.
2. Access your ownCloud over the web or locally via SSL.

I agree that being able to sort through photos is next to impossible without thumbnails to see at a glance what a particular photo is. I've shared your frustration with the ownCloud app and the generic placeholder thumbnail, it's not very useful.

The issue with the thumbnails appears to have been resolved with the latest update of ownCloud server. I was previously using ownCloud app version 1.5.8 and ownCloud server version 7.0.4 along with PHP 5.3. After seeing your post I looked into this and have since updated my Asustor NAS with PHP 5.5.3 (Beta) and ownCloud server 8.0.2. Note that the new version of PHP will automatically be downloaded and installed on your NAS when you update ownCloud. I have also updated the app on my phone to version 1.7.0 which I believe is the latest version as of this post.

The upgrades went smoothly but took considerably longer with the PHP update on the NAS. Once complete I logged into ownCloud using my web browser and completed the update, this process was much faster. I had to change my default upload file size as it defaulted back to 51MB. I also noted under the Admin settings page that this error was being displayed: "PHP charset is not set to UTF-8. This can cause major issues with non-ASCII characters in file names. We highly recommend to change the value of ‘default_charset’ php.ini to "UTF-8". To fix this I had to locate the active php.ini file. I did this by accessing the following URL in my web browser: http://HostnameOfNAS/phpinfo.php, you can substitute the hostname for the IP of your NAS as well. The active php.ini file is located here on my NAS after updating to php 5.5: /volume1/.@plugins/AppCentral/php-5.5/etc/php5/apache2 ... I edited the file adding the following line: default_charset = "UTF-8" ... I also edited a number of other settings based on my personal preferences such as max size, max post size, memory limit, max input time, max execution time etc. All these settings are important if attempting to upload either a large number of files or very large files themselves. I then saved the file and restarted my NAS. This got rid of the warning under the Admin settings page. I still receive another warning stating "APCu below version 4.0.6 is installed, for stability and performance reasons we recommend to update to a newer APCu version." This doesn't currently appear to have a negative impact on anything and my guess is that it's related to the Beta version of PHP installed.

*** Just a note that I use WinSCP to access all the directories on my NAS for administrative purposes. If you just right-click the file in WinSCP and select edit it should open it in your default text editor. When you make the change and "Save" it should auto save it to the NAS so that you don't have to download file, edit, save, upload file, overwrite existing file. It makes for much faster editing over using a utility such as Putty. ***

Once this was complete I browsed to my photos folder in ownCloud on my phone (using the app) and thumbnails started to populate. Images are now displayed in a grid format instead of the list format. This makes browsing through images quite easy as the thumbnails are larger. The only caveat here seems to be the amount of time for the thumbnail generation to complete. It took quite a while although I did have hundreds of photos. At this point you would have two options, either move your images folder under the ownCloud data directory or make use of Symbolic links. You mentioned you didn't want to move your folder so a Symbolic link will work fine which you can point at your existing photo library on your NAS. Just create the Symbolic link under your ownCloud data account directory, for instance: /volume1/Web/owncloud/data/youraccount/files ... I've tested this and it works great. The link name is arbitrary however the shortcut should point to where your existing image library resides on your NAS. For example: /volume1/mydata/pictures

As for SSL access, if you log into ownCloud via https://webaddress/owncloud and then go to the Admin settings page you can enforce https access. At that point ownCloud will use the self-signed certificate on the Asustor NAS. You could probably install a 3rd party certificate on the NAS but I haven't tried. This would be done under Settings > General > Certificate Manager. So once SSL is enabled, whether you're accessing ownCloud locally on your LAN, publicly over the web either via web browser or your phone app it will all be SSL.


Re: Owncloud

PostPosted: Sun Apr 05, 2015 11:19 pm
by sdemills
Hi Jono, thank you very much for taking the time to write such a comprehensive response.

I had originally installed the Enterprise version of ownCloud along with the same Android App version that you mentioned above.

So I saved my data files, uninstalled the Enterprise version of ownCloud and instead installed the version 8 standard ownCloud after which I copied back the saved files.

I did have some trouble getting things to work but succeeded in the end. Some things I wasn't able to do - I can't find phpini at all so I have not been able to make the suggested changes there. That despite having run
Code: Select all
find / -iname phpini.*
as root from the root folder.

Here is what I did and how I got on...

  • I set up the admin user and 2 standard users but beneath the WEB folder structure it only created data folders for the admin user. Maybe it would create the other folders when the other users eventually log in? Anyway the folders do exist now because I fetched them from the backup files.

  • I followed the suggestion to set up the ownCloud server to use HTTPS and although everything worked ok between the laptop and the server, the Android App would not connect and neither could the Android browser (Chrome). I tried this over the same WiFi connection that the NAS and the laptop are using, and I tried it over mobile data but no joy.

  • I reconfigured the server so as to not force the clients to use HTTPS. Everything still worked between the NAS and the laptop, but still the Android App would not connect. However this time Chrome on Android would at least tell me that the connection was not coming from a trusted source and it pointed me to the config.php file where I added a couple of trusted sources being my external address for my NAS and the internal address of the NAS which for a phone needs to be its IP address rather than its name. After this change the Android App would connect, and I could also get the Android App to use SSL ok

  • Eventually I will once again force SSL but first I want to find out how to get a proper certificate as Chrome (on both laptop and phone) rejects the certificate and uses a non-secure connection - at least I'm assuming it is non-secure because it strikes through the HTTPS: part of the URL with a red diagonal line.

  • The thumbnail pictures now do appear as mentioned and they do take a long time to get set up, but afterwards they seem to be there all the time. If I had for example connected with ES File Explorer then I would have found every time I reconnect that the thumbnails would have to be rebuilt - so far ownCloud seems to keep them once it has built them

Re: Owncloud

PostPosted: Mon Apr 06, 2015 2:48 am
by raksabi
Hi Steve, you're quite welcome.

You're on the right track, just change your command slightly to be:
Code: Select all
find / -iname php.ini

If you create a Putty session to your NAS and run that command in the root you will receive 3 results.
The one you want is the first one:
Code: Select all

Not too sure what is happening regarding the SSL access, I personally haven't run into those issues.
I have a DynDNS account which is configured on my router, I have a host record (A record) set up on my account that always resolves to my public IP.
When I configure my phone I point it to...
Code: Select all

It works regardless of whether I'm inside my network on wifi or external of my network.

Self signed certificates will always generate a browser warning but should still work.
Having said that you should be able to click on "Proceed anyway" in Chrome.
It should still use the certificate and traffic should be SSL protected.
Once you enable "Enforce HTTPS" on your NAS it will only accept HTTPS traffic on port 443.
As I wrote that last line I just realized that perhaps the issue you were running into is that port 443 on your router is not forwarding to the (internal) IP of your NAS.
This is required to pass through SSL traffic.
3rd party certificates are always nice as the browser "trusts" it and gets rid of the warning.
Single root certificates are fairly inexpensive these days, around $10 or so per year.

Glad to hear that you got the thumbnails working!

Re: Owncloud

PostPosted: Tue Apr 07, 2015 6:24 pm
by sdemills
Hi Jono,

Thanks for the continued help. The SSL stuff is working now - just as you said, it puts out an initial warning but then it does actually work.

I too have a DDNS address for my server but for some reason it doesn't work whilst I'm connected to my own WIFI - I think it is something to do with how my ISP resolves addresses.

Anyway, I'm happy now because it's all working as hoped for.

I'm toying with settings up email servers now instead of using GMail's service because lately GMail has gone mad and is throwing even its own emails into Spam so I'm missing lots of important emails until I think to go and look in Spam.