It is currently Wed Apr 14, 2021 3:55 am
All times are UTC + 8 hours

aMule unstable

aMule stands for all-platform eMule file-sharing program. It is affiliated with the eMule project and was forked from xMule on 08/2003. It connects to the eDonkey2000 network, supports Linux, Mac, Solaris, *BSD platforms, and nearly every processor arch.

Moderator: MrK

aMule unstable

Postby MrK » Thu Jun 19, 2014 6:42 am

User reported problem with aMule running on AS-604T:
amule, after install, enable it... run awhile in browser, disconnect it (web).

wait a while, reconnect with password. able to connect (load the page), but the bottom part show amule is not connect to the internet. open configuration page, all show undefined

then, got to disconnect it, restart amule then only can have the data back... but awhile later,
same things happen again. got to restart the amule then only can solve the problem

I don't use aMule myself. Does anyone else experience that problem?
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: aMule unstable

Postby MrK » Sat Jun 28, 2014 10:36 pm

question from beastmst:

hai.. after a few days of trying, I think the problem is because the amuled
server crash on my asus 604...

is that a way for me to debug why it crash?
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: aMule unstable

Postby MrK » Sat Jun 28, 2014 10:41 pm

Hey beastmst,

If you're a asustor.com forum member, then post additional questions and answers to that thread (viewtopic.php?f=79&t=3734&p=11106) please.

The obvious would be to check if the amuled process is running by going to the 'Activity Monitor' > 'Process' in the ADM admin interface. The second is access the NAS using ssh and check the log file (/usr/local/AppCentral/amule/etc/logfile).
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: aMule unstable

Postby beastmst » Sun Jun 29, 2014 4:53 am

yes, i checked those files. nothing much i can find. any idea what else can i do?
beastmst
 
Posts: 3
Joined: Sat Jun 28, 2014 8:12 pm

Re: aMule unstable

Postby MrK » Sun Jun 29, 2014 3:01 pm

beastmst wrote:yes, i checked those files. nothing much i can find. any idea what else can i do?

And the amuled process does not appear in the 'Process' tab of the 'Activity Monitor' anymore? So it really is crashed?
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: aMule unstable

Postby sickboy » Sat Jul 19, 2014 4:15 pm

I am having aMule problem as well, the module crashes unexpectedly.
1. All downloads and uploads become blank when web browsing to aMule "Transfer" page.
2. aMule crashes when page refreshes, page became unreachable.
3. Disconnect from eMule server and KAD server unexpectedly, all settings in configuration page is blank.

Only way to fix is to manually restart the aMule module or restart NAS.

Is there a way to manually add eMule server to the server list?
The "Download Link" function only allow adding one Ed2K link, is it possible to make it accept batch list?

Configuration in aMule is untouched.

ADM Version: 2.2.0.R602
BIOS Version: 1.08
Model: AS-604T
Processor: Intel Atom 2.13 GHz Dual-Core Processor
Memory: 3.00 GB

Ethernet: LAN 1+2
Link Aggregation: Round-Robin

HDD: 4 X WDC WD20EFRX-68EUZN0
RAID Level: RAID 5
Total Capacity: 5.4TB
File System: EXT4
sickboy
 
Posts: 4
Joined: Sat Jul 19, 2014 3:52 pm

Re: aMule unstable

Postby beastmst » Fri Aug 01, 2014 9:07 pm

after updated the adm to 2.2.0.R6O2, the amule run a bit stable.. (still crash unexpectedly sometimes) but sometimes can run days withour crashing.

any idea what happen?
or is it better to recompile it again with the latest firmware...


thanks
syeo
beastmst
 
Posts: 3
Joined: Sat Jun 28, 2014 8:12 pm

Re: aMule unstable

Postby MrK » Sat Aug 02, 2014 5:17 am

beastmst wrote:after updated the adm to 2.2.0.R6O2, the amule run a bit stable.. (still crash unexpectedly sometimes) but sometimes can run days withour crashing.

any idea what happen?
or is it better to recompile it again with the latest firmware...

Recompiling won't do much I guess. It's probably more an issue with aMule itself. Are you familiar with the linux command line and SSH? If yes you could check the log file (/usr/local/AppCentral/amule/etc/logfile) to see if there's an clue about why it crashed.

/Thomas
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: aMule unstable

Postby beastmst » Thu Sep 10, 2015 5:36 pm

around 1 year.. still no person can fix this problem?

i notice that my amule will crash when certain download areah 99.xx percent...
i think this is something to do with the file write? or buffer write problem?


thanks
syeo
beastmst
 
Posts: 3
Joined: Sat Jun 28, 2014 8:12 pm

Re: aMule unstable

Postby badduck » Sun Nov 01, 2015 12:04 am

I am also having the same problem with Amule. I am running on AS-608T. :(
Anyone looking into this issue?

Regards,
Badduck
badduck
 
Posts: 1
Joined: Sat Oct 31, 2015 11:59 pm

Return to aMule

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest