It is currently Wed Apr 14, 2021 3:01 am
All times are UTC + 8 hours

No emule/amule?

aMule stands for all-platform eMule file-sharing program. It is affiliated with the eMule project and was forked from xMule on 08/2003. It connects to the eDonkey2000 network, supports Linux, Mac, Solaris, *BSD platforms, and nearly every processor arch.

Moderator: MrK

No emule/amule?

Postby Slime » Fri Mar 08, 2013 3:58 am

The client emule/amule will be integrated into the download center? Or reside on a separate application?
Posts: 9
Joined: Wed Mar 06, 2013 6:45 pm
Location: Italy

Re: No emule/amule?

Postby Steve@AST » Mon Mar 11, 2013 12:10 pm

Hi Slime,

We have put emule/amule in our App development roadmap, however, we are still evaluate integrate into Download Center or not.
so it's hard to provide a definite answer.


MacBook Air
iPhone 4s, New iPad, iPod nano
User avatar
Posts: 150
Joined: Tue Jun 05, 2012 4:20 pm

Re: No emule/amule?

Postby audiophile » Thu Mar 14, 2013 2:34 am

I am sure asustor will decide against emule/amule integration because of high security risk. Further emule/amule depends on a huge amount of open and half-open udp connections (ports) to the internet. this might severely restrain NAS availability and performance in the intranet...

Posts: 7
Joined: Thu Mar 07, 2013 1:51 am

Re: No emule/amule?

Postby jas2000 » Thu Jan 23, 2014 4:25 am

any news?
Posts: 2
Joined: Mon Nov 18, 2013 9:08 pm

Re: No emule/amule?

Postby MrK » Mon Mar 17, 2014 4:24 am


Created a package for aMule 2.3.1 for ASUSTOR. Maybe someone could give a try and provide some feedback?

aMule 2.3.1 for ASUSTOR AS-20xT/AS-20xTE & AS-30xT
aMule 2.3.1 for ASUSTOR AS-60xT

The password for the web interface (and for the EC interface too) is "admin", without the quotes of course. Using the aMule Remote GUI you can change the web password. Changing the EC interface password didn't work for me from the Remote GUI. There's no way to change the password using the web interface - which is really a unfortunate. Everything you find on the internet is a description how you do it manually ($ echo -n <your password here> | md5sum | cut -d' ' -f1).

The amule.conf file can be found in /usr/local/AppCentral/amule/etc and the two download directories (Temp and Incoming) are in /volume1/Download/aMule. Putting the amule.conf in the application directory seems the right place for me but makes it harder to change the file manually without accessing the NAS using SSH. But putting amule.conf into /volume1/Download/aMule is risky too since people may delete that folder too easy.

Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: No emule/amule?

Postby bouman4 » Mon Dec 19, 2016 11:36 pm

the program is unstable. is regularly away.
it is possible to make zoekken advanced search by zip rar jpg avi etc.
Posts: 1
Joined: Mon Dec 19, 2016 11:31 pm

Re: No emule/amule?

Postby Max36 » Thu Nov 09, 2017 7:27 am

Thank you MrK! The program works fine for me and quite stable.

The problem with changing password for Remote GUI has been solved a bit easier. Using Remote GUI I've changed password for WEB interface and just copied the data from WEBPassword field to ECPassword field in the amule.conf file. It works.

Any plans /ideas about update to the 2.3.2 version? As far as 2.3.1 is "a bit" :) outdated?

Thank you,
Posts: 16
Joined: Tue Mar 03, 2015 3:52 am

Re: No emule/amule?

Postby pyliu » Mon Sep 10, 2018 10:16 pm

aMule 2.3.1 for ASUSTOR AS-20xT/AS-20xTE & AS-30xT
the link is dead ... :(
Could somebody make a new one for my poor AS-202TE system?
Posts: 4
Joined: Mon Sep 10, 2018 10:08 pm

Re: No emule/amule?

Postby pyliu » Wed Sep 12, 2018 3:08 pm

found on github ...
I tried to copy whole source to my AS-202te and executed the build script from there.
After fixed lib-i386 soft link issues, I got the worked apk out.
I am glad to have aMule back on my old AS2 NAS. :D
Here is the aMule 2.3.2 for ASUSTOR AS-20xT/AS-20xTE & AS-30xT

I found that 2.3.2 has problem in searching content, the result count is much less than 2.3.1-r4 version (especially for CJK).
I put the aMule 2.3.1-r4 for ASUSTOR AS-20xT/AS-20xTE & AS-30xT here once someone might want to try.
Last edited by pyliu on Fri Sep 14, 2018 10:17 am, edited 2 times in total.
Posts: 4
Joined: Mon Sep 10, 2018 10:08 pm

Re: No emule/amule?

Postby Max36 » Thu Sep 13, 2018 6:47 am

Pyliu, great news! Believe many owners of AS2 series will be thankful for you! In order to avoid the problem with dead links you may want to place the build in the Asustor Developer Center. This way it should be published for all in App Central.

I would like to test it, but not sure if i386 version will be compatible with x64 AS62 series. May be some ideas about how to make x64 version? :)
Posts: 16
Joined: Tue Mar 03, 2015 3:52 am


Return to aMule

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest