Page 2 of 4

Re: aiMusic won't scan entire library

PostPosted: Fri Jun 27, 2014 4:46 pm
by finurliig
Disappointment: after todays update of ADM and an update of the soundsgood app I tried to rescan the music library, but it was no use: stil, less than half of my music files gets scanned. :cry:

Thanks for the tip on the logitech media server. Think I'll go for that instead.....

Re: aiMusic won't scan entire library

PostPosted: Fri Jun 27, 2014 5:42 pm
by finurliig
I appears that the logitech media server has vanished from the download page within ADM? Is the because of the update of ADM?

Re: aiMusic won't scan entire library

PostPosted: Mon Jun 30, 2014 12:14 pm
by orion
finurliig wrote:I appears that the logitech media server has vanished from the download page within ADM? Is the because of the update of ADM?

You can find it in Beta Apps.

Re: aiMusic won't scan entire library

PostPosted: Mon Jul 14, 2014 3:06 pm
by finurliig
Thank you Orion: I have been trying out LMS for a couple of days, and it works like a charm :D

I'm using squeezePlayer and orange Squeeze as a player on my (android) phone and tablets and I've never seen anything better.

Originally I intended to use Plex media player for streaming, bur the android app seems to be poorly put together:

*First of all, the server app on the nas routinely gives out and needs to be rebooted at least once a day.
*Second, playback randomly stops and the server diasappears from the list. I can rarely play an entire album without it happening.
*Thirdly, when in folder view, the android client app truncates the folder names, o it's impossible to see whats in ech folder...?

In short: plex is, unfortunately, crap.

Logitech media server has , as far as I can see, none of these shortcomings, and works perfectly. Problem solved. Me happy! :D

Re: aiMusic won't scan entire library

PostPosted: Mon Aug 04, 2014 4:47 pm
by dhstsw
Same problem here.

I had little time to investigate but it seems to me that Soundsgood has some problems with folder/file names containing the

"&" character.

Re: aiMusic won't scan entire library

PostPosted: Mon Aug 04, 2014 6:08 pm
by dhstsw
It's the "&" character indeed.

To "fix" the unscanned mp3s, until Asustor fixes Soundsgood you can do this:

(with Soundsgood active):

-check the unscanned folder for the "&" char both in folders and files.
-remove it from every instance (put, for example, a 'and' instead).
-move the entire folder *outside* the monitored partition (/Music).
-move again the entire folder *inside* the monitored partition (/Music).
-Give it some minutes and the missing folder should show up.

d.

Re: aiMusic won't scan entire library

PostPosted: Thu Sep 04, 2014 5:13 pm
by higherdemon
Now that is known what the problem I hope for a fix. I have hundreds of files with the & character...

Re: SoundsGood won't scan entire library

PostPosted: Wed Dec 17, 2014 10:29 am
by louis077
I have the same problem with my 400GB library. I'm going to give logitech a run.

-----------------EDIT-----------------------

miniDLNA app in beta works great. I would recommend this to anyone having trouble. Give the NAS a quick reboot and you are good to go.

Re: SoundsGood won't scan entire library

PostPosted: Thu Dec 18, 2014 10:38 pm
by dhstsw
In my case, after the last update, it simply stops again to index the mp3 (the "&" trick doens't work anymore) but, in exchange, it keeps on trying so i have my HDDs in perpetual spinning.....

Now, how much time asustor is aware of the indexing problem?

Re: SoundsGood won't scan entire library

PostPosted: Mon Dec 22, 2014 7:19 pm
by dhstsw
Ok, found what the latest bug is:

last version of soundgood can't index files nested in more deep levels of folder.

Example:

my collection is organized as:

Code: Select all
Music/
        /Artists/
                   /name of the artist/
                                               /album


If i have files in the 'name of the artist' level it gets indexed. If the file is in the album level it doesn't.
But Soundsgood *tries* to index it (without managing), since the disk are contantly spinning, unless i turn SG off.