It is currently Sat Apr 17, 2021 12:50 am
All times are UTC + 8 hours

(SOLVED) Read-only folders

NZBGet is a cross-platform binary newsgrabber for nzb files, written in C . It supports client/server mode, automatic par-check/-repair and web-interface. NZBGet requires low system resources and runs great on routers, NAS-devices and media players. Includes nzbToMedia postprocess scripts.

Moderator: clinton.hall

(SOLVED) Read-only folders

Postby Duzii » Wed Jul 22, 2015 5:53 pm


I am not sure if this is the correct place to post this.

When a download is finished the extracted folder is read-only. I am using Kodi and the add-on Artwork downloader, this add-on is unable to download any art-work to the folder containing the video since the folder is read-only. When I change the permissions of the folder to R/W the add-on works without a problem.

Is there a setting in NZBGet to make the folder R/W automatically? Or maybe a setting in the NAS settings?
Posts: 17
Joined: Wed Feb 05, 2014 4:54 am

Re: Read-only folders

Postby clinton.hall » Mon Jul 27, 2015 6:58 pm

I think this should be changed by the umask setting in nzbget.
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me:
User avatar
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Read-only folders

Postby Duzii » Tue Jul 28, 2015 7:54 pm

Hi Clinton,

I changed the Umask value to 0 and that seems to have solved the problem. Thank you
Posts: 17
Joined: Wed Feb 05, 2014 4:54 am

Return to NZBGet

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest