It is currently Sat Apr 17, 2021 1:17 am
All times are UTC + 8 hours

python2 not found

NZBGet is a cross-platform binary newsgrabber for nzb files, written in C . It supports client/server mode, automatic par-check/-repair and web-interface. NZBGet requires low system resources and runs great on routers, NAS-devices and media players. Includes nzbToMedia postprocess scripts.

Moderator: clinton.hall

python2 not found

Postby ho66es » Tue Jul 01, 2014 5:20 am

After update to latest release of ADM I noticed that downloaded shows didn't make it in to sickbeard, a look at logs showed what appeared to be a python issue

Code: Select all
DeleteSamples: env: can't execute 'python2': No such file or directory
Code: Select all

I looked for python 2 but unable to find it, I tried changing the first line of the relevant scripts from

Code: Select all
#!/usr/bin/env python2


Code: Select all
#!/usr/bin/env python

re processed from nzbget and it all worked fine. So I guess something got broken in the update in respect of pythons, should I try uninstall and reinstall, or is there something I could simply link or edit?
Posts: 476
Joined: Wed Mar 13, 2013 5:38 am

Re: python2 not found

Postby clinton.hall » Tue Jul 01, 2014 5:57 am

No.. The change was in my nzbToMedia scripts.... These changed from python to python2 since many other systems are coming with python default being python3.
This only impacts the dev branch of my scripts and not the master... I have submitted an nzbget (and SABnzbd) app update to app Central. These both link python2 to python2.7 (usually all should exist, python, python2 and python2.7).

Anyway, next update should fix it... I'll try and post the link here shortly so that you can manually install. I was hoping to have the update out before I merged my scripts to master.... But clearly you are running dev ;)
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me:
User avatar
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: python2 not found

Postby ho66es » Tue Jul 01, 2014 6:20 am

no probs, its working again for now :)
Posts: 476
Joined: Wed Mar 13, 2013 5:38 am

Return to NZBGet

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest