It is currently Thu Oct 18, 2018 7:30 pm
All times are UTC + 8 hours

[APKG] NZBGet

NZBGet is a cross-platform binary newsgrabber for nzb files, written in C . It supports client/server mode, automatic par-check/-repair and web-interface. NZBGet requires low system resources and runs great on routers, NAS-devices and media players. Includes nzbToMedia postprocess scripts.

Moderator: clinton.hall

Re: [APKG] NZBGet

Postby clinton.hall » Thu Jul 31, 2014 12:52 pm

latest version can be downloaded here https://www.dropbox.com/s/xlps8mgm0khoopm/nzbget_20140731_any.apk

this includes a patched libpar2 to allow new features in nzbget 14 (testing).

It has been submitted to AppCentral, but if you are on testing branch you need to update now.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: [APKG] NZBGet

Postby clinton.hall » Fri Apr 03, 2015 11:25 am

Hi All,

between ADM2.4 and a python update, you may find that nzbToMedia is no longer working when called from NZBGet.

It appears python has issues calling the libssl and libcrypto libraries that I have supplied with the nzbget App, but happily calls the ones found in /usr/lib

So, to get around this on 64 bit system rename or delete
/usr/local/AppCentral/nzbget/repository/lib/libssl.so.1.0.0
/usr/local/AppCentral/nzbget/repository/lib/libcrypto.so.1.0.0

on 32 bit rename or delete
/usr/local/AppCentral/nzbget/repository-32/lib/libssl.so.1.0.0
/usr/local/AppCentral/nzbget/repository-32/lib/libcrypto.so.1.0.0

Once you do this nzbget should still work, but on startup it may give warning about unable to find versions of libs. I don't know if ssl is broken by doing this...

I am hoping to recompile the nzbget binaries to force the path that is searched, and then remove the export of LD_LIBRARY_PATH so that python/post scripts can use the native libraries.

there is some work involved, so please let me know if A: you have this issue and B: renaming/removing these files works for you.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: [APKG] NZBGet

Postby ho66es » Fri Apr 03, 2015 5:10 pm

I have noticed a load of failed nzb to sick rage, curiously when i re post process from web interface they work fine, its only when it happens in background (overnight) it appears to fail. will try your fix

clinton.hall wrote:Hi All,

between ADM2.4 and a python update, you may find that nzbToMedia is no longer working when called from NZBGet.

It appears python has issues calling the libssl and libcrypto libraries that I have supplied with the nzbget App, but happily calls the ones found in /usr/lib

So, to get around this on 64 bit system rename or delete
/usr/local/AppCentral/nzbget/repository/lib/libssl.so.1.0.0
/usr/local/AppCentral/nzbget/repository/lib/libcrypto.so.1.0.0

on 32 bit rename or delete
/usr/local/AppCentral/nzbget/repository-32/lib/libssl.so.1.0.0
/usr/local/AppCentral/nzbget/repository-32/lib/libcrypto.so.1.0.0

Once you do this nzbget should still work, but on startup it may give warning about unable to find versions of libs. I don't know if ssl is broken by doing this...

I am hoping to recompile the nzbget binaries to force the path that is searched, and then remove the export of LD_LIBRARY_PATH so that python/post scripts can use the native libraries.

there is some work involved, so please let me know if A: you have this issue and B: renaming/removing these files works for you.
608t
ho66es
 
Posts: 475
Joined: Wed Mar 13, 2013 5:38 am

Re: [APKG] NZBGet

Postby ho66es » Sat Apr 04, 2015 4:44 pm

same failure occured overnight after renaming files
608t
ho66es
 
Posts: 475
Joined: Wed Mar 13, 2013 5:38 am

Re: [APKG] NZBGet

Postby clinton.hall » Sun Apr 05, 2015 4:58 am

Interesting. For me, the postprocess would not work at all (when doing post-process again)

Please check your nzbToMedia.log to see just what is happening overnight.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: [APKG] NZBGet

Postby gibxxi » Mon Apr 27, 2015 10:12 am

I've seen many indicators that SSL isn't included in the Python 2.7 branch that Asustor are providing. One of which being a complete lack of urllib3. I must admit I didn't do much digging, but any references to this module from within the python CLI return with "module not found" so something in the Asustor package is not working to my mind. I gave up on NZBGet due to the myriad of python errors/NZBGet messages being generated per job (over 1000). Will revisit it when Asustor fix their distribution or a solution is found. For now, SABnzbd will suffice for me.
___ GibsonXXI ___
"Si vis pacem para bellum!"

NAS1: Asustor AS5104T | NAS2: Infrant Repertoire U4 (Modified)
User avatar
gibxxi
 
Posts: 85
Joined: Tue Mar 31, 2015 2:59 am

Re: [APKG] NZBGet

Postby clinton.hall » Tue Apr 28, 2015 7:39 pm

NZBGet doesn't use Python. only the postprocess scripts (which are all user configurable and can be enabled and disabled as needed) use python.

Also, there are setting to change the logging levels for NZBGet.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: [APKG] NZBGet

Postby gibxxi » Wed Apr 29, 2015 4:42 pm

Your right, I must be thinking of something else on this NAS that doesn't work as expected. Silly me. SSL in Python on Asustor's Linux distribution definitely does have issues though.
___ GibsonXXI ___
"Si vis pacem para bellum!"

NAS1: Asustor AS5104T | NAS2: Infrant Repertoire U4 (Modified)
User avatar
gibxxi
 
Posts: 85
Joined: Tue Mar 31, 2015 2:59 am

Re: [APKG] NZBGet

Postby clinton.hall » Sun May 10, 2015 3:56 pm

Hi All,

new version to test.

https://www.dropbox.com/s/nagxhgmv5z3mukn/nzbget_20150510_any.apk

This actually uses the new official compiled binaries from NZBGet's author. This allows updating from within NZBGet's webui, starting with the current V15 testing (and then v15 stable when this is released).

I have also (hopefully) fixed the python library dependency issues and I have included the ffmpeg binaries as part of the app (makes it larger) so that we are not dependent on external urls that tend to change.

Please let me know your results.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: [APKG] NZBGet

Postby rk06 » Thu May 28, 2015 7:08 pm

Clinton thanks for the hard work. The update resolves the post process errors me!
rk06
 
Posts: 1
Joined: Thu May 28, 2015 7:03 pm

PreviousNext

Return to NZBGet

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest