It is currently Thu Dec 03, 2020 4:09 pm
All times are UTC + 8 hours

Connection refused II

Subsonic is a free, web-based media streamer, providing ubiquitous access to your music. Use it to share your music with friends, or to listen to your own music while at work. You can stream to multiple players simultaneously, for instance to one player in your kitchen and another in your living room.

Moderators: JohnnyFive, clinton.hall

Connection refused II

Postby ketebarbo » Fri Sep 25, 2015 9:52 pm

Since bobby_lights thread is closed I would like to reopen the same subject, because I practically am having the same problem. Every now and then, maybe twice a month, I try to connect to my subsonic installed in my asustor, but i get "connection error". I does'nt matter if it is a local or external attempt. What I then do is disable the subsonic app in the NAS, restart the NAS, and enable the subsonic app. After a couple of minutes I can connect again.
I have dynamic ip, but my router provides me with ddns. I have set up a portforward correctly, as far as I am concerned, including static-ip for the NAS. This is recurring problem.

What am I doing wrong, and what can I do to avoid getting disconnected from my subsonic server?

I would really appreciate help.
ketebarbo
 
Posts: 3
Joined: Fri Sep 25, 2015 9:28 pm

Re: Connection refused II

Postby gibxxi » Wed Nov 11, 2015 3:13 pm

Don't rely on the uPnP functionality built into your router or Subsonic too heavily. Both can and will fail on you when you least expect it, and usually when it's most inconvenient.

Use port forwarding if your having issues and turn off NAT-PMP support in Subsonic once the port(s) are setup in your router. My old router (Netgear DGN3500) Experienced this issue quite often, where it would simply stop forwarding uPnP traffic resulting in the same issue your experiencing. If your router supports it, you can try upping the 'Time To Live' and 'Hops' settings of uPnP, but if that fails, manual port-forwarding will likely be the only answer until a firmware update (or a new router) solves the issue.
___ GibsonXXI ___
"Si vis pacem para bellum!"

NAS1: Asustor AS5104T | NAS2: Infrant Repertoire U4 (Modified)
User avatar
gibxxi
 
Posts: 85
Joined: Tue Mar 31, 2015 2:59 am

Re: Connection refused II

Postby clinton.hall » Sun Nov 29, 2015 6:31 pm

Are there any logs for subsonic?
It sounds as though the subsonic app is hanging and needs to be restarted.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Connection refused II

Postby damien599901 » Fri Dec 04, 2015 3:52 pm

clinton.hall wrote:Are there any logs for subsonic?
It sounds as though the subsonic app is hanging and needs to be restarted.


Hi Clinton

could you update please this great app => 5.3?

have a great day ;)
Storage: AS7004T & AS5002T
Network: FREEBOX REVOLUTION V6
Laptop: Apple MACBOOK Pro OS X El Capitan & Windows 10
Media Player: ASUSTOR NAS with Kodi 16 Beta & HD_Engine 1 (thanks Fathe_Mande)
Portable: iPhone 6S Plus, iPad Mini 2 & iPad Air
damien599901
 
Posts: 558
Joined: Mon Dec 30, 2013 2:53 am

Return to Subsonic

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron