It is currently Tue Dec 01, 2020 9:58 pm
All times are UTC + 8 hours

Local player failure

Logitech Media Server (formerly SlimServer, SqueezeCenter and Squeezebox Server) is a streaming audio server supported by Logitech (formerly Slim Devices), developed in particular to support their Squeezebox range of digital audio receivers.The software is designed for streaming music over a network, allowing users to play their music collections from virtually anywhere there is an Internet connection.

Moderators: JohnnyFive, clinton.hall

Local player failure

Postby koymoy » Tue Mar 18, 2014 3:41 am

hi,

first of all, thx for making it possible at all to use LMS on NAS - incl. the local player. The problem i have, is that i have to disable/re-enable the app, after every bootup (night standby) to make the local player accessible. Any ideas? could there be some other app conflicting?

br.

Christian
koymoy
 
Posts: 77
Joined: Tue Sep 10, 2013 5:51 am

Re: Local player failure

Postby clinton.hall » Tue Mar 18, 2014 6:43 pm

I think any other App that has hdmi (so the portal, xbmc, boxee, soundsgood) will conflict...

I need to make a lot of changes to this if I can find some time...
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Local player failure

Postby koymoy » Tue Mar 18, 2014 8:14 pm

clinton.hall wrote:I think any other App that has hdmi (so the portal, xbmc, boxee, soundsgood) will conflict...

I need to make a lot of changes to this if I can find some time...


OK, THX for the reply - no rush :-)

But, maybe i should try and disable all the apps that potentially måle ude of HDMI? Or is LMS depending om media mode being enabled or some og the beforementioned apps? (I don't use HDMI on the nas, as i think the xbmc experience is horrible compared to my HTPC :-)

Update:
Disabling apps didn't work.

BR.
Christian
koymoy
 
Posts: 77
Joined: Tue Sep 10, 2013 5:51 am

Re: Local player failure

Postby koymoy » Wed Apr 02, 2014 2:59 am

Hi again,

was just thinking (and please take in to consideration, that i'm not a coder or anything ;-) would it be easier to have seperate player app, that was not running "internally" in LMS server? or is this already the case? it seems to me that there is several player edition out there for ie. Rpi - picoreplayer, squeezlite, squeezeslave.

just a thought - and thx for the effort anyways ;-)

BR.
Christian
koymoy
 
Posts: 77
Joined: Tue Sep 10, 2013 5:51 am

Re: Local player failure

Postby clinton.hall » Wed Apr 02, 2014 6:19 am

This may be what happens... I'll have to see if I can do this and still get implemented to be controlled with into LMS web UI.... Not sure when I'll find time to look at this....
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Local player failure

Postby Hooky » Thu Apr 03, 2014 1:13 am

Hi Christian,

Have you tried installing the Local Player plugin over the top? My squeezelite starts up ok each time, but I cant play mp3's unfortunately!

Just wondering if you'd tried it, and if so how you got on.

Cheers, H
Hooky
 
Posts: 45
Joined: Thu Oct 03, 2013 10:04 pm

Re: Local player failure

Postby koymoy » Thu Apr 03, 2014 1:59 am

Hooky wrote:Hi Christian,

Have you tried installing the Local Player plugin over the top? My squeezelite starts up ok each time, but I cant play mp3's unfortunately!

Just wondering if you'd tried it, and if so how you got on.

Cheers, H


Hi,

No, haven't tried that approach and don't exactly know how to go about it :) i have just tried installing Clintons work.

Right now i am running lms on the nas and using My rpi as Client, running picoreplayer. This setup works very well.
I only regret that i don't posses the neccessary skills to be of any real help - besides "complaining" :-D

but how do you install it seperately on top of lms?

Br.
Christian
koymoy
 
Posts: 77
Joined: Tue Sep 10, 2013 5:51 am

Re: Local player failure

Postby Hooky » Thu Apr 03, 2014 3:05 am

Sounds like a good setup, lms is great isn't it!? You can have a whole multi-room audio system for the price of a few RPi's! I use jogglers myself, and I think it would be great to use the NAS as an player too.

By that i just mean install Local Player as a plugin from within LMS web gui, from the third party plugins list. However, i'm not sure I'd recommend trying it as it might break what's already working for you! In which case you'd probably have to reinstall LMS and set it up again.

I'll be looking at it again soon, and if i have any breakthroughs i'll let you know, post up if you get things working too!
Hooky
 
Posts: 45
Joined: Thu Oct 03, 2013 10:04 pm

Re: Local player failure

Postby clinton.hall » Thu Apr 03, 2014 11:14 am

installing local player plugin over the top may work for 2 and 3 series, but will not work for 6 series.

the entire LMS is running in a virtual environment that is 32 bit. So when installing the plugin it always gets the 32 bit version, but as the plugins are not launched in the virtual environment, this plugin will not run in the 64 bit environment.

Also, since it doesn't run in the virtual environment, it requires all the necessary resources to be installed in your main OS.... this is where things get fun.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 839
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Local player failure

Postby Hooky » Fri Apr 04, 2014 5:59 am

Ah, I'm beginning to understand a little better now, thanks for the explanation.

So by 'resources' do you mean only the libraries or other stuff too, and is it then the case that the NAS is too locked down to be able to add these libraries outside of the virtual environment?
Hooky
 
Posts: 45
Joined: Thu Oct 03, 2013 10:04 pm

Next

Return to Logitech Media Server (Beta)

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest