It is currently Wed Jan 16, 2019 9:25 am
All times are UTC + 8 hours

Stop working after python upgrade

Sick Beard is a PVR for newsgroup users (with limited torrent support). It watches for new episodes of your favorite shows and when they are posted it downloads them, sorts and renames them, and optionally generates metadata for them. It currently supports NZBs.org, NZBMatrix, NZBs'R'Us, Newzbin, Womble's Index, NZB.su, TVTorrents and EZRSS and retrieves show information from theTVDB.com and TVRage.com.

Moderators: JohnnyFive, clinton.hall

Re: Stop working after python upgrade

Postby marped01 » Wed Aug 19, 2015 6:38 pm

Oh boy... shoulda learned my lesson by now, dont update anything on this nas without first reading forums :cry:
AS-604T
2 GB Corsair RAM
4 x WD40EFRX-68WT0N0(WD RED 4TB) in Raid5
marped01
 
Posts: 22
Joined: Thu Jun 19, 2014 10:55 pm

Re: Stop working after python upgrade

Postby nullPointer » Wed Aug 19, 2015 7:31 pm

You can get the old packages from http://appdownload.asustor.com/

I tried infinityzx's as well, but he's working on an x64 box, and i'm on i386, so needed a different package

I downloaded the right package, modified it to look like a newer version like Infinity did; backed up my Sab + SB configs, then uninstalled python, manual-install the old package, and then re-installed SB

After copying back my config, everything is working now
nullPointer
 
Posts: 2
Joined: Wed Jul 22, 2015 12:26 am

Re: Stop working after python upgrade

Postby clinton.hall » Wed Aug 19, 2015 8:28 pm

Ok... here is a "fix" for the (x86_64 systems) but please try at your own risk... This works for me to get SickRage working...

Download _ssl.so (a new version I just compiled) from here https://www.dropbox.com/s/uhzp2tun7w7gio9/_ssl.so

Then rename/backup the existing version from /volume1/.@plugins/AppCentral/python/lib/python2.7/lib-dynload/_ssl.so
and replace it with the new version from the link above.

Use ssh, or win scp to do this.

Please let me know if you have any further issues...
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Stop working after python upgrade

Postby clinton.hall » Wed Aug 19, 2015 8:35 pm

And Asustor has heard... a new version is on the way. Just going through some testing now :)
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Stop working after python upgrade

Postby TBIce » Wed Aug 19, 2015 10:11 pm

clinton.hall wrote:And Asustor has heard... a new version is on the way. Just going through some testing now :)


Nice information

Thx

Ice ouT
TBIce
 
Posts: 3
Joined: Wed Aug 19, 2015 4:52 pm

Re: Stop working after python upgrade

Postby Jhinta » Fri Aug 21, 2015 12:27 am

clinton.hall wrote:Ok... here is a "fix" for the (x86_64 systems) but please try at your own risk... This works for me to get SickRage working...

Download _ssl.so (a new version I just compiled) from here https://www.dropbox.com/s/uhzp2tun7w7gio9/_ssl.so

Then rename/backup the existing version from /volume1/.@plugins/AppCentral/python/lib/python2.7/lib-dynload/_ssl.so
and replace it with the new version from the link above.

Use ssh, or win scp to do this.

Please let me know if you have any further issues...


tnx system is up again
Jhinta
 
Posts: 38
Joined: Tue May 19, 2015 11:43 pm

Re: Stop working after python upgrade

Postby TBIce » Fri Aug 21, 2015 3:01 am

clinton.hall wrote:Ok... here is a "fix" for the (x86_64 systems) but please try at your own risk... This works for me to get SickRage working...

Download _ssl.so (a new version I just compiled) from here https://www.dropbox.com/s/uhzp2tun7w7gio9/_ssl.so

Then rename/backup the existing version from /volume1/.@plugins/AppCentral/python/lib/python2.7/lib-dynload/_ssl.so
and replace it with the new version from the link above.

Use ssh, or win scp to do this.

Please let me know if you have any further issues...



It did not fix the problem with deluge :(

Ice ouT
TBIce
 
Posts: 3
Joined: Wed Aug 19, 2015 4:52 pm

Re: Stop working after python upgrade

Postby scottnzuk » Fri Aug 21, 2015 4:40 pm

marped01 wrote:Oh boy... shoulda learned my lesson by now, dont update anything on this nas without first reading forums :cry:


Hear hear!

Thanks to Clinton for yet again another fix :ugeek: Thank you!! :ugeek:

I do wonder if ASUSTOR actually test any apps when roll out an update.. :?:

check out Clinton forum profile for his website
scottnzuk
 
Posts: 13
Joined: Sat Jul 12, 2014 4:29 am

Re: Stop working after python upgrade

Postby clinton.hall » Fri Aug 21, 2015 7:31 pm

To Be fair, Asustor do test apps... (most of mine take a while to get released as they need to be tested and I am asked to verify several issues before release).

In the forums there is a lot of "there is a new version, where is it?" so Asustor do cop some flack if they don't update... and testing very function of every App is not that easy...

I will say that I am happy to see Python 2.7.10 given that other NASs are still running 2.7.3 etc...

From my side, I will try and do what I can, with what time I have, to support the community... Ultimately, as soon as Python 2.7.10r10 is released, this should ix these issues.

Any issues discovered, not fixed by my ssl patch above, please report and I'll try and test to confirm in python 2.7.10r10 will fix.
AS-604T
3 x ST4000DM0000 (Seagate 4TB) in Raid5
2 GB RAM expansion
AS-302T

Apps (user)
NZBGet - CouchPotato - SickBeard - Git - Python

Apps (maintainer):
NZBGet - BitTorrent Sync - Mylar - LazyLibrarian - Gamez
-Maintenance of Apps acquired from JohhnyFive since ADM2.0:
SABnzbd - CouchPotato - SickBeard - HeadPhones - Subsonic

About Me: http://fockwulf.wix.com/index
User avatar
clinton.hall
 
Posts: 831
Joined: Thu May 09, 2013 7:01 pm
Location: New Zealand

Re: Stop working after python upgrade

Postby MikeG.6.5 » Sat Aug 22, 2015 5:39 am

Ok, as far as I know not listed or mentioned in the forums, or in App Central, there is a new update to Python. It not only fixes the issue with SickBeard, but also gets the conversion scripts I had working again.

Link to it here:

64-bit: http://appdownload.asustor.com/0010_999 ... x86-64.apk

32-bit: http://appdownload.asustor.com/0010_999 ... 0_i386.apk

If you haven't seen it in App Central, you can grab it from those links and do a manual update via App Central.
MikeG.6.5
 
Posts: 910
Joined: Fri May 15, 2015 1:56 am

PreviousNext

Return to SickBeard

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron