Page 1 of 1

SABnzbplus error when upgrading

PostPosted: Wed Mar 30, 2016 3:06 pm
by Stik
Hi,
SABnzb plus attempts to upgrade during startup but fails leaving 0.8Beta6 installed.
The following is the log file generated at startup.
it seems to say that it was successful even after the errors but it isn't.

Any advise?

Thanks


Code: Select all
Performing SABnzbdplus prestartup checks at Wed Mar 30 17:30:07 CST 2016...
 Creating Symbolic links for required utils... Done
Done
Checking for a new version...
 Downloading online version file... Done
 Reading file... Done
 Determine current (installed) version... 0.8.0Beta6 (80046)
 Determine stable release... 1.0.0 (1000099)
 ALL_RELEASES tag found, also checking unstable branch...
 No unstable release available... skipping
 Checking which is newest... Stable, upgrading
Upgrading SAB remotely...gzip: invalid magic
/bin/tar: Child returned status 1
/bin/tar: Error is not recoverable: exiting now
./etc/script/apkg_script_ldr.sh: cd: line 486: can't cd to SABnzbd-1.0.0
.. Done
APKG SABnzbdplus has been upgraded from: 0.8.0Beta6 to 1.0.0
Starting SABnzbplus once, in compile mode... Done
 Checking if all configured directories exist........HEAD is now at c50957d V10.14 ready for merge
Already up-to-date.
 Done
Starting SABnzbdplus Done (Wed Mar 30 17:30:22 CST 2016)

Re: SABnzbplus error when upgrading

PostPosted: Wed Mar 30, 2016 8:06 pm
by clinton.hall
I have an updated package in review. This uses git and installs from the latest repository.
Try a manual install https://www.dropbox.com/s/57dgs79jwlktpor/sabnzbdplus_20160320_any.apk

Re: SABnzbplus error when upgrading

PostPosted: Thu Mar 31, 2016 12:41 pm
by Stik
Thanks that installed ok,

the version now says "0.8.x [unknown]" I assume that is correct.

Thanks for your work in maintaining these apps


EDIT: Just noticed that it now says "1.1.x [unknown]" so it must be doing something in the background

Re: SABnzbplus error when upgrading

PostPosted: Sat Apr 16, 2016 10:52 am
by Elusivity
Clinton, I realise you've got a life and maintain a whole heap of apps for us, other apps for other platforms and your nzb to media scripts for various platforms, but is your beta going to be promoted to full release anytime soon? Not too fussed as the existing version works, more interested in how much beta testing is done before release?

Re: SABnzbplus error when upgrading

PostPosted: Mon May 30, 2016 7:40 pm
by clinton.hall
sorry for the delay.
This should be released in App Central. It is tested by Asustor before being accepted. I also release in forums first to get initial feedback before submitting to Asustor.