It is currently Tue Mar 09, 2021 4:07 pm
All times are UTC + 8 hours

[SOLVED] Fresh install failed with last Entware (use by Clinton Hall)

SABnzbd makes Usenet as simple and streamlined as possible by automating everything we can. All you have to do is add an .nzb. SABnzbd takes over from there, where it will be automatically downloaded, verified, repaired, extracted and filed away with zero human interaction.

Moderators: JohnnyFive, clinton.hall

[SOLVED] Fresh install failed with last Entware (use by Clinton Hall)

Postby father.mande » Tue Jan 05, 2021 11:02 pm

Hi,

Some APKG use Entware packages (2500+ packages) to build their own solution
SABnzbplus ... use Python(3) from Entware

If your new installation failed ... one possible reason is that Python3 can't be installed when Python2 (Entware) is already installed (Know bug by Entware team https://github.com/Entware/Entware/issues/582 )
The error is : symlink /opt/bin/python already exist if python2 is installed

Solution from Entware team
... 1 uninstall Python2 (official APKG is at same level) ... best solution to avoid any misunderstanding in the future.
... 2 change python3 install by adding --force-overwrite (but it's the SABnzbplus integrator that have to do it in start-stop.sh script)

Workaround (by me)
... 1 remove /opt/bin/python ... so Python3 can be installed .... BUT python2 is now only available using python2 or python2.7 symlink (even an alias can be used if it's interactive)

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1108
Joined: Sat Sep 12, 2015 2:55 am

Return to SABnzbdplus

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest