It is currently Tue Dec 01, 2020 11:34 pm
All times are UTC + 8 hours

sabnzbdplus without docker (Clinton.Hall)

SABnzbd makes Usenet as simple and streamlined as possible by automating everything we can. All you have to do is add an .nzb. SABnzbd takes over from there, where it will be automatically downloaded, verified, repaired, extracted and filed away with zero human interaction.

Moderators: JohnnyFive, clinton.hall

sabnzbdplus without docker (Clinton.Hall)

Postby earthwalkerx » Thu Sep 24, 2020 12:17 am

Hi,
I update sabnzbdplus without docker - 20200909 (Clinton.Hall) know I can start it (was not possible after last ADM update - 3.5.1.R8C1.
But now I get these errors:
Code: Select all
Essential modules are missing, downloading cannot start.
unrar binary... NOT found
par2 binary... NOT found!
SABYenc module... NOT found! Expecting v4.0.0 - https://sabnzbd.org/sabyenc
[N/A] The command in build_command is undefined.


:shock:
earthwalkerx
 
Posts: 23
Joined: Sat May 21, 2016 6:38 am

Re: sabnzbdplus without docker (Clinton.Hall)

Postby adrenalinenz » Thu Sep 24, 2020 6:29 am

I have the same issue, I restarted the app and unrar binary and par2 binary are now found, but I still get SABYenc module... NOT found! Expecting v4.0.0 - https://sabnzbd.org/sabyenc error.

I have version sabyenc-3.3.6 installed, cannot install a version 4.0.0 at all:

root@NAS1:/volume1/.@root # pip install sabyenc==4.0.0
ERROR: Could not find a version that satisfies the requirement sabyenc==4.0.0 (from versions: 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.4.0, 2.4.1, 2.4.2, 2.5.0, 2.5.1, 2.6.2, 2.6.3, 2.6.4, 2.7.0, 2.8.0, 3.0.0, 3.0.2, 3.1.1, 3.3.0, 3.3.1, 3.3.2,3.3.3, 3.3.4, 3.3.5, 3.3.6)
ERROR: No matching distribution found for sabyenc==4.0.0

When starting sabnzb I can see it detects the version.

Requirement already satisfied: sabyenc3>=4.0.0 in /volume1/.@plugins/AppCentral/sabnzbdplus/env/lib/python3.8/site-packages (from -r requirements.txt (line 1)) (4.0.2)
adrenalinenz
 
Posts: 8
Joined: Mon Feb 05, 2018 6:56 am

Re: sabnzbdplus without docker (Clinton.Hall)

Postby adrenalinenz » Thu Sep 24, 2020 6:07 pm

I got version 4.0.2 installed using:

Code: Select all
python -m pip install --force-reinstall --ignore-installed --no-binary :all: sabyenc3


I then updated the requirements.txt file to 4.0.2 although I shouldn't need to. But I still get the same error:
Restarted sabnzbd, the following is displayed as it starts:
Code: Select all
Requirement already satisfied: sabyenc3>=4.0.2 in /volume1/.@plugins/AppCentral/sabnzbdplus/env/lib/python3.8/site-packages (from -r requirements.txt (line 1)) (4.0.2)


Yet the error remains SABYenc module... NOT found! Expecting v4.0.0 - https://sabnzbd.org/sabyenc
adrenalinenz
 
Posts: 8
Joined: Mon Feb 05, 2018 6:56 am

Return to SABnzbdplus

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest