It is currently Sat Jan 23, 2021 12:53 am
All times are UTC + 8 hours

File Copy issue

Share your awesome tips and tricks here.

File Copy issue

Postby Project86 » Sat Oct 20, 2018 2:29 am

Cross posting this here, as the sections on this forum are not very well defined.

I am in the process of copying files from a 4TB external drive, which is USB powered (not that it probably matters, but trying to be specific). I will copy several directories full of files (anywhere from a few dozen GB to several hundred) without issue. I am doing this on my 1 month old AS6404t with brand new WD Red drives in it. I use ADM "File Explorer" as it is simple and efficient for this one-time procedure.

But then once in a while, seemingly at random, I am getting an error that says "Unable to copy or move files/folders (Ref.5019)". Everything stops at that point. I can try again, sometimes it will work without issue, sometimes I get the error again.

I don't think this external drive has issues, as I have copied the same contents multiple times to other drives without issue. Also I am merely reading from it, not writing, so that should be simple enough.

Anyone know what the Ref5019 copy error means?
Project86
 
Posts: 16
Joined: Mon Feb 17, 2014 12:23 am

Re: File Copy issue

Postby sksbir » Sat Oct 20, 2018 5:41 pm

Hi
I see three potential sources for problems like yours:

1/ disks in NAS are not in HCL. Take a look here to validate that your disks are listed : https://www.asustor.com/service/hd?id=hd&lan=en

2/ filenames and/or directory names are too long, especially if the target shared folder on the NAS is encrypted. ( I think, limitation is about 140 characters ).

3/ file/directory names with accents or other special characters could be a problem.
sksbir
 
Posts: 339
Joined: Tue Aug 25, 2015 9:23 pm

Re: File Copy issue

Postby Project86 » Sun Oct 21, 2018 12:24 am

Thank you for the reply. To address each point:

1) My drives are on the list.

2) This is a good idea, though later attempts to copy the same files work just fine.... so I'm not sure if it can be related or not.

3) Same as above.
Project86
 
Posts: 16
Joined: Mon Feb 17, 2014 12:23 am

Re: File Copy issue

Postby sksbir » Tue Oct 30, 2018 6:35 am

ok
then try an other way , eg copying from shell command. If it fails, you may get a more meaningful message. If not, then you will have proven that it comes from the graphical interface and the copy command that is used by it.
sksbir
 
Posts: 339
Joined: Tue Aug 25, 2015 9:23 pm

Return to Tips & Tricks

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest