It is currently Fri Dec 15, 2017 1:13 am
All times are UTC + 8 hours

virtualbox 4.3.36 - guest VM network performance

Just about everything is virtual these days. Topics relating to virutalization go here.

virtualbox 4.3.36 - guest VM network performance

Postby jauling » Thu Feb 16, 2017 8:20 pm

Hi everyone,

I've got an AS5104T with 8GB memory. I recently spun up an Ubuntu 16.04.2 64-bit Linux guest VM on it under Virtualbox 4.3.36 (latest as of this posting), and ran some iperf3 tests. The results are a bit confusing and not sure why its not good.

I've got a Windows 10 PC connected to the same network switch as my AS5104T. I run iperf3 server on both my Windows 10 PC and my Ubuntu guest VM.

From my Linux VM, I can connect to the iperf3 server on my Windows 10 PC and the throughput is acceptable, and close to line speed:
Code: Select all
root@feeble:~# iperf3 -c loopy
Connecting to host loopy, port 5201
[  4] local 10.4.2.22 port 40738 connected to 10.4.2.12 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec   106 MBytes   886 Mbits/sec    0    215 KBytes       
[  4]   1.00-2.00   sec   108 MBytes   902 Mbits/sec    0    215 KBytes       
[  4]   2.00-3.00   sec   111 MBytes   925 Mbits/sec    0    215 KBytes       
[  4]   3.00-4.00   sec   101 MBytes   853 Mbits/sec    0    215 KBytes       
[  4]   4.00-5.01   sec   106 MBytes   881 Mbits/sec    0    215 KBytes       
[  4]   5.01-6.01   sec   105 MBytes   885 Mbits/sec    0    215 KBytes       
[  4]   6.01-7.01   sec   104 MBytes   873 Mbits/sec    0    215 KBytes       
[  4]   7.01-8.01   sec   104 MBytes   875 Mbits/sec    0    215 KBytes       
[  4]   8.01-9.00   sec   105 MBytes   882 Mbits/sec    0    215 KBytes       
[  4]   9.00-10.01  sec   105 MBytes   874 Mbits/sec    0    215 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.01  sec  1.03 GBytes   883 Mbits/sec    0             sender
[  4]   0.00-10.01  sec  1.03 GBytes   883 Mbits/sec                  receiver


If I reverse the stream, or run iperf3 client from my Windows 10 PC, the results are basically 1/4th the result:
Code: Select all
root@feeble:~# iperf3 -c loopy -R
Connecting to host loopy, port 5201
Reverse mode, remote host loopy is sending
[  4] local 10.4.2.22 port 40742 connected to 10.4.2.12 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  27.1 MBytes   227 Mbits/sec                 
[  4]   1.00-2.00   sec  25.3 MBytes   212 Mbits/sec                 
[  4]   2.00-3.00   sec  23.4 MBytes   196 Mbits/sec                 
[  4]   3.00-4.00   sec  25.0 MBytes   209 Mbits/sec                 
[  4]   4.00-5.00   sec  25.1 MBytes   211 Mbits/sec                 
[  4]   5.00-6.00   sec  24.7 MBytes   207 Mbits/sec                 
[  4]   6.00-7.00   sec  23.5 MBytes   197 Mbits/sec                 
[  4]   7.00-8.00   sec  23.6 MBytes   198 Mbits/sec                 
[  4]   8.00-9.00   sec  24.3 MBytes   204 Mbits/sec                 
[  4]   9.00-10.00  sec  24.7 MBytes   207 Mbits/sec                 
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   247 MBytes   207 Mbits/sec                  sender
[  4]   0.00-10.00  sec   247 MBytes   207 Mbits/sec                  receiver


I've got a ticket open with Asustor support, but we haven't gotten that far yet. It would be great if they'd consider upgrading Virtualbox to something newer, like 5.x, but not sure when or if that will happen.

On a side note, I also connected my Macbook Air to the same switch via USB3 dongle, and was able to send and receive with my Windows 10 PC at close to line speed in both directions. From the NAS itself, transferring files has good speed as well, so it seems the issue is isolated to the virtualization layer.

Has anyone run into this weirdness? If anyone has the time to test this, that'd be great too! Thanks.
jauling
 
Posts: 18
Joined: Wed Feb 01, 2017 1:34 am
Location: Amsterdam

Re: virtualbox 4.3.36 - guest VM network performance

Postby jauling » Sat Mar 11, 2017 7:30 pm

Upgraded to ADM2.7 + Virtualbox 5.1.14, but still have the same network performance issues...
jauling
 
Posts: 18
Joined: Wed Feb 01, 2017 1:34 am
Location: Amsterdam

Return to Virtualization

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest