Page 1 of 1

Virtualbox launch problem via ADM

PostPosted: Sun Jan 03, 2021 3:53 pm
by krieger
Hello,

I'm using AS6404T. I successfully installed the VM app. When im clicking in via ADM (Opera, chrome) im getting 404 error The requested URL was not found on this server. Someone can help me?

Re: Virtualbox launch problem via ADM

PostPosted: Mon Jan 04, 2021 3:45 pm
by angel2
same here, I think it happens after installing virtualbox extension pack

Re: Virtualbox launch problem via ADM

PostPosted: Tue Feb 09, 2021 10:57 pm
by gloops100
+1
same issue after installed Extension pack.

Any idea ?

Re: Virtualbox launch problem via ADM

PostPosted: Thu Feb 11, 2021 3:52 am
by duardito
I fixed it rebooting.

Re: Virtualbox launch problem via ADM

PostPosted: Tue Feb 16, 2021 11:29 pm
by ddales1477
I've been hunting a resolution for this for days and days.

From what I can gather the ONLY way to access the Virtualbox UI with the Guest Extensions is to use the Asustor Portal. That means, physically connect a keyboard, mouse, and monitor to your NAS. Otherwise, you won't be able to use the Virtualbox Extensions which is required to enable remote network connections, change display settings, etc... etc...

Using the Web UI for Virtualbox from your computer/laptop/whatever will not work once you install the Extension Pack. Although there is a way to redirect a remote connection to your Portal it's really not worth the effort in my opinion. But if you want to you can Google it.

Once you have a Virtualbox guest setup you can access it via Remote Desktop or VNC for example. You don't need to leave the keyboard, mouse, and monitor connected once it's running. However, if you need to change anything you'll have to go back to the Portal again.

Also, you can only run 1 virtual guest at a time.

Terrible design but I guess it is what it is.

EDIT: There is a posting on the forum to get access through EZConnect. A real pain though.

Re: Virtualbox launch problem via ADM

PostPosted: Thu Feb 25, 2021 9:08 am
by angel2
the solution is written here in another thread by user ysaotome, he found it on virtualbox forums.

Code: Select all
 root@hoge:/volume1/.@root # cd /volume1/.@plugins/AppCentral
root@hoge:/volume1/.@plugins/AppCentral # cd virtualbox/bin
root@hoge:/volume1/.@plugins/AppCentral/virtualbox/bin # ./VBoxManage extpack install /volume1/Download/Oracle_VM_VirtualBox_Extension_Pack-4.3.20-96996.vbox-extpack
./VBoxManage: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /volume1/.@plugins/AppCentral/virtualbox/bin/VBoxRT.so)
./VBoxManage: /usr/lib/libssl.so.1.0.0: no version information available (required by /volume1/.@plugins/AppCentral/virtualbox/bin/VBoxRT.so)
0%...
10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "Oracle VM VirtualBox Extension Pack".


I have done this without Asustor HDMI or Asustor Portal.
You just need to enable ssh and login with root. Root password is “admin” account password.

viewtopic.php?f=46&t=5799


You have to do this method after every restart, be careful.
Before doing all of this delete VirtualBox Extension Pack from AppCentral.
Also you have to download Oracle_VM_VirtualBox_Extension_Pack-4.3.20-96996.vbox-extpack from Oracle website, the appropriate version based on your VirtualBox version.

Hope this helps

Re: Virtualbox launch problem via ADM

PostPosted: Mon Apr 05, 2021 6:11 pm
by cj_euler
ok, fixed it by rebooting, and then it says

phpVirtualbox login in

I don't have any password but I tried

username: admin
password: admin

and it let me log in

Re: Virtualbox launch problem via ADM

PostPosted: Wed May 26, 2021 3:29 am
by loocar
In my case, the restart did not help. By phpVirtulabox I have new tab with IP_HOST/virtualbox? Sid = FTutYKdY
ERR_CONNECTION_REFUSED and Via Asustor portal - i have black screen. I don't even know where the logs are to see what's going on.
My Envirement:
Virtualbox app 6.1.12r01 + ExtensionPack. MAchine: AS6102T. ADM 3.5.6.RHA2. BIOS: 2.23