It is currently Tue Aug 21, 2018 7:28 pm
All times are UTC + 8 hours

dm-crypt not working on AS202TE

Backup and data protection discussion at its finest.

dm-crypt not working on AS202TE

Postby sundance » Fri Aug 18, 2017 3:56 am

Hello!
I am using a AS202TE and I am very happy with it.
Still ecryptfs available for this device has some limitation. The one that creates problems for me it the file name length (not more than 135 characters). So, when I backup data from other servers this is a constant problem.

I am trying to use dm-crypt since this is included in the package but I have no success.
When I run "cryptsetup benchmark" I get the following output:

root@AS-202TE-9689:/volume1/.@root # cryptsetup benchmark
# Tests are approximate using memory only (no storage IO).
PBKDF2-sha1 53194 iterations per second
PBKDF2-sha256 33677 iterations per second
PBKDF2-sha512 12617 iterations per second
PBKDF2-ripemd160 54251 iterations per second
PBKDF2-whirlpool 14191 iterations per second
Required kernel crypto interface not available.
Ensure you have algif_skcipher kernel module loaded.

I tried to load dm-crypt with "modprobe dm-crypt" but no change.

I checked /lib/modules and I see that no *aes*.ko file is there... So my question is:

Does AS202TE support dm-crypt (cryptsetup)?

Thank you!
sundance
 
Posts: 1
Joined: Fri Aug 18, 2017 3:48 am

Return to Backup and Data Protection

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest