It is currently Sat May 26, 2018 4:24 am
All times are UTC + 8 hours

Added new disk to RAID 5, ADM Storage Manager not reporting correct capacity

Backup and data protection discussion at its finest.

Added new disk to RAID 5, ADM Storage Manager not reporting correct capacity

Postby SPOinNS » Wed Apr 26, 2017 10:53 am

Has anybody got an explanation for the following?

I have an AS-204TE that was happily running 3 x WD40EFRX (4TB WD Reds) in RAID 5.

I purchased a 4th WD40EFRX and installed it last week giving 4 identical disks in total. After a 33 hour sync process came to an end I expected to see a 10+TB usable capacity. Instead ADM Storage Manager reported 7+TB, unchanged from the 3 disk RAID 5.

I made a support ticket with Asustor asking them to look into the problem. Last night they TeamViewered in and went to work. Being on the east coast of Canada meant that this all took place around 5 a.m. my time. I tried to stay around and observe but I had committments and needed to get some sleep. I asked them to leave me a email detailing what they did to resolve the problem. When I went to bed they were working away in Putty with most of their efforts centered around the inode function.

I woke this morning to find that Storage Manager was now not reporting any storage capacity, accurately or otherwise, and Asustor Tech Support had left me this email:

Thanks for the info.
Our engineer has connected to the remote session and check the status.
We find that the volume1 in your NAS has reached the expand limitation of the platform(in AS-2 and AS-3 series model, the volume expansion capacity can only grow 8TB maximum).
In your case, you will need to backup the data in the volume and go ADM-Settings-Factory to initialize the NAS again with these 4 drives in Raid5 volume to have correct capacity.

Please don't be hesitate to contact if you got further question.

Best regards.
Jack Ni
Technical Support Department


I'm finding this difficult to understand. Asustor's published specs for this model specify maximum single volume size of 16TB. What Tech Support is telling me doesn't even agree with their own specs.

Furthermore exactly the same thing happened last year when I went from 1 disk to 3 disks and created the RAID 5. ADM Storage Manager refused to accurately reflect the true size of the volume. Tech Support had to intervene, again centered around the inode function, but were able to fix the problem to everyone's satisfaction.

That tale of woe is detailed in this forum post from March of 2016:
https://forum.asustor.com/viewtopic.php?f=45&t=7607&p=23429#p23429

My question now is: should i ask Tech Support to rexamine this current problem? Perhaps with more experienced personnel? I don't want to get their back's up but I have only tried to expand storage on this NAS twice and the same problem has occurred both times.

I really don't want to start all over with a factory reset and watch the disks thrash for another 33+ hours before I begin copying back my data, especially if it can be fixed remotely as it was last year.

I have asked Asustor several times if this is a known bug in ADM, perhaps limited to the 32 bit AS2XX & AS3XX series and they resolutely refuse to comment on the question. Draw your own conclusions.

Final bit of silliness - I turned on TeamViewer for them last night and they hit me back with a link for TeamViewer 11. It seems they can't use TeamViewer 12. Sheesh.
SPOinNS
 
Posts: 36
Joined: Wed Apr 29, 2015 1:10 pm

Re: Added new disk to RAID 5, ADM Storage Manager not reporting correct capacity

Postby Kapitein Haak » Wed Apr 26, 2017 3:25 pm

Hello SPOinNS,

Apparently Asustor is not the only manufacturer imposing this limit (https://community.netgear.com/t5/Using- ... d-p/858270). You can create a 16TB volume, but apparently only when creating it from scratch or incrementing a volume which was created at 8 TB and increased with the maximum of 8TB (over the lifetime of the volume).
Other manufacturers have moved away from EXT4 to ReiserFS removing the 8TB limitation. Hopefully Asustor wil move on as well.

Best regards,
Kapitein Haak.
"What would the world be like without Captain Hook?"
---
"Homo sapiens non urinat in ventum" (A wise man doesn't piss into the wind), only in Amsterdam:
https://www.google.nl/maps/@52.36289,4. ... 312!8i6656
User avatar
Kapitein Haak
 
Posts: 331
Joined: Tue Oct 15, 2013 2:40 pm
Location: Stranded on the Dutch coast.

Return to Backup and Data Protection

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest