Page 1 of 2

NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 6:18 am
by CygnusBlack
Hi.

I have two Ironwolf HDDs in Raid 1.
I've tried mounting one of the drives in Ubuntu/Mint without success (sees the drive but gives a PMBR error), using an USB dock station. PartedMagic also gives errors.

Halp!

Edit: a newer dock station solved the problem.

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 7:37 am
by ilike2burnthing
https://support.asustor.com/index.php?/ ... using-a-pc

Or put in a new drive and rebuild the array

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 9:32 am
by CygnusBlack
Thanks for your reply but I've followed the guide before posting the original message. Doesn't work.
I get a "no arrays found..." error...

As I said, the NAS is dead so there's no way to use it to rebuild the array.

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 9:43 am
by ilike2burnthing
Oh! Sorry, read the post but not the title, my bad.

I remember someone having a similar issue here before. I'll have a dig and come back to you soon.

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 9:50 am
by CygnusBlack
No problem! Thanks in advance!

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 9:59 am
by orion
Did you try the method? https://support.asustor.com/index.php?/Default/Knowledgebase/Article/View/189/22/how-to-extract-data-from-a-hard-drive-single-of-my-failed-nas-by-using-a-pc. Although it's the case of single drive volume, RAID-1 should be similar.

If it does not work, you should try "mdadm" command in Ubuntu (mdadm --assemble to create a md device first).

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 10:23 am
by ilike2burnthing
The comment I was thinking of - viewtopic.php?f=240&t=11101#p35860

A couple of others which may be easier to try first:
- viewtopic.php?f=228&t=11095#p35937
- viewtopic.php?f=107&t=11290&start=10#p36690

Hopefully they're of some help.

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 10:23 am
by CygnusBlack
@orion
Yes I did and did not work. Check a bunch of posts above your reply.
I didn't use the --assemble though as I thought the OS automatically looked for arrays.

Re: NAS is dead. How to access HD data?

PostPosted: Fri Sep 18, 2020 10:27 am
by CygnusBlack
@ilike2burnthing

Thanks! After looking at the posts, it seems I need to use the --assemble string as @orion pointed out before.

I'll try tomorrow and I'll let you know :)

Re: NAS is dead. How to access HD data?

PostPosted: Sun Sep 20, 2020 12:13 am
by CygnusBlack
This thread has lost some posts... :shock: