Page 1 of 2

:oops: Please help me for hosting my website.

PostPosted: Fri Aug 01, 2014 11:54 am
by survivor_ak47
Hi gang,

Recently i had purchase a domain,
created an dns from ddns.net,
enable DDNS service (status success)
enable Mysql
enable Web server (enable ssl and php too)
created virtual host that link with what i created with ddns.net. pointed to a new created folder.
enable WebDAV (donno is it a need)
enable FTP (donno is it a need)

installed PhPmyadmin apps, access and create a database with default ''collation'' selection.
installed WordPress, pointed to the database created in mysql, host name kept it as localhost.

new web theme had install in wordpress, it's working but it's in local hosting site. can't manage to get it air.

My domain purchase with Godaddy. have tried adjustment here and there with Godaddy.but it just don't go live to my domain. but still kept it as localhost.

i just want my domain to be air.

somehow i'm stuck here.

can someone help me put it up? what did i left out?

Re: :oops: Please help me for hosting my website.

PostPosted: Fri Aug 01, 2014 3:11 pm
by Kapitein Haak
Hello survivor_ak47,

created an dns from ddns.net, Ok, so you probably got an <mydomain>.no-ip.org domain (or something similar).
enable DDNS service (status success) If you check "www.whatismyip.com" you should get the same IP address as when you perform: ping <mydomain.somewhere.ontheinternet> from a command prompt. If not, back to the drawing board.
enable Mysql Check
enable Web server (enable ssl and php too) Check, you only need ssl if you require an encrypted connection.
created virtual host that link with what i created with ddns.net. pointed to a new created folder. I would suggest you place your website in /volume1/web, this works better if you need access to other services from your NAS from your public DNS name.
enable WebDAV (donno is it a need) You probably don't need this, you should disable this.
enable FTP (donno is it a need) You can keep this enabled if you DO NOT forward the ftp port from your internet router to your NAS
What seems to be missing is the forwarding of the port 80 (www) and perhaps port 443 (ssl) from your internet router to your NAS.
You could use Easy connect -> EZ router in the NAS settings or configure your router from it's webpage. Then you should check from a phone (or a device connected to a different internet connection) if you can reach the website. Some internet routers do not allow traffic from the LAN back into your network, preventing the access to your own website from the local network.

Let us know if you get it working,
Kapitein Haak.

Re: :oops: Please help me for hosting my website.

PostPosted: Sun Aug 03, 2014 9:42 pm
by survivor_ak47
hey bro,

i have set up everything, you told. i just can't my domain hook up. i have upgrade my domain to be able to map to wordpress. but it only help with wordpress web base dashboard. but the web base and the nas wordpress is not link at all.. i just want to host it on my own nas. i even forward my domain to my ddns, it just don't work.

to make it simple, how can i have my website created from wordpress.com link to my nas wordpress. i wanted to host it on my server.

how you may help me. been on the computer for almost near a week trying, still back to zero. ha..

wainting for solution.

regards
Lewis

Re: :oops: Please help me for hosting my website.

PostPosted: Mon Aug 04, 2014 11:41 am
by orion
survivor_ak47 wrote:hey bro,

i have set up everything, you told. i just can't my domain hook up. i have upgrade my domain to be able to map to wordpress. but it only help with wordpress web base dashboard. but the web base and the nas wordpress is not link at all.. i just want to host it on my own nas. i even forward my domain to my ddns, it just don't work.

to make it simple, how can i have my website created from wordpress.com link to my nas wordpress. i wanted to host it on my server.

how you may help me. been on the computer for almost near a week trying, still back to zero. ha..

wainting for solution.

regards
Lewis

Did you enable "EZ-Router" in ADM web page -> Settings -> Easy of Access? You may post pictures or settings here (EZ-Router and DDNS tab). According to your description, your problem might be related to port forwarding settings.

Re: :oops: Please help me for hosting my website.

PostPosted: Mon Aug 04, 2014 2:28 pm
by Kapitein Haak
Yes, Orion is right. First things first; browsing:
http://<ip.generated.by.whatismyip.com> (from your phone preferably)
http://<local.lanip.of.yournas>
should give you the same webpage. As long as the first URL is showing something else, the other stuff surely won't work.

BR, Kapitein Haak.

Re: :oops: Please help me for hosting my website.

PostPosted: Wed Aug 06, 2014 12:04 pm
by survivor_ak47
Hi gang,

Please see the pics, anything left out? how can it be hosted correctly. if it can be done and learn from your guys, it will be a good help form you. let me know if i can buy you some coffee... hee...

Re: :oops: Please help me for hosting my website.

PostPosted: Thu Aug 07, 2014 12:16 pm
by orion
Ok, that should be fine to use "localhost" in Database Host.

It seems that you applied no-ip ddns service. And your port forwarding detection is successful. The next step is to test if port forwarding and ddns are working fine. And I believe suggestions from Kapitein Haak are right to check global IP first. Have you tried the followings:
I think you can skip your own domain first.
By these ways, you should be able to know what's wrong in your environment (maybe, it's caused by your router, ISP, nas... etc.).

Re: :oops: Please help me for hosting my website.

PostPosted: Tue Aug 12, 2014 3:15 pm
by survivor_ak47
orion wrote:Ok, that should be fine to use "localhost" in Database Host.

It seems that you applied no-ip ddns service. And your port forwarding detection is successful. The next step is to test if port forwarding and ddns are working fine. And I believe suggestions from Kapitein Haak are right to check global IP first. Have you tried the followings:
I think you can skip your own domain first.
By these ways, you should be able to know what's wrong in your environment (maybe, it's caused by your router, ISP, nas... etc.).


Hi,

I had no problem accessing thro my ADM with what you mention.([*] In a browser, http://your_wan_ip:8000/, http://your_registered_ddns_name:8000/) i should say, i'm setting up correctly.

if i key in( [*] In a browser, http://your_wan_ip/). it bring me to a page

Congratulations!

You have successfully enabled the Web server on your ASUSTOR NAS.

To begin hosting your website on the NAS,
simply upload your web pages to the [ Web ] shared folder.

Click here to enter ADM
------------------------------------------------------------------------------------------

can i say i'm ready to go on the next step?

what should i do next?

Thanks for helping.

regards

lewis

Re: :oops: Please help me for hosting my website.

PostPosted: Tue Aug 12, 2014 10:48 pm
by Kapitein Haak
Hello survivor_ak47,

Please also try:
Everything else you tried looks just fine. It should give you one of the following:
    - The standard message from Asustor (congratulating you), then you need to place your website in /volume1/web
    - Your own website, then all is well
    - A page not found error, in which case you are directed by your virtual directory to a folder which does not exist, then you would need to rectify this configuration so it will work

Let us know what the result is.

Best regards,
Kapitein Haak.

Re: :oops: Please help me for hosting my website.

PostPosted: Wed Aug 13, 2014 10:46 am
by orion
Yes, you are ready to go. If you configured your wordpress correctly (in your local LAN), you should be able to access the page:
http://your_registered_ddns_name/wordpress/

And, you can configure your own domain name to map to your wan IP. Then, you can access your nas by your own domain name from outside.