It is currently Wed Jun 23, 2021 7:14 am
All times are UTC + 8 hours

Unable to delete files/folders. (Ref 5011)

File Explorer comes pre-installed with ADM and can be used to browse and manage the files on your NAS.

Unable to delete files/folders. (Ref 5011)

Postby AYu » Tue Apr 19, 2016 6:13 pm

The problem started with I external backup my Asustor AS202TE to an external hard disk every month. At the first few months, the situation was fine. However, an error happened and the error message is as follows:

rsync: readlink_stat("/share/User Homes/admin/photos/050429/DSC_7813.JPG") failed: Input/output error (5)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at /asustor/branch2_5_2016_02_02/x86/source/rsync-3.0.9/main.c(1067) [sender=3.0.9]

Then I tried to delete the folder of "050429" and it said, "Unable to delete files/folders. (Ref 5011)". I tried to use file explorer in ADM and window file explorer in PC which linked with the AS202TE to delete but failed.

I searched in this forum and found that others had encountered similar problem before.

(by matock » Tue Feb 03, 2015 9:40 pm)
After contacting the support, they brought me a solution. I share it here, it might help somebody else.

My file system was damaged with "1.3% of non-contiguous blocks". The solution is to repair the file system by running the fsck utility. How to proceed:

1. backup all your data
2. turn off the unit and pull out all drives
3. turn on the unit without drives
4. once the unit is bootup, put the drives back (do not run initialization process!)
5. login with "root" and password "admin" via SSH
6. run "mdadm -A /dev/md1 /dev/sda4 /dev/sdb4" to assemble the RAID volume
7. run "fsck.ext4 -p /dev/md1" to repair automatically the file system
8. run "reboot"

In my case, the automatic repair failed and it proposed to me to run it in manual mode, without the -p parameter. I just replied to all questions with the default proposition (y).

After reboot I did also:
- I re-executed the fsck to check again the volume --> file system clean
- I did a full compare between the volume and the backup --> none file was missing
- I was able to delete my nasty folders

However, please forgive me that I don't understand how to fix it using the above steps. It is also hard to backup all the data first because the data is over 2TB and I don't have an external hard disk this big now.

Frankly, if it is a common problem, I really worry about the stability and reliability of the Asustor NAS system. Thanks a lot.
Posts: 8
Joined: Wed Jul 08, 2015 7:33 am

Return to File Explorer

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest