It is currently Thu Jan 21, 2021 10:51 am
All times are UTC + 8 hours

git segfault

This is where you can find the latest ADM official release. Feel free to discuss any questions regarding it here.

git segfault

Postby jeromeb » Thu Sep 15, 2016 5:45 am

Hello,

I have git installed on my nas but it segfault each time I try to git clone/pull/...

on the log (with dmesg via ssh):
[86955.300770] git-remote-http[15609]: segfault at 0 ip 00007f05eb6bca26 sp 00007fffba967aa8 error 4 in libc-2.22.so[7f05eb594000+195000]

My command:
/volume1/home/admin/git $ git clone https://github.com/certbot/certbot.git
Cloning into 'certbot'...
/volume1/home/admin/git $

No error on the shell, I have the latest version of ADM 2.6.4.R9.C2 but I have the same issue with the latest version, not sure to know when it's append.

Regards,
-----------------------------------------
AS-604t user
-----------------------------------------
jeromeb
 
Posts: 17
Joined: Sun Sep 01, 2013 8:48 pm
Location: Paris / France

Re: git segfault

Postby orion » Mon Sep 19, 2016 11:19 am

That's weird. I tried the exact command that you executed, and I got successful result (admin account under my AS-304T). I think you can try to remove "git" and reinstall it again.
User avatar
orion
 
Posts: 2862
Joined: Wed May 29, 2013 11:09 am

Re: git segfault

Postby jeromeb » Tue Sep 27, 2016 2:44 pm

Hello,

Thanks for your reply.
I don't want to do that because if I remove this "package" I need to remove many others (dependency), and as it's a linux not "like" a windows a binary is a binary, her it's an issue with libc-2.22.

I don't understand for now why I only have issue with git pull/push and not with git log/status...

Did someone else have issue with libc-2.22 since the last ADM update ?

Regards
-----------------------------------------
AS-604t user
-----------------------------------------
jeromeb
 
Posts: 17
Joined: Sun Sep 01, 2013 8:48 pm
Location: Paris / France

Re: git segfault

Postby jeromeb » Mon Oct 10, 2016 2:57 pm

After tests, I have a solution.

git was installed via the asustor + via ipkg.
the version who come with ipkg is more recent and not linked with the new version of libc of ADM 2.6.4

I have remove the git package from ipkg and now it works.

Regards,,
-----------------------------------------
AS-604t user
-----------------------------------------
jeromeb
 
Posts: 17
Joined: Sun Sep 01, 2013 8:48 pm
Location: Paris / France

Return to [Official] For AS-60X Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 4 guests