It is currently Tue Jan 19, 2021 4:26 am
All times are UTC + 8 hours

System does not go to sleep

This is where you can find the latest ADM official release. Feel free to discuss any questions regarding it here.

System does not go to sleep

Postby erikl » Sat Jul 09, 2016 1:45 am

I have earlier reported the problem that my NAS does not enter sleep mode during night.

I have now installed the new version of software and has used the new diagnostics tool to investigate.

For MY configuration the problem seems to be that the Mac OS X Service (process cnid_dbd) issues a write to the disc every 30 minutes, also when no active Mac is connected.

I have changed the disc hibernation time to 15 minutes, and the discs actually enters hibernation status but are awakened every 30 minutes. However the system_go_to_sleep time can not be set lower than 30 minutes and thus the system will not enter sleep mode due to the write from the Mac Service.

I don't know why the Mac Service issues this write every 30 minutes, but suspects it is just a "I am alive" written to a log file. That should obviously be avoided.

The Mac Service on my NAS is just configured with "Enable Mac File Service (AFP)". The additional options "Advertise AFP over Bonjour" and "Enable Time Machine Support" are NOT activated.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Re: System does not go to sleep

Postby orion » Mon Jul 11, 2016 1:27 pm

I don't own Mac system. However, after I enable AFP, I did not see any activities about "cnid_dbd" in diagnostics tool. It may be caused that AFP might work once at your environment, but not in my environment. I think you should report this issue to asustor: http://support.asustor.com/
User avatar
orion
 
Posts: 2855
Joined: Wed May 29, 2013 11:09 am

Re: System does not go to sleep

Postby erikl » Wed Aug 17, 2016 2:18 am

After some more testing, I have come to the conclusion that this happens when a Mac computer has a connection to the NAS (has a mounted "remote" disc). As long as this mount exists, the write appears every 30 minutes. Disconnecting (Dismounting) the remote disc makes the write go away and the NAS to enter first disc hibernation mode and then later sleep mode.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Re: System does not go to sleep

Postby Somatics » Wed Aug 17, 2016 1:54 pm

erikl wrote:After some more testing, I have come to the conclusion that this happens when a Mac computer has a connection to the NAS (has a mounted "remote" disc). As long as this Best Diet Pills blog article exists, the write appears every 30 minutes. Disconnecting (Dismounting) the remote disc makes the write go away and the NAS to enter first disc hibernation mode and then later sleep mode.


Ah, yes that works, thanks Erik. I wish there was a way that I didn't have to keep disconnecting and reconnecting every day though.
Last edited by Somatics on Sat Feb 29, 2020 6:00 pm, edited 5 times in total.
Somatics
 
Posts: 1
Joined: Sat Aug 06, 2016 10:23 pm

Re: System does not go to sleep

Postby erikl » Sun Sep 11, 2016 6:56 pm

I encourage ASUS (or whoever is responsible for the Mac OS X Service-app) to make a change so the app does not issue a write every 30 minutes - presumably without any reason.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Re: System does not go to sleep

Postby erikl » Sun Jan 08, 2017 12:39 am

Release notes for update 2.6.6 RCF2 said that it had

"Fixed “external disk could not enter hibernation” issue"

I hoped that referred to the problem mentioned originally in this thread. Sorry to observe that after installation there is no change to the problem. When a MAC computer has a "disc" mounted there is still a write every 15 minutes by a process named cnid_dbd. Thus the discs will not hibernate and the NAS will still not go to sleep.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Re: System does not go to sleep

Postby orion » Thu Jan 12, 2017 1:23 pm

Did you report it to asustor? http://support.asustor.com/
User avatar
orion
 
Posts: 2855
Joined: Wed May 29, 2013 11:09 am

Re: System does not go to sleep

Postby erikl » Thu Jan 12, 2017 4:24 pm

Yes, I think I did that back in July 2016. I think my report is one of the reasons for introducing the special Diagnostics tool (see this article from Knowledgebase: https://support.asustor.com/index.php?/ ... ew-feature) .

After using the diagnostics tool I more detailed reported my observations in this forum.

I have used the diagnostics tool again after the upgrade and the write to the disc still occurs every 15 minutes as long as a Mac has a disc "mounted" to the NAS.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Re: System does not go to sleep

Postby erikl » Tue May 09, 2017 4:24 pm

I have now been in contact with support on this matter and swapped a number of emails.

The solution to be problem seems to be to use the SMB- and not the AFP-protocol, when mounting a disc from a Mac computer.

To disable AFP go to ADM-services, Mac OSX and then disable AFP. When you connect (or reconnect) a disc from the Mac use the smb protocol instead.

Anyway, now my NAS goes to sleep during night even if there is a mounted disc from a Mac.
erikl
 
Posts: 9
Joined: Sat Jan 30, 2016 5:00 pm

Return to [Official] For AS-60X Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 2 guests