Page 1 of 1

AS-608T wont start after adding RAM

PostPosted: Thu Mar 29, 2018 10:52 pm
by tomsavini
Hello all :)

My first post. I just bought a used AS-608T. Wanted to try something else than Synology.
So far I am very, very happy with it. Looks like this is good value for the money.

Small problem.
I see that 1GB of RAM is included. I guess that it is enough for me, but 2gb more wasnt expensive, so I bought this;

When I turn on the nas it wont start. It says starting up etc, but it doesn't go any further. I tried waiting 5 minutes, nothing happens. I tried turning it off, and taking out the RAM. Then it starts normally.

Is there a way to find out if it is the 608T or the ram that it is faulty?
I have the latest software on the 608T

Re: AS-608T wont start after adding RAM

PostPosted: Thu Mar 29, 2018 11:42 pm
by MonsMagnus
Did you follow the troubleshooting steps in this guide? ... 1522338143

Since it says the max is 3gigs of ram I assume there is no need to install memory in matched pairs. Still, I would remove the original 1gig module and place the new 2gig module in its slot to determine if there is some sort of a timing conflict between the two. I also would never order ram from ASUSTOR, it's usually more expensive than you can purchase from Micron directly.

Let us know.

Re: AS-608T wont start after adding RAM

PostPosted: Sat Mar 31, 2018 1:27 am
by mafredri
I’m curious where you got such an old model, IIRC Asustor no longer provides support for it.

I’ve examined the AS-6xxT series in great detail and they are very kinky with regards to RAM. Especially my unit refuses to operate correctly with any RAM in the expansion slot. The only RAM upgrade I’ve managed to get working properly so far is replacing the internal 1gb with a 2gb module. I’ve also tried 4gb and while it works fine at first. The system becomes unusably slow after 12 hours.

But replacing the internal RAM requires you to take apart the NAS and remove the motherboard, so it’s not very convenient.

I’ve also been unsuccessful in diagnosing this via the EFI firmware, it’s very bare bones and seems slapped together :/.

Re: AS-608T wont start after adding RAM

PostPosted: Sat Mar 31, 2018 1:30 am
by mafredri
Oh and I’ve had the same problem (NAS doesn’t boot) with one memory module. According to specs, it should’ve worked but didn’t. My recommendation is to return it and try another brand or model.

Re: AS-608T wont start after adding RAM

PostPosted: Thu Apr 12, 2018 7:30 pm
by tomsavini
Thanks a lot for the replies guys, highly appreciated :)

MonsMagnus; I did try all the troubleshooting steps, no luck I'm afraid.
I could try removing the internal RAM, but it is supposed to work with the other input - so I think I will return it.
Do you have any idea of the specs/names of other ram's that will work/are cheaper?
Thanks :)

Hello mafredri
Yes, it's an old model. The reason; the price. I did pay 130 USD for it, kinda cheap.
It seems to work very well. The OS is updated, looks nice.

I have a Synology DS413J, but I like the OS better on this Asustor.
I guess a newer model has better specs, but my use is kinda minimal. I only use it to stream movies I have ripped from my collection (Kodi on a Nvidia Shield Android TV).
I would like to keep apps etc at a minimum.
I guess I don't need more ram, but if it is cheap... Why not?
Or. When I read the rest of your post, maybe it is better to keep the 1gb ram.

Re: AS-608T wont start after adding RAM

PostPosted: Thu Apr 12, 2018 10:14 pm
by MonsMagnus
Without knowing which model you are going to settle on (since you say you are returning this one) I really cant advise you on ram specs. I can say that if you go to they can hook you up with most any memory you require. I personally installed this "Crucial 8GB Kit (4GBx2) DDR3L 1600 MT/s (PC3L-12800) SODIMM 204-Pin Memory - CT2KIT51264BF160B" in my 6202T and it has worked flawlessly.

As for your current problem, if you can get at the 1gig that is already installed I'd remove it and install the memory you already have to test that the unit will work. My guess is you have a timing conflict between the two sticks of ram. If it boots up with only the new stick of memory installed then you might consider sending that ram back and ordering a pair from Crucial so you get identical timings. When you remove the factory installed ram be sure to look it up on the internet to find out what its specs are. Just my 2 cents...