It is currently Thu Oct 18, 2018 2:45 am
All times are UTC + 8 hours

Testing NAS NIC - SEVERE performance issues

Looking for discussion about hardware compatibility? Look no further.

Testing NAS NIC - SEVERE performance issues

Postby Rainz » Sun Nov 05, 2017 7:53 pm

NAS: AS-606T
SysInfo:
ADM: 3.0.3 RAI4
BIOS:1.09

I am looking in to troubleshooting a performance issue involving filetransfer to and from the NAS and a Windows 2012 Essentials server.

The NAS may not be the issue, but the specific error I receive from the software I use for the transfers is
121 - The semaphore timeout period has expired

The software support have an article about this, referring me to:
https://support.microsoft.com/en-us/hel ... rkstations
but I fail to see how I can do some of the troubleshooting on the NAS NIC following those instructions.

The connection to the NAS is being dropped and reestablished several times per minute. It's connected as a Network Drive to the NAS Share and I have enabled all possible settings in regards to creating a persistent connection in Windows, Registry tweaks and CMD settings like NET USE *** /PERSISTENT:YES and even a couple of registry tweaks to that effect, which is probably just the same thing.

Suggestions?

(Had the NAS for years and I had little or no issues with it prior to this)
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Re: Testing NAS NIC - SEVERE performance issues

Postby Rainz » Wed Nov 08, 2017 9:12 pm

I am not getting any transfer speed between my Server and the Nas.

Not yet blaming the NAS, but browsing the shared NAS file structure from my Server 2012 essenstials is proving a nightmare and I may have to resort to carrying USB drives between them for a working backup.
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Re: Testing NAS NIC - SEVERE performance issues

Postby orion » Thu Nov 09, 2017 10:42 am

I did not own a environment with Server 2012 essentials. I think you should check with asustor's support for this environment.
User avatar
orion
 
Posts: 2060
Joined: Wed May 29, 2013 11:09 am

Re: Testing NAS NIC - SEVERE performance issues

Postby Rainz » Thu Nov 09, 2017 5:15 pm

I thought I was?
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Re: Testing NAS NIC - SEVERE performance issues

Postby orion » Fri Nov 10, 2017 10:01 am

Rainz wrote:I thought I was?

I mean here: https://support.asustor.com/
User avatar
orion
 
Posts: 2060
Joined: Wed May 29, 2013 11:09 am

Re: Testing NAS NIC - SEVERE performance issues

Postby Rainz » Fri Nov 10, 2017 3:41 pm

Sent...
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Re: Testing NAS NIC - SEVERE performance issues

Postby Rainz » Sat Nov 11, 2017 4:18 am

After some digging on the Internet I found issues with SMB on Server 2012.

Examining the SMBClient Event log, and related, I found a HUGE amount of errors associated to connection interrupts with NAS shares. Having the Event ID I could search some more and there were two possible actions one could take for remedy:

I have tried both remedies above and they did not help a lot, maybe fewer disconnects/timeouts, but still many per minute...

Finally I have checked the SMB versioning for any possible conflicts, and AGAIN I lack tools to thoroughly check what is on my ASUSTOR NAS, but your SMB version refers to 3 and Windows 8 in your settings and SMB signing is set to Default. Well, Windows 2012 should be version 3.0 (not 3.01 or above) so I will assume it may be the same on both ends, NAS and Server.
Ref: https://en.wikipedia.org/wiki/Server_Message_Block
Which is it for ASUSTOR?
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Re: Testing NAS NIC - SEVERE performance issues

Postby Rainz » Sun Jan 07, 2018 5:17 pm

This was due to and issue with SMB in the latter ADM's and has now been corrected by Asustor...
Rainz
 
Posts: 19
Joined: Thu Oct 24, 2013 12:25 am

Return to Hardware Compatibility

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 2 guests