Page 1 of 1

AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Sat Aug 19, 2017 10:55 pm
by derselia
Still testing all the features of my AS6104T. Latest bug:

SPDIF Audit out appears to only work when I am using KODI. In any other App (Portal, ADM, Chrome, Youtube, Netflix) there is no sound at all.

KODI works because there is a setting which I can direct the audio out. Anyone know how I can set this?

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Wed Sep 13, 2017 9:49 am
by crazynas
Soundsgood (music play) support SPDIF audio out.

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Sat Sep 30, 2017 6:40 am
by alpton
I have this same issue on the 5102T.
I logged a ticket with support (Ticket ID: 16564) and was informed "the browser can only ouput audio from HDMI"

Chrome/Chromium used to work but stopped working so switched to firefox until firefox stopped working as well.
I initally thought this was an issue with firefox dropping support for ALSA from v52 on but downgrading the browser to 43 doesn't fix the issue.

Can somebody confirm this is the case? i.e. no support for SPDIF output from any browser?
I don't have audio output from my monitor to use or test HDMI output

Thanks,

James.

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Sun Oct 15, 2017 4:16 am
by alpton
For anybody else having this issue...
I had to buy additional hardware to resolve the issue. A hdmi audio extracter which was approx €20.
This should be fixable in the OS (it did work and kodi can output to spdif) but I got fed up waiting for a fix.

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Wed Oct 18, 2017 9:49 am
by crazynas
Hi alpton,
You may submit ticket http://support.asustor.com

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Thu Oct 19, 2017 2:21 am
by alpton
Already did, see above...

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Tue Nov 07, 2017 4:33 pm
by metrichye
Hi!

I think I have similar problem with my Asustor AS-6202T NAS.
One of the main reasons I purchased this NAS because of it's S/PDIF capability as at some cases I also want to use it for some web browsing and youtube watching with SOUND as well.
- I have a rather old Yamaha amplifier with S/PDIF and coaxial digital input, but no HDMI input. I really like this amplifier which I don't want to "throw out" as it works flawlessly.
- I have an Acer computer monitor with HDMI but without speaker.

- S/PDFIF works fine under KODI as there's a possibility to set it up, but under ADM there's no sound at all, nor with Youtube App (which uses a web browser), I think it tries to output the sound only by using the HDMI and I just can't find any option regarding this in the ADM settings tab.
(Note to the previous commenter: From the Youtube app I also haven't found a back/exit button, but the usual ALT+F4 key combination works)

Please help me how/where to set up S/PDIF as default sound output?

Thanks for your help,

Regards
metrichye

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Sat Nov 18, 2017 6:10 pm
by raydoo
Any News on this? I dont have any Sound on Amazon Video neither Kodi works

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Sat Mar 31, 2018 9:22 pm
by PeterKool
Hi Raydoo,

I have been struggling with similar problem for months now.

I have the NAS connected to a TV through HDMI but could not get any sound on my TV, could only have sound using Kodi and selecting sound through SPIDF cable connected to separate amplifier and speakers. So I had to turn on my audio system all the time, and could only use Kodi to watch movies etc. No sound through the Youtube app of Chrome app on the Asustor portal. Super annoying.

Today I installed the new ADM version 3.1.0.RFQ3 and I was fiddling around with the Asustor Portal Video resolution. At some point I noticed that when I changed the monitor resolution, after some seconds of black screen while switching resolution, at the top of the screen a blue volume bar appeared which I could then manipulate with a mouse. After shifting this bar to the max (to the right), sound returned while using the Youtube app on the Asustor Portal or any other website through the Chrome app.

So maybe this works for you as well.

best regards !

Peter

Re: AS6104T SPDIF Audio Out No Sound except for KODI.

PostPosted: Wed Jan 15, 2020 4:17 am
by oldwood
PeterKool, Thanks for that it worked for me also.

It seems to be an issue with the volume control not showing??

Thanks,
Gerry