Page 1 of 1


PostPosted: Wed Dec 19, 2018 1:58 am
by jose
Dear All,

I kindly request your support. Currently I am facing problems to watch 4k movies (any kind). I am able to watch them, but after a few seconds, the movie stops and starts again, and it is quite difficult to watch a movie like this. The configuration I have at home is the following: TV Sony A1 4K, NAS server AS6404T, and home cinema Marantz SR6011.
The issue is that NAS Server does not make any transcoding, as it is not needed. CPU load is 40%, but I have never been able to watch a 4k movie. I have tried to use clients at my TV Sony like Plex, Kodi, VLC, Video .....but none of them are solving the problem. I am a little bit frustrated. All cabling I am using between these 3 units is HDMI 2.0 premium certified, therefore I guess is not an issue with the cabling.
When I see 4K videos through Netflix (app installed in my TV) or Youtube ....I do not experience any problem at all ....and the quality is wonderful. However, I am not able to do the same with the movies I have in my NAS server.

Could you please provide some feedback to me on what to do here?

Thanks for reading this.


PostPosted: Wed Dec 19, 2018 10:05 am
by orion
Sounds that your player is on TV side, right? ("clients at my TV Sony like Plex, Kodi, VLC, Video .....") What's your network speed between TV and NAS? Or you installed KODI on NAS (NAS to TV is HDMI?)


PostPosted: Sat Dec 22, 2018 6:41 pm
by jose
Yes. Player it is install on TV (Kodi, plex, VLC ....). Connection between TV (Kodi or Plex client) is done through HDMI to the NAS (Plex Server and directory of movies in 4K). TV and NAS are also connected the the home network (ethernet cable category 6a - cable length 1,5 meters or less between TV, NAS and router).


PostPosted: Sat Dec 22, 2018 6:43 pm
by jose
I have Netflix app installed in the TV. I can reproduce all 4k movies from the Netflix Server without any problem. For that reason I think it is not an issue with the cabling at home ....


PostPosted: Tue Dec 25, 2018 10:25 am
by orion
Those info are actually conflicted: players on TV (netflix, kodi, vlc...) v.s. HDMI connection between TV and NAS. Your players should get video contents from network, right? You confused me successfully. Normally we should expect:

Media player software (TV) <----> media contents (NAS). As I know, HDMI interface is not capable for it. You need to make sure of it.

TV display <---> (media player software + media contents: NAS). That's HDMI interface.


PostPosted: Tue Dec 25, 2018 6:05 pm
by father.mande


to get the real capabilities (hardware acceleration ... only valuable usage) of your HDMI NAS display use the tool : vainfo ... that list
... all profile available for video acceleration
... ... this profile depends first of the hardware but also of the VA-API lib provide (a little old for now : 1.7.2 ... when current for Intel graphic is 2.x and compatible with 2.x driver : 1.8.x )
here after the how-to (in a terminal user root and your admin password) ... on my AS5002T (old) :
Code: Select all
root@AS5002TaPhil:/volume1/.@root # source /usr/local/AppCentral/xorg/CONTROL/
root@AS5002TaPhil:/volume1/.@root # vainfo
libva info: VA-API version 0.39.3
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/local/AppCentral/xorg/lib/dri/
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.2)
vainfo: Driver version: Intel i965 driver for Intel(R) Bay Trail - 1.7.2
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
root@AS5002TaPhil:/volume1/.@root #

4k (not supported by AS5002T) appear as HEVC BUT take care of the profile
... ex. Main support only 8 bits ... so if your source (video file) is 10 bits you can't have video acceleration and go back to software decoding ... bad result even for a largest CPU)



PostPosted: Thu Jan 03, 2019 2:30 am
by jose
thanks for the feeback here.

Orion, I reproduce 4k movies from Netflix , but also I have some 4k movies downloaded in my NAS Server. Therefore both possibilities are compatible.
Yes. I was aware of that. Only 8 bits is possible with this kind of NAS Sever.
Playing with the system, I think I have been able to isolate the problem. It is connected in some how with HDMI ARC ...and I am not able to understand why. If I put this function off in the TV and the Home Cinema, NAS Server is able to reproduce 4k movies without any problem. However, if I put the ARC function on again, then the same movie goes slowly and with a lot of cuts. Therefore I would say that the bottleneck is the HDMI ARC cabling. But Why? In theory the bandwidth of this cable should be enough, as it is HDMI ARC 2.0 and certified.
I may leave the ARC function off and problem solved ....but if I do that, then I am not able to reproduce the sound through the Home Cinema ..... I am getting crazy here ....


PostPosted: Thu Jan 03, 2019 10:53 am
by orion
Sounds that your player should be on NAS side (plex).
After checked, AS6404T seems supporting HEVC 10-bit decoding by CPU hardware. However, the supports on player software is another check point. On the other hand, audio portion could be decoded by NAS player side or by home cinema Marantz SR6011. I'm not sure if there is an option about audio: "HDMI audio pass-through" on plex player. You can check that.

You may try another player on NAS: viewtopic.php?f=98&t=9588 (audio output should set to pass-through)