It is currently Tue Mar 09, 2021 4:06 pm
All times are UTC + 8 hours

No temp reading for we red 4tb

Got a question about our NAS utilities? The answer lies within.

No temp reading for we red 4tb

Postby spikey1973 » Fri Aug 18, 2017 10:04 am

Hello,

I'm about t replace a harddrive (more space needed)
So while looking around I noticed the following..
I have two drives in my as6102.. drive one a 4tb WD red.. and in the second slot.. a seagate barracude 1 TB.. which I'm about to replace..

But I noticed that the barracuda shows a running temperature for the drive.. while the wd doesn't. I never looked at this. Before but it strikes me as odd. I never have had any problems with the drive.. could this still be a failure? Or is it normal for a wd red of 4tb..

I tried to look at specs.. but can't seem to find if it should or shouldn't display temp readings.

Any suggestions would be appreciated!
spikey1973
 
Posts: 66
Joined: Fri Feb 10, 2017 4:11 am

Re: No temp reading for we red 4tb

Postby orion » Fri Aug 18, 2017 11:53 am

I'm surprised. I can always read disk temperature. You can go to ADM web -> Storage Manager -> Disk -> select WD disk -> SMART Info. Did you see ID=194? That's temperature record of this disk.
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: No temp reading for we red 4tb

Postby spikey1973 » Fri Aug 18, 2017 6:30 pm

i checked what you suggested...
smart info: completely empty field. on the other hand for the other disk (already, showing the temp) shows a full list of (smart) data.
Smart scan (full): no error found.. guess it has something to do with smart not being on? although the status is good, and status is healthy

i also rebooted and checked the uefi / bios.. but for 1 i didn't see a reference to s.m.a.r.t as such.. but did find no difference in settings for both drives.
als on boot it clearly stated s.m.a.r.t. enabled. but no reference to a specific drive.
and ofcourse some part is indeed enabled as the 2e slot drive's smart capabilities work great.
spikey1973
 
Posts: 66
Joined: Fri Feb 10, 2017 4:11 am

Re: No temp reading for we red 4tb

Postby orion » Mon Aug 21, 2017 10:02 am

SMART info is generated by HDD itself. So it's surprised that this HDD don't provide ID-194 SMART info.
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: No temp reading for we red 4tb

Postby spikey1973 » Thu Aug 24, 2017 12:42 am

i figured out how to solve it..

i took the drive and connected it externally to my ubuntu laptop.
installed smartmontools:
# sudo apt-get install smartmontools

ran:
# sudo smartctl -i /dev/sdb

to check the drive's info, including smart.

apparently the smart functions can be turned on and off! didn't know either but some googling led me there.

running:
#sudo smartctl -s on /dev/sdb

turned the smart functionality on..

why it wasn't on from the start is somewhat of a mystery to me but it got solved.
hope this will help others.

ps: sdb is just my drive's name, please check you run this on the correct drive on your system for your self!
spikey1973
 
Posts: 66
Joined: Fri Feb 10, 2017 4:11 am

Re: No temp reading for we red 4tb

Postby orion » Thu Aug 24, 2017 10:05 am

Wow, I didn't know that. Thanks for sharing.
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: No temp reading for we red 4tb

Postby spikey1973 » Fri Aug 25, 2017 6:46 am

my pleasure..

i ask a lot,, but once i find stuff out that could be intreresting to all, i try to share.
spikey1973
 
Posts: 66
Joined: Fri Feb 10, 2017 4:11 am

Re: No temp reading for we red 4tb

Postby vitosx » Mon Oct 09, 2017 8:20 pm

Just in case somebody had similar issue, you can install smartctl commandline tool on NAS too. It is available through entware-ng package from App Central.
After installing it you can connect through ssh and launch:
opkg update; opkg install smartmontools
vitosx
 
Posts: 50
Joined: Sun Sep 24, 2017 11:30 pm

Return to NAS Utilities

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest