It is currently Tue Jan 25, 2022 10:26 am
All times are UTC + 8 hours

Cant Install Apps

Got a question about our NAS utilities? The answer lies within.

Cant Install Apps

Postby kc7azo » Fri Jan 14, 2022 5:23 am

I was trying to update Plex today and now i am unable to even install any apps. The App Central with say its installing but won't actually do anything. Any help would be appreciated.

EDIT: just got this error:
Unable to connect to App Central server or connection timeout. Please check your network environment and try again later. (Ref. 5608)
kc7azo
 
Posts: 2
Joined: Fri Jan 14, 2022 5:20 am

Re: Cant Install Apps

Postby image36 » Fri Jan 14, 2022 6:34 am

Im having same issue. When opening app central it never loads gives message "Unable to connect to App Central server or connection timeout. Please check your network environment and try again later. (Ref. 5608)" after factory restore.
image36
 
Posts: 1
Joined: Fri Jan 14, 2022 6:29 am

Re: Cant Install Apps

Postby nimbustorer » Fri Jan 14, 2022 8:36 am

Hello! I've run into the same problem, and here's what I discovered:

(FYI, I ran into this problem regardless of whether I tried to install the very latest version of Plex Media Server directly from an apk file, OR from App Central, which offers, at the moment, a slightly older version of Plex.)

TL;DR - The developer.asustor.com website is down, App Central needs it, but I found a workaround.

Details - The developer.asustor.com site provides the nice app icons that the ADM web interface's App Central uses. I assume it provides more than that, but maybe not for this! Here's why I think that: I did some digging under the hood, and discovered a wget process that seemed to be hung:

Code: Select all
root@mynas:/var/log # netstat -tp | grep -v TIME_WAIT
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 mynas:ssh               mymac:62894             ESTABLISHED 6005/0
tcp        0      0 localhost:1884          localhost:50250         ESTABLISHED 5909/mosquitto
tcp        0      1 mynas:42698             ec2-107-21-242-130.compute-1.amazonaws.com:www SYN_SENT    19298/wget
tcp        0      0 localhost:50250         localhost:1884          ESTABLISHED 6015/cmsmgr
tcp        0      0 mynas:8001              mymac:64376             ESTABLISHED 1746/lighttpd
tcp        0      0 mynas:8001              mymac:64647             ESTABLISHED 1746/lighttpd

Code: Select all
root@mynas:/volume1/.@root # ps -ef | grep 19298
19298 root      0:00 /usr/bin/wget -O /usr/local/AppCentral/plexmediaserver/CONTROL/icon-server.png http://developer.asustor.com/uploadIcons/0020_999_1596450666_plex.png

So, I tried downloading it myself, using a browser. No luck, and a little sleuthing reveals that the website is, indeed, down right now. So I found a random little png icon to use instead, put it in the /usr/local/AppCentral/plexmediaserver/CONTROL directory, named it "icon-server.png" and assigned it user/group/file attributes that matched a similar png image already in there:

Code: Select all
root@mynas:/volume1/.@plugins/AppCentral/plexmediaserver/CONTROL # ls -al
total 64
drw-rw-r--    2 root     root          4096 Jan 13 15:58 ./
drwxr-xr-x    5 5556     5556          4096 Jan 13 15:52 ../
-rw-rw-r--    1 root     root           127 Jan 12 11:02 changelog.txt
-rw-rw-r--    1 root     root          1061 Jan 12 11:04 config.json
-rw-rw-r--    1 root     root            81 Jan 12 11:02 description.txt
-rw-r--r--    1 root     root          3017 Jan 13 15:52 icon-disable.png
-rw-rw-r--    1 root     root         10343 Jan 12 11:02 icon-enable.png
-rw-rw-r--    1 root     root         10343 Jan 12 11:02 icon.png
-rwxr-xr-x    1 root     root          1592 Jan 12 11:02 start-stop.sh*

Code: Select all
chown root:root icon-server.png
chmod 664 icon-server.png

I then killed the process that was running that hung wget...
Code: Select all
kill -9 19298
...and the install immediately finished up in App Central -- it would seem that when I killed the wget process, having already done its work for it, the rest of the install went off without a hitch.

And yes, I now have a slightly wonky looking icon in App Central for my Plex Media Server install... lol

Hope that helps. :)
nimbustorer
 
Posts: 1
Joined: Fri Jan 14, 2022 8:11 am

Re: Cant Install Apps

Postby kc7azo » Fri Jan 14, 2022 9:12 am

I will try to replicate your results!
kc7azo
 
Posts: 2
Joined: Fri Jan 14, 2022 5:20 am

Return to NAS Utilities

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 4 guests