It is currently Tue Mar 09, 2021 4:10 pm
All times are UTC + 8 hours

Configuring a VPN Service on the Asusutor

Configuring a VPN Service on the Asusutor

Postby AnubisB » Thu Jan 21, 2021 6:34 am

Hello,

I am trying to setup a VPN on my 6604 but not succeeding so far.

I want to use Sonar & Radar to to download my media, but want to do so from behind a VPN as one does on a PC.

I setup Radar, and Sonar, but cant move forward without a VPN.

I use Cyberghost VPN, so I tried following the tutorial on Asustor website, https://www.asustor.com/en-gb/online/Co ... ?topic=322, but it still doesn't work.

Can anyone help me out,

Thank you
AnubisB
 
Posts: 10
Joined: Wed Jan 20, 2021 8:28 am

Re: Configuring a VPN Service on the Asusutor

Postby orion » Thu Jan 21, 2021 10:03 am

You need to post the details about the error. Or no one knows what's going on.
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: Configuring a VPN Service on the Asusutor

Postby AnubisB » Fri Jan 22, 2021 6:12 am

This is the error I get.

I am sure I have input the right data in, I checked 4 times.

Appreciate any help I can get.
Attachments
Capture.JPG
Capture.JPG (71.84 KiB) Viewed 259 times
AnubisB
 
Posts: 10
Joined: Wed Jan 20, 2021 8:28 am

Re: Configuring a VPN Service on the Asusutor

Postby orion » Fri Jan 22, 2021 10:00 am

The error is at the connection step. I believe you'll need to contact to Cyberghost VPN.

On the other hand, I think you can try those settings under PC first (use standard openvpn tool, rather than Cyberghost VPN software). That might be helpful to identify what's the problem.
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: Configuring a VPN Service on the Asusutor

Postby AnubisB » Mon Jan 25, 2021 8:26 am

Hi Orion,
So I did what you suggested and downloaded an open VPN client onto my PC and used the same credentials that I used to setup the Lockerstor and it worked perfectly with no issues at all.
This leads to the conclusion that it is not the connection, it is the configuration on the NAS which I followed to the letter as per their tutorial.

Any ideas?
AnubisB
 
Posts: 10
Joined: Wed Jan 20, 2021 8:28 am

Re: Configuring a VPN Service on the Asusutor

Postby orion » Mon Jan 25, 2021 10:01 am

mm... I cannot deduce what's the problem without detailed log. I'll suggest you to send a support request to asustor. They should be able to check it remotely. https://support.asustor.com/
User avatar
orion
 
Posts: 2946
Joined: Wed May 29, 2013 11:09 am

Re: Configuring a VPN Service on the Asusutor

Postby AnubisB » Sun Jan 31, 2021 3:49 am

Hi all,
I just wanted to let you know the updates, So I switched VPN providers from Cyberghost to Express VPN and Voila! Everything worked!
It was obviously something to do with Cyberghost.
Express VPN also came with AMAZING speeds, much better than Cyberghost.

Just wanted to let you know how it was resolved, thanks to all that helped.
AnubisB
 
Posts: 10
Joined: Wed Jan 20, 2021 8:28 am

Re: Configuring a VPN Service on the Asusutor

Postby cutedrake » Sat Mar 06, 2021 9:40 pm

I suggest you to use a docker for that instead of the AppCentral package, since using the standard solution from Asustor makes the whole traffic pass through the VPN. Instead, by using the haugene/transmission-openvpn docker instance, you make only the transmission traffic pass through the VPN. This is far better for example if you plan to host your own website, since you will benefit from the local loopback. Otherwise, if you want to access for example a local Nextcloud instance, all the traffic will go through the VPN!
cutedrake
 
Posts: 8
Joined: Wed Jan 13, 2021 10:23 pm

Return to [Official] For AS52xx/53xx/66xx Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest