It is currently Sat Oct 16, 2021 8:13 pm
All times are UTC + 8 hours

AS5304T Wake on WAN (WoW) Enablement

AS5304T Wake on WAN (WoW) Enablement

Postby kclew » Mon Sep 20, 2021 11:16 am

Hello all,

I would like to ask if anyone manage to get WoW to work on AS5304T after putting the system on sleep? It says it is supported on 2.5Gb which it has 2 of it. (https://www.asustor.com/solution/wake_on_wan#wow).

I had connected the NAS 2.5Gb port to my Asus RT-AC68U router which only has 1Gb port. Will this impact the WoW functionality?

I had manage to use the WoL function and had configured the NAS to be accessible from internet via AiMaster.

Appreciate any advise.


Regards
kclew
 
Posts: 3
Joined: Fri Sep 17, 2021 11:21 am

Re: AS5304T Wake on WAN (WoW) Enablement

Postby Nazar78 » Tue Sep 21, 2021 12:50 am

Log into your Asus RT-AC68U's admin page, WAN -> Virtual Server / Port Forwarding. Enable the port forwarding. Then add the following profile, under Custom Configuration:

Service Name: WOW
Protocol: UDP
External Port: 9
Internal Port: empty (default to same as external port 9)
Internal IP Address: Your AS5304T local IP
Source IP: empty

The above is assumed your WAN on TCP IPv4. If you're on TCP IPv6, you just need to allow the firewall passthrough UDP 9 under Firewall -> General -> Inbound Firewall Rules:
Service Name: WOW
Remote IP/CIDR: empty
Local IP: empty
Port Range: 9
Protocol: UDP
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 489
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: AS5304T Wake on WAN (WoW) Enablement

Postby kclew » Tue Sep 21, 2021 11:15 am

Hello Nazar,

Thanks very much for the detailed info below. Appreciate very much.

I had enabled port 8000,8001 (TCP, UDP) and 9 (UDP) on my AC86U. I can see the services running on Sytem Log -> Port Forwarding.

I had also configured 5304T in Settings-> Manual Connect -> DDNS and EZ-Router.
a) DDNS - I can connect to my NAS using browser from my mobile both using Cloud ID and DDNS.
b) EZ-Router - It was showing status when I was configuring them last week. However, now it just gives an error "No UPnP/NAT-PMP router found or your router does not have UPnP/NAT-PMP enabled (ref:5318)".

I have a AiMesh setup in my LAN:
1) AC86U - AiMesh router
2) AC68U - AiMesh node - 5304T is connected here.

Just a curious question if 5304T 2.5Gb port must be connected to 2.5Gb port on router for WoW to work? Since that's how info/table showed by Asustor.


Regards
kclew
 
Posts: 3
Joined: Fri Sep 17, 2021 11:21 am

Re: AS5304T Wake on WAN (WoW) Enablement

Postby Nazar78 » Tue Sep 21, 2021 12:01 pm

NP. I personally don't use UPnP. It opens security risks and not 100% reliable. So I manually managed all my ports, IPv4 via port forwarding and IPv6 via firewall.

8000,8001 (TCP, UDP)
You only need TCP for both 8000(HTTP)/8001(HTTPS). Since I manually managed my ports, I didn't open any of these two ports. Instead I did a reverse proxy from a front-facing HTTPS port 443 to the NAS's internal HTTP port 8000.

Just a curious question if 5304T 2.5Gb port must be connected to 2.5Gb port on router for WoW to work? Since that's how info/table showed by Asustor.
1G ethernet ports on the router will work too. For troubleshooting, connect the NAS directly to the main router.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 489
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: AS5304T Wake on WAN (WoW) Enablement

Postby kclew » Thu Sep 23, 2021 10:38 am

Hello Nazar,

Connected my NAS directly to main router AC86U, still cannot WoW. WoL no problem.

Will continue to search internet if there are any pointer or tips.

Thanks for all the help.
kclew
 
Posts: 3
Joined: Fri Sep 17, 2021 11:21 am

Re: AS5304T Wake on WAN (WoW) Enablement

Postby orion » Thu Sep 23, 2021 10:56 am

Not sure what happened neither. I'll suggest you to send a support ticket to asustor directly. https://support.asustor.com/ They should be able to get detailed logs remotely.
User avatar
orion
 
Posts: 3187
Joined: Wed May 29, 2013 11:09 am

Re: AS5304T Wake on WAN (WoW) Enablement

Postby Nazar78 » Thu Sep 23, 2021 6:46 pm

kclew wrote:Hello Nazar,

Connected my NAS directly to main router AC86U, still cannot WoW. WoL no problem.

Will continue to search internet if there are any pointer or tips.

Thanks for all the help.

You can try troubleshoot if the request actually went through from the internet. Simply install Debian Linux Center (mine has been modded to Ubuntu), then open the terminal and run:
Code: Select all
sudo nc -ul 9

The command will halt waiting for input but you'll see some gibberish characters (Magic Packets) when you try to wake the NAS from the WAN, provided you've correctly port forward the UDP port 9 from your router to your NAS IP as mentioned previously. If you're using an Android, try the WOL app from Google Play Store: https://play.google.com/store/apps/deta ... .wakeonlan
Screenshot 2021-09-23 184303.png
Screenshot 2021-09-23 184303.png (30.4 KiB) Viewed 199 times
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 489
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Return to [Official] For AS52xx/53xx/66xx Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 2 guests