It is currently Thu Dec 03, 2020 2:45 pm
All times are UTC + 8 hours

[MH-Kodi] please think to use (internal) update to get last version (18 or 19)

myHD is an isolated (namespace (mnt, IPC, PID)) Ubuntu environment to run Ubuntu application displayed as ASUSTOR Asportal / Xorg applications.

Moderator: father.mande

[MH-Kodi] please think to use (internal) update to get last version (18 or 19)

Postby father.mande » Tue Aug 18, 2020 8:58 pm

Hi,

Just to remember, if you use myHD and MH-kodi, you can update to last version using the Ubuntu standard update
use : myHD apt_upgrade_package
or :
enter in myHD Ubuntu env. as root (the Ubuntu one)
myHD_root
then update and upgrade
apt-get update ; apt-get -y dist-upgrade
... this not only upgrade kodi or others ... but also upgrade to last security patch and last version of VA-API (video acceleration) and new functionnality not always available under A.D.M.

Actual versions available are :
2:19.0+git20200818.0307 for advanced user using Kodi19
2:18.6+dfsg1-2ubuntu1

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1047
Joined: Sat Sep 12, 2015 2:55 am

Re: [MH-Kodi] please think to use (internal) update to get last version (18 or 19)

Postby BigErn » Wed Aug 19, 2020 1:52 am

I'm on an AS5304T on ADM 3.5.0.R5D3. I'm trying to update the Kodi 18. I've tried to do this through SSH using putty with the commands you provided here and using the update Ubuntu button in the myHD web interface. It errors out every time with this message:

Preparing to unpack .../libc6_2.27-3ubuntu1.2_amd64.deb ...
/var/lib/dpkg/tmp.ci/preinst: 132: [: Illegal number:
/var/lib/dpkg/tmp.ci/preinst: 9: /var/lib/dpkg/tmp.ci/preinst: arithmetic expression: expecting primary: "4 * 10000 + 14 * 100 + "
dpkg: error processing archive /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb (--unpack):
new libc6:amd64 package pre-installation script subprocess returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 65 not upgraded.
Last edited by BigErn on Wed Aug 19, 2020 4:17 am, edited 1 time in total.
BigErn
 
Posts: 11
Joined: Tue Jan 28, 2020 9:11 am

Re: [MH-Kodi] please think to use (internal) update to get last version (18 or 19)

Postby father.mande » Wed Aug 19, 2020 4:07 am

Hi,

Yes it's a know (now) bug due to libc update that don't support malformed Asustor kernel version : 4.14.x (x generate error in calculation)
so the solution is to change this value for the update

... this will be solved in next update of myHD (soon I hope)

To solve it do :
in a ssh terminal connect using root/your_admin_password (not admin)
enter in myHD environment :
myHD_root
cd /bin
mv uname uname.asustor
echo -e '#!/bin/sh\n\n/bin/uname.asustor "$@"'"|sed 's/\\.x/\\.187/g'">uname
chmod +x uname

exit OR redo update ... : apt-get update; apt-get -y dist-upgrade

After IF YOU exit : redo the update / upgrade using Web interface or command line tool

Sorry for that ... I don't imagine this before I fail in the problem ;) :mrgreen:

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1047
Joined: Sat Sep 12, 2015 2:55 am

Re: [MH-Kodi] please think to use (internal) update to get last version (18 or 19)

Postby BigErn » Wed Aug 19, 2020 4:18 am

Thanks for your quick reply. Now the upgrade worked as it should. I had seen you mention that error in another forum, but forgot that it applied here.

I tried to upgrade Kodi many times using the instructions here with the built-in updater in the myHD web interface and using SSH, but it was always stuck on Kodi version 18.3, until I saw that you have to add the Kodi repository with this command:
Code: Select all
add-apt-repository ppa:team-xbmc/ppa
After that Kodi updated to the latest version 18.9.

And after doing that Dolby Atmos/TrueHD audio stopped working. I tried to uninstall and go back to the prior version of Kodi, but then it was stuck on version 18.1 and wouldn't boot so I just ended up removing all of myHD.
BigErn
 
Posts: 11
Joined: Tue Jan 28, 2020 9:11 am

Re: [MH-Kodi] please think to use (internal) update to get last version (18 or 19)

Postby eviljack » Mon Oct 26, 2020 4:57 pm

Hello,

I try to do Ubuntu update but I have the same problem and dont know which password to use. When I try user root with password for my admin account its not ok. Im newbie with linux so sorry for stupid question...

EDIT: sorry, my mistake, I had inactive "admin" account...
Asustor 6102T 8GB RAM (2*4GB Crucial CT51264BF160BJ)
Yamaha RX-V785
Ryzen 3600X, 48GB RAM, RTX 2060 8GB
eviljack
 
Posts: 3
Joined: Fri Oct 23, 2020 10:08 pm

Return to myHD

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest