It is currently Fri Jun 25, 2021 2:38 pm
All times are UTC + 8 hours

No Internet Connection inside Debian Desktop

Linux Center is Linux Container APP, can run different isolated Linux systems on Asustor Nas system using a single Linux kernel.

No Internet Connection inside Debian Desktop

Postby lmag » Tue Dec 17, 2019 9:06 pm

Hi! I am getting no Internet connection inside Debian Desktop after installing it in Linux Center. I can't even install packages. Already tried resetting and reinstalling everything to no avail. ADM can access the Internet whithout problems. Is there a network configuration that I am missing? Please help.
lmag
 
Posts: 2
Joined: Tue Dec 17, 2019 8:58 pm

Re: No Internet Connection inside Debian Desktop

Postby Nazar78 » Wed Dec 18, 2019 2:17 am

Can you see the IP to ssh when you open the Linux Center app?

If yes, try opening the browser inside Debian Destop then browse to the ADM or router IP i.e. http://192.168.1.1. Can you reach those pages? If yes most probably your DNS is wrong. Open the terminal switch to root, su -, password same as admin, then edit this file using vi or nano, /etc/resolv.conf. Ensure the nameserver is set to your router's IP or you can use Google's 8.8.8.8. In case this file doesn't exist, go ahead create one with the content "nameserver 192.168.1.1" without quotes where that IP refers to your router's or Google DNS. You can provide multiple DNS servers up to 3 e.g.:

nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 1.1.1.1

Refer to man resolv.conf for more details.

If you can't see the IP to ssh or couldn't reach any of those IPs then either the selected interface is wrong (if you have dual LAN port not in load balancing mode, check Linux Center settings ensure the correct interface is selected) or probably the network settings in Debian itself which you can try setting it manually to static IP in this file /etc/network/interfaces then restart the networking service. Refer to man interfaces for more details.

I don't know your NAS model and I'm replying from my mobile of my mind. For more details you could easily look it up from the hints provided.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 295
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: No Internet Connection inside Debian Desktop

Postby jbo » Sat Jul 25, 2020 5:20 am

Hello,

I have a same issue with a debian server installation.
I try to modify resolv.conf without succes.

Actually 192.168.1.1 is the ip of the router (livebox).
NAs and the debian have also static ips.

I don't have any idea to solve the issue.
Every help is welcomed.
jbo
 
Posts: 12
Joined: Tue Sep 02, 2014 7:45 pm

Re: No Internet Connection inside Debian Desktop

Postby father.mande » Sat Jul 25, 2020 2:49 pm

Hi,

Please first check (and post here) the network config ... starting with resolv.conf is good (common problem) but the best is to start from low level
1 connect to A.D.M. terminal (ssh) with root / your_admin_password and print network info
... use ifconfig or ip (ip addr show / ip link show)
2 do the same in Debian Desktop

I don't know how Asustor manage network for Linux Center, but I suppose it's a "standard" Linux container within manager like docker or directly managed (as I do with my own Ubuntu environment in my APKG)

container support multiple network configuration (here short short short explain :mrgreen: ) :
... host one (so share host I.P. and port table) generally no problem except port already used ...
... veth connections ... so use a private link between A.D.M. and Linux center ... so require routing and or masquerading in A.D.M. to connect container to Internet or other system on LAN
... ... debug can be done using A.D.M. tools like iptables and ip route tool
... macvlan connection ... it's an independent I.P. on same adapter (so with private I.P. and port table) able to be considered as independent server connect to box with DHCP or static
... ... debug is reduced in A.D.M. (only verify that adapter is in promiscuous mode ... require to exchange data)
... ... or external verify with mac address that a DHCP address is done by box EVEN static configured, some box also refuse to provide multiple I.P. on same Mac address ...
... direct connection ... so container use a specific Ethernet link ... not the eth use by A.D.M.
... ... common problem in this case is that A.D.M. already attach an address to this Ethernet when connected to the LAN ... so freeing it is enough to solve connect problem

If network appear correct ... use tools like traceroute to understand way used by data when you try to join some site ...

If you have not enough tools or not complete version, remember that Entware bring you lot of GNU complete tools to get more details and informations.

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1187
Joined: Sat Sep 12, 2015 2:55 am

Re: No Internet Connection inside Debian Desktop

Postby jbo » Sun Jul 26, 2020 5:56 am

Thank you Philippe for your answer.

I notice you maintain entware-ng among other.
Actually, i thought about linux center because i would like to install megacmd and it is not planned for datasync or the app central...
I will check if there is an up-to-date package for entware (i am not familiar with entware). If i don't have connectivity and security issues, it could be a perfect solution.

Otherwise, i will check your kind explanations.
And i will compare with my data:

NAS

Code: Select all
admin@premier:/volume1/home/admin $ ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master eth0-br qlen 1000
    link/ether 10:bf:48:8a:fc:b2 brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq qlen 1000
    link/ether 10:bf:48:8a:fd:b6 brd ff:ff:ff:ff:ff:ff
4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
    link/ether 02:42:b0:b2:e1:bd brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever
    inet6 fe80::42:b0ff:feb2:e1bd/64 scope link
       valid_lft forever preferred_lft forever
6: veth8d60152@if5: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master docker0
    link/ether a6:be:60:57:05:40 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a4be:60ff:fe57:540/64 scope link
       valid_lft forever preferred_lft forever
9: nat-br: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue qlen 1000
    link/ether fe:36:54:3a:ee:cc brd ff:ff:ff:ff:ff:ff
    inet 10.172.5.1/24 brd 10.172.5.255 scope global nat-br
       valid_lft forever preferred_lft forever
    inet6 fe80::c474:8cff:fe08:326b/64 scope link
       valid_lft forever preferred_lft forever
10: eth0-br: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue qlen 1000
    link/ether 10:bf:48:8a:fc:b2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.60/24 brd 192.168.1.255 scope global eth0-br
       valid_lft forever preferred_lft forever
    inet6 fe80::12bf:48ff:fe8a:fcb2/64 scope link
       valid_lft forever preferred_lft forever
12: veth5UVHAM@if11: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master nat-br qlen 1000
    link/ether fe:36:54:3a:ee:cc brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc36:54ff:fe3a:eecc/64 scope link
       valid_lft forever preferred_lft forever
14: vethMCQ890@if13: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master eth0-br qlen 1000
    link/ether fe:0c:c0:a1:0f:a4 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc0c:c0ff:fea1:fa4/64 scope link
       valid_lft forever preferred_lft forever
admin@premier:/volume1/home/admin $ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master eth0-br qlen 1000
    link/ether 10:bf:48:8a:fc:b2 brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq qlen 1000
    link/ether 10:bf:48:8a:fd:b6 brd ff:ff:ff:ff:ff:ff
4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
    link/ether 02:42:b0:b2:e1:bd brd ff:ff:ff:ff:ff:ff
6: veth8d60152@if5: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master docker0
    link/ether a6:be:60:57:05:40 brd ff:ff:ff:ff:ff:ff
9: nat-br: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue qlen 1000
    link/ether fe:36:54:3a:ee:cc brd ff:ff:ff:ff:ff:ff
10: eth0-br: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue qlen 1000
    link/ether 10:bf:48:8a:fc:b2 brd ff:ff:ff:ff:ff:ff
12: veth5UVHAM@if11: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master nat-br qlen 1000
    link/ether fe:36:54:3a:ee:cc brd ff:ff:ff:ff:ff:ff
14: vethMCQ890@if13: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue master eth0-br qlen 1000
    link/ether fe:0c:c0:a1:0f:a4 brd ff:ff:ff:ff:ff:ff
admin@premier:/volume1/home/admin $


DEBIAN

Code: Select all
admin@LXCDEBIAN10S:~$ ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
11: eth1@if12: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether b2:f4:a5:06:56:eb brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 10.172.5.2/24 brd 10.172.5.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::b0f4:a5ff:fe06:56eb/64 scope link
       valid_lft forever preferred_lft forever
13: eth0@if14: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether be:5d:af:96:35:0a brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 192.168.1.32/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 71824sec preferred_lft 71824sec
    inet6 fe80::bc5d:afff:fe96:350a/64 scope link
       valid_lft forever preferred_lft forever
admin@LXCDEBIAN10S:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
11: eth1@if12: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether b2:f4:a5:06:56:eb brd ff:ff:ff:ff:ff:ff link-netnsid 0
13: eth0@if14: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether be:5d:af:96:35:0a brd ff:ff:ff:ff:ff:ff link-netnsid 0
jbo
 
Posts: 12
Joined: Tue Sep 02, 2014 7:45 pm

Re: No Internet Connection inside Debian Desktop

Postby father.mande » Sun Jul 26, 2020 3:22 pm

Hi jbo,

I will have a look to result ... but Asustor used linux bridge and veth and perhaps direct link or macvlan link, so investigating require more command ...
I can't enter in your system to check ... so I will try, even it's not in my plan, to install Linux Center and can directly try to understand how it is build and where are the potential problem similar to your own.

So please wait (I have to stop some dev.), or wait for other support here or ... ask Asustor support.

In second hand ... Entware is now the ONLY version to used (Entware-ng is an oldest up to all platform use the same structure as now with Entware today x86(32 bits), x86_64, armhf (arm for Asustor), arm64 (arm 64 bits))
in Entware you can get megacmd tools (in the 1900 package proposed)
Code: Select all
opkg list | grep mega
libmega - 3.7.0-1 - MEGA SDK - Client Access Engine (library).
megacmd - 1.2.0-1 - MEGAcmd provides non UI access to MEGA services. It intends to offer all the functionality with your MEGA account via commands.
meganz-sdk - 3.7.0-1 - MEGA SDK - Client Access Engine (utility).


Entware is a package manager for package coming from OpenWRT for a large number of platform
... after install ... all library (updated including basic one like libc ... 2.27 compare to 2.22 for A.D.M.) all program, data, config file are in /opt in A.D.M. ... all program run as native mode inside A.D.M. without containers
... by default all user / group / password and network are the same and ALL A.D.M. files & folder are accessible as any A.D.M. command tools.
... after install (and reconnect terminal to get correct PATH (automatic) you have one command opkg (openwrt package manager)
... init script are in /opt/etc/init.d and use standard init file name style Snnxxxxxx ... (nn is the order)
... config file are generally in /opt/etc

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1187
Joined: Sat Sep 12, 2015 2:55 am

Re: No Internet Connection inside Debian Desktop

Postby Nazar78 » Sun Jul 26, 2020 3:25 pm

jbo wrote:Hello,

I have a same issue with a debian server installation.
I try to modify resolv.conf without succes.

Actually 192.168.1.1 is the ip of the router (livebox).
NAs and the debian have also static ips.

I don't have any idea to solve the issue.
Every help is welcomed.


The network should work right out of the box when you first launch the LXC. And your interfaces seems looks ok too. Which Debian server you did install? 10 Buster?

Can you reach ADM from Debian using IP only? Try SSH from Debian to the NAS:
Code: Select all
ssh -oConnectTimeout=1 192.168.1.60
or
Code: Select all
ssh -oConnectTimeout=1 10.172.5.1
Getting any errors besides timeout is a good sign.

Please provide the following from Debian:
Code: Select all
ip route


You might want to test switching the default gateway to eth0, try below in Debian:
Code: Select all
sudo /sbin/route delete default gw 10.172.5.1 dev eth1
sudo /sbin/route add default gw 192.168.1.1 dev eth0
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 295
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Re: No Internet Connection inside Debian Desktop

Postby father.mande » Sun Jul 26, 2020 5:27 pm

Hi,

Just install L.C. to have a look

1 sorry, my error, it's a tiers provider NOT Asustor ... so support is not done by Asustor

2 install debian10-desktop
... test using default software install ... no problem (veth - veth - masquerade in A.D.M.)
... test changing default gateway to use LAN I.P. ... no problem

so I can't reproduce your problem ... ???
I suggest to try the change gateway (as Nazar78 also have proposed) ... but no reason in the delivery to have to do it ...

I have stopped my test ... but in some days I will analyse totally the network and the low level bridge for getting a LAN I.P.

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1187
Joined: Sat Sep 12, 2015 2:55 am

Re: No Internet Connection inside Debian Desktop

Postby jbo » Mon Jul 27, 2020 5:33 am

Thank you father.mande and nazar78 for your answers.

Here are the return:
Code: Select all
admin@LXCDEBIAN10S:~$ ssh -oConnectTimeout=1 192.168.1.60
Could not create directory '/home/admin/.ssh'.
The authenticity of host '[192.168.1.60]:22 ([192.168.1.60]:22)' can't be established.
ECDSA key fingerprint is SHA256:qaKe9D/iaGOCD+VJ1xFBou82GIfpTz9F2fA+LM9Law8.
Are you sure you want to continue connecting (yes/no)? yes
Failed to add the host to the list of known hosts (/home/admin/.ssh/known_hosts).
Password:
admin@premier:/volume1/home/admin $ exit
Connection to 192.168.1.60 closed.
admin@LXCDEBIAN10S:~$     ssh -oConnectTimeout=1 10.172.5.1
ssh: connect to host 10.172.5.1 port 22: Connection refused
admin@LXCDEBIAN10S:~$ ip route
default via 10.172.5.1 dev eth1
10.172.5.0/24 dev eth1 proto kernel scope link src 10.172.5.2
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.32
admin@LXCDEBIAN10S:~$


I try the change gateway as Nazar78 suggested.
It seems to solve the issue.

As i don't know if it will be permanent when the nas will reboot, i would like to understand exactly what the problem was...

Above all, thank you for the help.
jB

Ps: @Philippe, i will have a look at entware.
jbo
 
Posts: 12
Joined: Tue Sep 02, 2014 7:45 pm

Re: No Internet Connection inside Debian Desktop

Postby Nazar78 » Mon Jul 27, 2020 3:15 pm

jbo wrote:As i don't know if it will be permanent when the nas will reboot, i would like to understand exactly what the problem was...

It's temporary and will be lost once the container restarts, just like any real OS.

You can try add it in the Debian's /etc/network/interfaces, add right after the "iface eth0 inet dhcp":
Code: Select all
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
   post-up route del default gw 10.172.5.1;\
      route add default gw 192.168.1.1 metric 0;\
      route add default gw 10.172.5.1 metric 1

source /etc/network/interfaces.d/*.cfg

Test reboot or systemctl restart networking.service or service networking restart, then ip route or traceroute -d google.com to confirm. The above should work but if that doesn't help, create a startup script or cron @reboot then add those route commands.

As for the root cause I'm not sure exactly as it works fine on mine, need more debugging.
AS5304T - 16GB DDR4 - [40TB N300 RAID10 + 5 Bay USB: 8TB RAID5 & 480GB SSD for Apps]
User avatar
Nazar78
 
Posts: 295
Joined: Wed Jul 17, 2019 10:21 pm
Location: Singapore

Next

Return to Linux-Center

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest