It is currently Sun May 16, 2021 11:51 pm
All times are UTC + 8 hours

ADM 3.5 SW issues

ADM 3.5 SW issues

Postby Simonix » Thu May 21, 2020 12:38 am


I just got my new AS4002T that I've initialized with ADM 3.5.0.R5D3.

So far, I'm unfortunately rather disappointed by the quality of the software. For reference, I'm coming from the QNAP & OMV world.

1. Looksgood was installed during the initialization process but did not work: log in impossible. I uninstalled it, installed MariaDB and reinstalled. Then it worked but got broken again following a NAS reboot.

2. The recycle bin folder is present in the shared folder even if that function is turned off - odd

3. The recycle bin folder requires admin rights regardless of the setting "Only accessible by administrator group users"

4. With BTRFS, no quotas can be set (neither at user nor folder level)

5. Not possible to limit the Time Machine size limit from the UI at any level: AFP, quota (due to point 4)

6. Time Machine requires to have AFP enabled while competitors can rely on SMB only. Activating AFP & Time machine makes the mac to see the time machine share as SMB first and then falls back to AFP - odd again

7. I'm having issues to see the SMB shares in the network neighborhood regardless of Mac or Windows machines

Any help on these points would be very much appreciated.


PS: surprised to see this device using a kernel 4.4 introduced first in... 2016.
PS2: the ADM web interface is not usable on iPhone or iPad?! AiMaster doesn’t fill that gap.
Posts: 12
Joined: Sat May 16, 2020 5:16 am

Re: ADM 3.5 SW issues

Postby Simonix » Thu May 28, 2020 3:36 pm

I've done some investigation myself.

1. Apparently Looksgood 'works' only if media are added right after Looksgood installation. Otherwise, no login possible.
Anyway, I've decided not to use it for several reasons: format not supported, no DLNA server integrated, errors in the sorting/covers... I've tried both Jellyfin (run in Docker) & Plex. Jellyfin is very promising but not as polished as Plex yet. For instance, the DLNA server showed many media as incompatible for no reason and seemed heavier in terms of resources.

5. I wanted to limit the space allocated to Time Machine in the afp config. That works but such change ends up overwritten by the system.

7. It seems like some SMB settings influence this to become better or worse.

I've created a ticket which I hope will help get some fixes. At this stage, I'm unfortunately considering returning the product.
Last edited by Simonix on Tue Jun 16, 2020 10:24 pm, edited 2 times in total.
Posts: 12
Joined: Sat May 16, 2020 5:16 am

Re: ADM 3.5 SW issues

Postby Simonix » Thu May 28, 2020 7:12 pm

And one more bug found. I have 2 apps that can be updated but the app central icon shows "1".
Posts: 12
Joined: Sat May 16, 2020 5:16 am

Re: ADM 3.5 SW issues

Postby Simonix » Tue Jun 16, 2020 10:02 pm

So this is the end of the road for me and Asustor. I will unfortunately return this product because of the software quality and poor support.

I created 3 weeks ago a ticket which did not bring any real answer nor solutions. The most I got from the support was to confirm that Asustor does not support any kind of quotas (user level nor folder level) with BTRFS.

This means that there is currently no way to use an Asustor NAS with BTRFS and Time Machine with 1 volume since Time Machine will use all the available space.

This is very disappointing as there are ways to limit Time Machine regardless of the file system. Netatalk offers the 'vol size limit' parameter and samba offers the option.

PS: the support asking admin access right without supervision was chocking!
Posts: 12
Joined: Sat May 16, 2020 5:16 am

Return to [Official] For AS40XX Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest