It is currently Sun May 16, 2021 11:01 pm
All times are UTC + 8 hours

Firmware update error 5502

Firmware update error 5502

Postby machapman » Sun Jun 02, 2019 5:37 am

In March I bought a new AS4004 NAS and since then I've been unable to update the firmware. It repeatedly fails with a 5052 error. I have tried everything; different disks, factory resets, manual and automatic updates etc.
In March I raised a ticket with Asustor support, but the problem has not been resolved. Unfortunately my router isn't able to auto-configure Asus Cloud access using UPNP. So I manually configured ssh access instead and have set up DDNS using Draytek's DDNS facility. Asustor technicians seem unable to use this despite the fact I can log in with no problem and have been trying to get me to sort out Asustor cloud access instead of just ssh-ing in and sorting the issue out using the access that is currently available.
I'm getting really fed-up with the lack of progress - so does anyone else have any idea what error 5052 is and how I can get ADM updated?
I'm also not happy with having to leave my network permanently open like this while Asustor do nothing much. UPNP on a router is a security risk and I normally would not allow random addresses to ssh into my servers. But it seems I have no alternative if I want to stop my new NAS being a useless brick.
Posts: 2
Joined: Sun Jun 02, 2019 5:20 am

Re: Firmware update error 5502

Postby orion » Mon Jun 03, 2019 11:09 am

I don't know what's the error 5502/5052. You can try to ask asustor support to give you the firmware file. You can do manual upgrade (off-line upgrade).
User avatar
Posts: 3042
Joined: Wed May 29, 2013 11:09 am

Re: Firmware update error 5502

Postby machapman » Wed Jun 05, 2019 2:39 am

I have tried doing manual upgrades. I have tried every firmware possible for this unit from the upgrade one version newer to the very latest. Every single firmware gives a 5502 error.
Posts: 2
Joined: Sun Jun 02, 2019 5:20 am

Re: Firmware update error 5502

Postby Andrii » Thu Oct 08, 2020 5:51 pm


It looks like I have this problem also: viewtopic.php?f=27&t=11420&p=37135&hilit=Ref.+5052#p37135

I'm wondering, how did you solved it? It's really frustrating that such a big company like Asustor doesn't provide comprehensive support for their products :) I'm starting to think about to sell my Asustor NAS and buy from some other vendor - Synology (a couple of my friends are having such NAS devices and they're happy with them - everything is cleat and the support is really great)
Posts: 5
Joined: Thu Oct 08, 2020 5:13 pm

Re: Firmware update error 5502

Postby father.mande » Thu Oct 08, 2020 6:32 pm


I don't think it's linked to certificate ... but
Also x86_64 can't be compare to Arm64 series
... you can change or upgrade memory
... you can boot from USB and check DOM (Disk on Memory)

Arm64 series (AS4004)
... memory is soldered
... DOM is in fact a flash memory with only one visible partition /dev/mtdblock0
... nothing (as I know) is documented (for user) to add a console or to boot from USB ...

The error ... seems to be attached (but it's only my opinion) to memory ... update process don't have the same control than in operation ... so a NAS can run (managing memory error) without visible problems ... ONLY using a stress program can help to discover hidden problem.

For x86_64 lot of possible solutions exist ... it's unfortunately more difficult for Arm or Arm64 series (I don't own an Arm64 model ... so I can't test or open it ... )

I suggest you to P.M. to Shawn.S@AST (email or P.M.) from the forum ... Shawn is very attached to offer as possible a good support to users. (click "members" he is in the first list)

At end, I own multiple NAS from different Brand ... Syno, Qnap, etc. etc. ... don't dream without big problem as yours, if support is only for software and basic usage ... you get the same result ... when the problem is complicated (even with "unknown error code" or hardware potential problem) ... no difference up you climb to level 2 or 3 ... the first level can be less efficient than user in the forum ... (ex. orion expertise)

AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG :
User avatar
Posts: 1161
Joined: Sat Sep 12, 2015 2:55 am

Return to [Official] For AS40XX Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest