It is currently Wed May 12, 2021 10:40 pm
All times are UTC + 8 hours

apache mode not enabled

apache mode not enabled

Postby zqhong » Thu Mar 21, 2019 4:16 am

I'm noticing that I cannot use .htaccess to setup password controlled access to the webserver. The error message was 'Invalid command 'AuthType'', which points to mode-authn-core not enabled.

Is there a way that I can fix this? Thank you.
zqhong
 
Posts: 1
Joined: Thu Mar 21, 2019 4:11 am

Re: apache mode not enabled

Postby father.mande » Thu Mar 21, 2019 6:13 am

Hi,
zqhong wrote:I'm noticing that I cannot use .htaccess to setup password controlled access to the webserver. The error message was 'Invalid command 'AuthType'', which points to mode-authn-core not enabled.
Is there a way that I can fix this? Thank you.


I have solve the problem by adding a mods-available pointing on authn_core, then create a link to this new .conf file in mods-enabled
Code: Select all
cat mods-available/authn_core.conf
LoadModule authn_core_module /usr/builtin/lib/apache2/modules/mod_authn_core.so

[EDIT] I forget ... restart Apache after the change (/usr/builtin/etc/init.d/S54apache2 restart)

You don't have to redo this, up to an A.D.M. update (check was require)
I have open a ticket on this problem.

Philippe.
AS5202T /AS5002T / AS202TE / AS1002T
My Blog specific to my APKG : https://blog.father-mande.ovh/
User avatar
father.mande
 
Posts: 1156
Joined: Sat Sep 12, 2015 2:55 am

Return to [Official] For AS40XX Series

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron