It is currently Fri Nov 16, 2018 3:37 am
All times are UTC + 8 hours

[PlexMediaPlayer 2.20.0] Include mpv player (command line)

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby Maerlin » Tue May 15, 2018 4:38 am

father.mande wrote:Hi,
Maerlin wrote:Thanks.
Here is another log.
Around 23:28 I tried to play several home made videos.
Some at 48khz: no sound, output driver: null
One at 44khz: no sound, output driver: null
The last one is my AC3 test file, just to be sure: sounds OK on 5+1 channels. output driver: alsa.
Just as a reminder, my AS5002t is plugged through HDMI to an AMP, which is plugged to the TV. The amp is a Philips Fidelio E5.
Still very strange :)
Edit: those files are all playing properly in openPHT... :-S


Don't have an AMP to test (just an HDMI extractor to Optical to a small DTS prologic decoder)

The interesting (even not correct) is that output driver is "null" (so no sound at all by definition ... ) ??? no idea why ??? ... I can't test before end of the week ... but I will re-check config settings file ...

Philippe.


I don't think it is important, but I did not update asustor ffmpeg yet.
I'm still on 3.3.2.r11
As a matter of fact I can live without stereo, but still it is better with it :)
But don't spend too much time with it, your wirk is already wonderful!
Maerlin
 
Posts: 21
Joined: Fri Mar 10, 2017 5:37 am

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby father.mande » Tue May 15, 2018 4:24 pm

Hi,
Maerlin wrote:I don't think it is important, but I did not update asustor ffmpeg yet.
I'm still on 3.3.2.r11
As a matter of fact I can live without stereo, but still it is better with it :)
But don't spend too much time with it, your wirk is already wonderful!


Plex Media Player use libmpv library that include inside (as static) the last FFMpeg version (from Git stable)
... so the FFmpeg use and provide by Asustor is not used by P.M.P. ...

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 544
Joined: Sat Sep 12, 2015 2:55 am

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby father.mande » Sat May 19, 2018 11:15 pm

Hi Maerlin,

I just be back in my lab and run some test with PMP2 v2.10
My testing situation :
AS5002T (last A.D.M. last Asportal / Xorg)
PMP2 (v2.10)
AS5002T -> HDMI audio extractor to Optical supporting 5.1 + raw mode -> Optical converter supporting DTS and AC3 To direct speaker (5.1 + Bass) -> speakers
------------> HDMI audio extractor support HDMI pass through BUT modifying the EDID response (from Xorg or PMP) to add audio information to support 5.1 + codecs DTS and AC3
------------> HDMI output is connected to a 1080P monitor sound disabled
the audio visibility (EDID of my screen (Benq) + audio extended information :
Code: Select all
# cat /proc/asound/card0/eld#0.0
monitor_present         1
eld_valid               1
monitor_name            BenQ GL2250H
connection_type         HDMI
eld_version             [0x2] CEA-861D or below
edid_version            [0x0] no CEA EDID Timing Extension block present
manufacture_id          0xd109
product_id              0x78a1
port_id                 0xd9894495558859e
support_hdcp            0
support_ai              0
audio_sync_delay        0
speakers                [0x4f] FL/FR LFE FC RL/RR RLC/RRC
sad_count               2
sad0_coding_type        [0x2] AC-3
sad0_channels           5
sad0_rates              [0xe0] 32000 44100 48000
sad0_max_bitrate        640000
sad1_coding_type        [0x7] DTS
sad1_channels           6
sad1_rates              [0xc0] 44100 48000
sad1_max_bitrate        1536000

... so you can see the coding supported and for each the rates / bit-rate max supported

... if you list audio devices visible by mpv (/opt/mpv/bin/mpv --audio-device=help)
You can see (this depend of HDMI graphic driver)
... the HDMI "normal" output (generally in first position)
... a new HDMI direct sample mixing
... and an HDMI Hardware device with all software conversion

My settings :
FIRST test : HDMI device output (normal) / HDMI audio device type/ AC3 and DTS checked
... pass-through work as expected ... but no sound with stereo files (as you)
SECOND test : same but change audio device type to S/PDIF
... pass-through AND stereo works as expected

I have run a test with HDMI direct sample mixing ... without correct result (sound BUT pass-through is converted to stereo ... )
I have run a test with Auto detect device ... but without success ... no sound

So I can suggest you to try again but using SPDIF as Audio device type and HDMI Audio output as device ...
I have not a long time to run full tests ... it's just a first try and my first result ...

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 544
Joined: Sat Sep 12, 2015 2:55 am

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby Maerlin » Mon May 21, 2018 1:00 am

Hi Philippe, I'll give it a try this week thanks!
Maerlin
 
Posts: 21
Joined: Fri Mar 10, 2017 5:37 am

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby Maerlin » Tue May 29, 2018 3:09 am

Maerlin wrote:Hi Philippe, I'll give it a try this week thanks!


Well it seems to work! Surprisingly by selecting optical instead of hdmi... whereas I have nothing connected in optical... stereo and 5.1 works.
Thanks!
Maerlin
 
Posts: 21
Joined: Fri Mar 10, 2017 5:37 am

Re: [PlexMediaPlayer 2.10.0] Include mpv player (command line)

Postby father.mande » Tue May 29, 2018 4:31 am

Hi,
Maerlin wrote:
Maerlin wrote:Hi Philippe, I'll give it a try this week thanks!

Well it seems to work! Surprisingly by selecting optical instead of hdmi... whereas I have nothing connected in optical... stereo and 5.1 works.
Thanks!


It's also surprising for me (no spdif at all in my lab.) ... but I don't "discover" this ... it's by reading multiple posts in Plex forum (so this explain the delay) that I have suggested this test (after I doing it myself)

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 544
Joined: Sat Sep 12, 2015 2:55 am

Re: [PlexMediaPlayer 2.12.1] Include mpv player (command line)

Postby father.mande » Sun Jun 17, 2018 8:58 pm

Hi,

Please find attach link (in first post) to update Plex Media Player 2 to v 2.12.1

2.12.1
Plex Media Player v2.12.1 is now available to all macOS and Windows users.
NEW:
Desktop web-client updated to 3.55.3

Plex Media Player v2.12.0 is now available to all macOS and Windows users.
NEW:
Desktop web-client updated to 3.53.6
FIXED:
Restored ability to delete Watch Later/Recommended items
Fixed Browse by Folder showing unwatched flags on folders
Fixed cursor getting lost when navigating up to menu on Live TV Watch Now
Fixed metadata being displayed behind episode thumbnail in some cases
Fixed smooth scroll behaviour on some dashboard pages
Fixed audio & subtitle preference changes not being reflected immediately on the preplay page
Removed “Discover” and “Watch Now” buttons from Live TV Browse All

Plex Media Player v2.11.1 is now available to all macOS and Windows users.
NEW:
TV web-client updated to 3.54.2
FIXED:
Removed non-functional Channel provider


Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 544
Joined: Sat Sep 12, 2015 2:55 am

Re: [PlexMediaPlayer 2.12.1] Include mpv player (command line)

Postby Maerlin » Sun Jul 01, 2018 3:02 am

Hi Philippe,

With 2.10 and 2.12 I have another big framedrop problem.
PMP can't go hardware decoding any more, even with simple h264 file.

Known issue?

Thanks

Some logs:


Code: Select all
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Opening done: http://127.0.0.1:32400/library/parts/35057/1527509320/file.mkv?X-Plex-Session-Identifier=fghylhyuqwdkadht5bl0udiw&X-Plex-Client-Identifier=fgz5yge5dwndvc49xf01nstt&X-Plex-Device-Screen-Resolution=1920x1080%2C1920x1080&X-Plex-Version=3.56.0&X-Plex-Client-Capabilities=protocols%3Dshoutcast%2Chttp-video%3BvideoDecoders%3Dh264%7Bprofile%3Ahigh%26resolution%3A2160%26level%3A52%7D%3BaudioDecoders%3Dmp3%2Caac%2Cdts%7Bbitrate%3A800000%26channels%3A8%7D%2Cac3%7Bbitrate%3A800000%26channels%3A8%7D&X-Plex-Product=Plex%20Media%20Player&X-Plex-Platform=Konvergo&X-Plex-Platform-Version=2.12.1.dev-git&X-Plex-Device=Linux&X-Plex-Device-Name=ASUSTOR-NAS&X-Plex-Model=unknown&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Language=fr&Accept-Language=fr
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Running hook: ytdl_hook/on_preloaded
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Running hook: main/on_preloaded
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: sid="no" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: aid="1" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: ad="" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: vd="" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - mkv: select track 0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - mkv: select track 1
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:  (+) Video --vid=1 (*) (h264 1920x808 23.976fps)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:  (+) Audio --aid=1 --alang=eng (*) (dts 6ch 48000Hz)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:      Subs  --sid=1 --slang=eng (*) (f) 'English Forced' (subrip)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - display-tags: File tags:
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - display-tags:  Title: panther-2-1080-noaudio
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vo/opengl-cb: Assuming 23.976080 FPS for display sync.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Container reported FPS: 23.976025
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Codec list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd:     h264 - H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Opening decoder h264
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vdpau...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vaapi...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vdpau-copy...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Error when calling vdp_device_create_x11: 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vaapi-copy...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: VA-API version 0.40.0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: va_getDriverName() returns 0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: Trying to open /usr/local/lib/dri/i965_drv_video.so
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: va_openDriver() returns -1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Window size: 1920x1080
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video source: 0x0 (0:0)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video display: (0, 0) 1x1 -> (0, 0) 1920x1080
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video scale: 1920.000000/1080.000000
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: OSD borders: l=-1073740864 t=0 r=-1073740864 b=0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video borders: l=0 t=0 r=0 b=0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: No hardware decoding available for this codec.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Using software decoding.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Detected 2 logical cores.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Requesting 3 threads for decoding.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: DR failed - disabling.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Selected codec: h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vf: User filter list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vf:   (empty)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Codec list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad:     spdif_dts (dts) - libavformat/spdifenc audio pass-through decoder
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Opening decoder spdif_dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Selected codec: spdif_dts (libavformat/spdifenc audio pass-through decoder)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: User filter list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af:   lavcac3enc (ac3)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Starting playback...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: In: profile=20 samplerate=48000
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [in] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [lavcac3enc] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - autoconvert: inserting resampler
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - swresample: format change, reinitializing resampler
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - swresample: 48000Hz stereo spdif-dts -> 48000Hz stereo floatp
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - swresample: unsupported conversion: spdif-dts -> floatp
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - swresample: libswresample failed to initialize.
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - af: Disabling filter ac3 because it has failed.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [userspeed] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [userspeed] (disabled)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [convert] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Using software decoding.


2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1297 - no decoder for "h264"
2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1297 - no decoder for "dts"
2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1321 - no AC3 encoder available
Maerlin
 
Posts: 21
Joined: Fri Mar 10, 2017 5:37 am

Re: [PlexMediaPlayer 2.12.1] Include mpv player (command line)

Postby Maerlin » Thu Jul 12, 2018 2:25 am

Maerlin wrote:Hi Philippe,

With 2.10 and 2.12 I have another big framedrop problem.
PMP can't go hardware decoding any more, even with simple h264 file.

Known issue?

Thanks

Some logs:


Code: Select all
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Opening done: http://127.0.0.1:32400/library/parts/35057/1527509320/file.mkv?X-Plex-Session-Identifier=fghylhyuqwdkadht5bl0udiw&X-Plex-Client-Identifier=fgz5yge5dwndvc49xf01nstt&X-Plex-Device-Screen-Resolution=1920x1080%2C1920x1080&X-Plex-Version=3.56.0&X-Plex-Client-Capabilities=protocols%3Dshoutcast%2Chttp-video%3BvideoDecoders%3Dh264%7Bprofile%3Ahigh%26resolution%3A2160%26level%3A52%7D%3BaudioDecoders%3Dmp3%2Caac%2Cdts%7Bbitrate%3A800000%26channels%3A8%7D%2Cac3%7Bbitrate%3A800000%26channels%3A8%7D&X-Plex-Product=Plex%20Media%20Player&X-Plex-Platform=Konvergo&X-Plex-Platform-Version=2.12.1.dev-git&X-Plex-Device=Linux&X-Plex-Device-Name=ASUSTOR-NAS&X-Plex-Model=unknown&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Language=fr&Accept-Language=fr
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Running hook: ytdl_hook/on_preloaded
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Running hook: main/on_preloaded
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: sid="no" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: aid="1" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: ad="" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Set property: vd="" -> 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - mkv: select track 0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - mkv: select track 1
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:  (+) Video --vid=1 (*) (h264 1920x808 23.976fps)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:  (+) Audio --aid=1 --alang=eng (*) (dts 6ch 48000Hz)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - cplayer:      Subs  --sid=1 --slang=eng (*) (f) 'English Forced' (subrip)
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - display-tags: File tags:
2018-06-30 19:35:18 [ INFO  ] PlayerComponent.cpp @ 589 - display-tags:  Title: panther-2-1080-noaudio
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vo/opengl-cb: Assuming 23.976080 FPS for display sync.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Container reported FPS: 23.976025
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Codec list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd:     h264 - H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Opening decoder h264
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vdpau...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vaapi...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vdpau-copy...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Error when calling vdp_device_create_x11: 1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Looking at hwdec h264-vaapi-copy...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: VA-API version 0.40.0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: va_getDriverName() returns 0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: Trying to open /usr/local/lib/dri/i965_drv_video.so
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vaapi: libva: va_openDriver() returns -1
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Window size: 1920x1080
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video source: 0x0 (0:0)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video display: (0, 0) 1x1 -> (0, 0) 1920x1080
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video scale: 1920.000000/1080.000000
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: OSD borders: l=-1073740864 t=0 r=-1073740864 b=0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - libmpv_render: Video borders: l=0 t=0 r=0 b=0
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Could not create device.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: No hardware decoding available for this codec.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Using software decoding.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Detected 2 logical cores.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Requesting 3 threads for decoding.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: DR failed - disabling.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Selected codec: h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vf: User filter list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vf:   (empty)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Codec list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad:     spdif_dts (dts) - libavformat/spdifenc audio pass-through decoder
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Opening decoder spdif_dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: Selected codec: spdif_dts (libavformat/spdifenc audio pass-through decoder)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: User filter list:
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af:   lavcac3enc (ac3)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - cplayer: Starting playback...
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - ad: In: profile=20 samplerate=48000
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [in] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [lavcac3enc] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - autoconvert: inserting resampler
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - swresample: format change, reinitializing resampler
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - swresample: 48000Hz stereo spdif-dts -> 48000Hz stereo floatp
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - swresample: unsupported conversion: spdif-dts -> floatp
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - swresample: libswresample failed to initialize.
2018-06-30 19:35:18 [ ERROR ] PlayerComponent.cpp @ 593 - af: Disabling filter ac3 because it has failed.
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [userspeed] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [userspeed] (disabled)
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - af: [convert] 48000Hz stereo 2ch spdif-dts
2018-06-30 19:35:18 [ DEBUG ] PlayerComponent.cpp @ 587 - vd: Using software decoding.


2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1297 - no decoder for "h264"
2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1297 - no decoder for "dts"
2018-06-30 19:44:44 [ ERROR ] CodecsComponent.cpp @ 1321 - no AC3 encoder available


Someone experiencing the same problem?
Thanks
Maerlin
 
Posts: 21
Joined: Fri Mar 10, 2017 5:37 am

Re: [PlexMediaPlayer 2.12.1] Include mpv player (command line)

Postby isewise » Sun Jul 15, 2018 8:06 am

I notice some frame drops occasionally. I'm wasn't sure if PMP is the culprit, but I have noticed frame drops when watching some media.
isewise
 
Posts: 17
Joined: Sun Apr 12, 2015 6:25 am

PreviousNext

Return to PMP (PlexMediaPlayer)

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron