It is currently Tue Jan 19, 2021 2:58 am
All times are UTC + 8 hours

(SOLVED) Serviio App Request

Serviio is a free media server.
It allows you to stream your media files (music, video or images) to renderer devices (e.g. a TV set, Bluray player, games console or mobile phone) on your connected home network.

More instruction: http://forum.asustor.com/viewtopic.php? ... it=serviio

Re: Serviio App Request

Postby nulllaw » Thu Feb 13, 2014 4:35 pm

Agree!
nulllaw
 
Posts: 4
Joined: Thu Feb 13, 2014 3:28 pm

Re: [HOW TO] Run Serviio on ASUSTOR

Postby Skalmannen » Sun Mar 23, 2014 10:02 am

Thank you for the guide. I have a little problem though.
I tried to follow the guide and I can see the pictures and play my mp3 songs but I get error message when try to play movies.

This is how it looks in the log when I try to run a movie.

Code: Select all
Unknown encoder 'libmp3lame'
Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 128 kb/s
Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 640x352 [SAR 1:1 DAR 20:11], 25 tbr, 25 tbn, 25 tbc
Duration: 01:30:22.72, start: 0.000000, bitrate: 1082 kb/s
Input #0, avi, from '/volume1/Media/1 == Filmer ==/== 1 Nya Filmer ==/10 Rules for Sleeping Around (2013)/10.rules.for.sleeping.around.dvdrip.xvid.avi':
2014-03-23 03:01:13,407 WARN [ProcessExecutor] Process /volume1/serviio-1.4/bin/ffmpeg has a return code of 1! This is a possible error. Detailed output follows.
2014-03-23 03:01:12,407 WARN [ServiioStatusService] IOException occured. Returning error code 500 to the REST layer. Message: Transcoded file '/tmp/Serviio/transcoding-temp-11-flv_player-MEDIUM.stf' cannot be found, FFmpeg execution probably failed 


I first used the ipkg package with ffmgeg but uninstalled it and then downloaded your compiled ffmpeg version.

Anything i am missing?
Skalmannen
 
Posts: 2
Joined: Sun Mar 23, 2014 9:51 am

Re: [HOW TO] Run Serviio on ASUSTOR

Postby grzenio » Tue Apr 01, 2014 1:33 pm

this is problem: FFmpeg execution probably failed

what version ffmpeg dou you have? if mine then install from optware and change in script path eg. /opt/bin/ffmpeg
NAS: AS-302T
Notebook: HP 8540w, i7, 16GB RAM, Elementary OS Luna
Mmedia: Serviio on ASUSTOR NAS & Samsung TV
Network: TP-LNIK TL-WR1043ND
Portable: Moto G
grzenio
 
Posts: 34
Joined: Fri Jan 03, 2014 9:52 pm

Serviio on Asustor

Postby Taxman » Wed Apr 30, 2014 6:19 pm

Any chance someone from Asustor would be kind enough to package Serviio into an easy to use apk file or even put in on app central with the authors consent.

You can already manually install serviio the hard way on Asustor NAS but it would be nice to not have to go through all that and Serviio is probably the best UPnP/DLNA server available. The built in UPnP 1/2 servers leave a lot be desired in certain areas and Plex is a mess with overloaded browsing categories.

It looks like someone is trying to make an attempt at an apk file
https://github.com/boretom/serviio-apk
Taxman
 
Posts: 17
Joined: Thu Mar 07, 2013 12:22 am

Re: Serviio on Asustor

Postby soilderco » Wed Apr 30, 2014 10:16 pm

Hi
thanks for your information.... ;)
Storage: AS-302T
soilderco
 
Posts: 83
Joined: Tue Nov 12, 2013 11:01 pm

Re: Serviio on Asustor

Postby MrK » Thu May 01, 2014 3:01 pm

Hey, I created the Serviio APK as a starting point for someone else on this forum. He didn't take it further I guess. Creating the Serviio package is easy but what is a pain in the where-the-sun-does-not-shine is compiling ffmpeg for Serviio. If someone is up to that task I'm happy to integrate it into the package (instructions on Serviio's webpage).

If someone wants to have a look at the package (it's easy to disassemble with the ASUSTOR apk tool). It includes the latest Serviio and WebGUI 1.5.4:

Serviio 1.4.1.2-r1 for any ASUSTOR NAS with ffmpeg but without libass (hardcodec subtitles) and librtmp (streaming)

/Update 2014-05-16 : now includes ffmpeg (without libass and librtmp - couldn't get them to compile)
Last edited by MrK on Fri May 16, 2014 2:58 pm, edited 1 time in total.
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: Serviio on Asustor

Postby Kapitein Haak » Thu May 01, 2014 4:53 pm

Hello MrK,

Could you use a softlink to /usr/local/AppCentral/xbmc/ffmpeg-smd/usr/bin/ffmpeg? This is a precompiled working version for XBMC (if XBMC is installed of course).


BR, Kapitein Haak.
"What would the world be like without Captain Hook?"
---
"Homo sapiens non urinat in ventum" (A wise man doesn't piss into the wind), only in Amsterdam:
https://www.google.nl/maps/@52.36289,4. ... 312!8i6656
User avatar
Kapitein Haak
 
Posts: 333
Joined: Tue Oct 15, 2013 2:40 pm
Location: Stranded on the Dutch coast.

Re: Serviio on Asustor

Postby MrK » Thu May 01, 2014 6:29 pm

Kapitein Haak wrote:Could you use a softlink to /usr/local/AppCentral/xbmc/ffmpeg-smd/usr/bin/ffmpeg? This is a precompiled working version for XBMC (if XBMC is installed of course).

Hey Kapitein,

It's not that I don't have ffmpeg compiled but not with all the modules Serviio recommends on their Webseite. And I doubt that the ffmpeg for XBMC is including the modules which Serviio recommends - but I don't know of course.

/MrK
Storage: AS-202T | AS-604T (borrowed)
PC/Laptop: iMac 27" & rMBP 15"
Media Server/Player: Plex on ASUSTOR NAS & Samsung TV
MrK
 
Posts: 127
Joined: Tue Nov 19, 2013 7:19 pm

Re: Serviio on Asustor

Postby Taxman » Fri May 02, 2014 1:48 am

Awesome thank your MrK it works great, thankfully I don't need transcoding just the compatibility that Serviio offers. The default UPnP server has some odd discovery issues with Apple Airports and clients going through those but Plex/Serviio are fine.

Edit: Looks like I spoke too soon, music and photo work fine but for some reason it refuses to scan video content. I tried forcing a refresh and removing the sources and adding them again but nothing seems to get it scan videos, is anyone else seeing this ?
Last edited by Taxman on Fri May 02, 2014 2:54 am, edited 3 times in total.
Taxman
 
Posts: 17
Joined: Thu Mar 07, 2013 12:22 am

Re: Serviio on Asustor

Postby Auberon2k » Fri May 02, 2014 1:57 am

I'm going to give this a try later too. I don't really transcode anything from my NAS to my PS3's. The default UPnP1/2 does some weird things with some files I have. Some that worked fine when shared from a Windows 7 "server" using WMP report as unsupported data type from UPNP. So weird. Anyhow I'm trying other apps to see which works best for me. Plex was waaaaay to much mess. It had massive trouble recognizing my media, I had to spend 3 hours renaming my Doctor Who 1963 collection to match naming it expected otherwise it would ignore massive chunks of media, just way too much work for simple DLNA sharing. UPNP1 worked but lacked any real configuration/customization. Asustor provided me miniDLNA, totally lacks an interface so it's less than UPNP1. I got a copy of Twonky, but it's got a 30 day trial limit and costs $20 thereafter. I'll load Serviio on and see how it behaves.
Auberon2k
 
Posts: 213
Joined: Sat Aug 31, 2013 12:47 am

PreviousNext

Return to Serviio

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 1 guest