It is currently Sun Jun 16, 2019 7:22 pm
All times are UTC + 8 hours

[serviio 1.10.1] require ffmpeg 3 Asustor

Serviio is a free media server.
It allows you to stream your media files (music, video or images) to renderer devices (e.g. a TV set, Bluray player, games console or mobile phone) on your connected home network.

More instruction: http://forum.asustor.com/viewtopic.php? ... it=serviio

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby father.mande » Thu Dec 27, 2018 7:51 pm

Hi,
ksergey2012 wrote:Dear father.mande! I will write in more detail. I have the ADM 3.2.4.RNN1 firmware installed on my NAS. From App Central, the FFmpeg 3.3.2-13 and JRE 1.8.0_191 packages are installed. Video files are in the public folder - "Media", photo files are in the folder - "PhotoGallery", audio files are in the folder - "Music". All video files have extensions mkv or avi. All file names are UTF-8 encoded. Once again, I repeat, the entire media library was moved from Synology NAS, on which Serviio worked perfectly. I just thought, maybe the problem is due to the fact that your package does not support the names of files and folders that are written in Cyrillic? Most likely it is so, I have part of the audio and photo files, their names are written in Latin (I think Serviio scanned them), but the names of all video files are written in Cyrillic and Serviio does not see them. Dear father.mande, a big request to you, if the problem is connected with the support of the names written in Cyrillic, to correct this problem. Thank you for your work!



Serviio provide is 100% the code provide for Linux (without any modification)
Error managing Cyrilic (known problem by serviio ... read F.A.Q.) can come from :
... bad or incorrect language definition when user (root) start serviio
... ... this can come from Linux part (A.D.M.) so first try option in settings to manage non unicode file name to Ru for ex. ... or your language
... ... ask Asustor ... because tools to manage locale are NOT available ... so we can't debug this part
... ... you can try also to change LC_ALL variable in start-stop.sh of serviio ... but how to be sure to get the correct existing UTF-8 language file ... previous remark

This is explain in F.A.Q. and relative post in serviio Forum
... language impact JRE execution for file name
... language can impact FFmpeg when it try to analyse the contents of a file
... perhaps serviio ... but as F.A.Q. said ... it's a Linux (so A.DM. for Asustor) problem

For get and provide to Asustor support better information ... please provide the serviio log file (where problem with language is visible) ... do a scan with few files in a folder ...

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 678
Joined: Sat Sep 12, 2015 2:55 am

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby ksergey2012 » Thu Dec 27, 2018 8:27 pm

Good. Today I will try to install Serviio 1.10.1 and rename several files to Latin. And see the result. I think, most likely, the problem is in ADM, rather than in Serviio (everything worked perfectly on Synology). The only thing I did not understand was that I needed to change in the file “start-stop.sh”? And where can I see the magazine Serviio? By the way, Dear father.mande, the link for downloading the Serviio 1.10.1 package is not working (Not Found).
ksergey2012
 
Posts: 13
Joined: Wed Dec 26, 2018 5:05 pm

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby father.mande » Thu Dec 27, 2018 8:34 pm

Hi,
ksergey2012 wrote:Good. Today I will try to install Serviio 1.10.1 and rename several files to Latin. And see the result. I think, most likely, the problem is in ADM, rather than in Serviio (everything worked perfectly on Synology). The only thing I did not understand was that I needed to change in the file “start-stop.sh”? And where can I see the magazine Serviio? By the way, Dear father.mande, the link for downloading the Serviio 1.10.1 package is not working (Not Found).


Extra character in download URL ... apologize it's now corrected ...

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 678
Joined: Sat Sep 12, 2015 2:55 am

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby ksergey2012 » Thu Dec 27, 2018 10:59 pm

Dear Philippe! Well, everything is as it is, I renamed several video files to Latin, Serviio saw them and scanned them! What to do now? Rename several thousand files - it is not possible! Writing to support Asustor, I think this is not an option, they are just banging out, citing the fact that the Serviio package is not officially supported. How to be? I'd like to use Serviio, especially since I bought a license.
ksergey2012
 
Posts: 13
Joined: Wed Dec 26, 2018 5:05 pm

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby father.mande » Thu Dec 27, 2018 11:22 pm

Hi,
ksergey2012 wrote:Dear Philippe! Well, everything is as it is, I renamed several video files to Latin, Serviio saw them and scanned them! What to do now? Rename several thousand files - it is not possible! Writing to support Asustor, I think this is not an option, they are just banging out, citing the fact that the Serviio package is not officially supported. How to be? I'd like to use Serviio, especially since I bought a license.


In fact I don't know ... I am only a user like you ...
can you provide an URL to download a file with Cyrillic name (a sample or what else) ...so I can run some tests and see if it's possible to do somethings only by user configuration
But I am not true with the fact that Asustor don't reply to you ... managing locale is an A.D.M. problem neither able to be solve without Asustor help

For My Information : did you try to change the locale in settings (especially for non unicode file name ?

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 678
Joined: Sat Sep 12, 2015 2:55 am

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby ksergey2012 » Thu Dec 27, 2018 11:28 pm

P.S.
Dear Philippe! If necessary, here is a screenshot of the start-stop.sh file:
Attachments
Снимок экрана (5).png
Снимок экрана (5).png (136.86 KiB) Viewed 478 times
ksergey2012
 
Posts: 13
Joined: Wed Dec 26, 2018 5:05 pm

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby father.mande » Fri Dec 28, 2018 12:45 am

Hi,
ksergey2012 wrote:P.S.
Dear Philippe! If necessary, here is a screenshot of the start-stop.sh file:


Thanks ... But I write it :roll: .. so not necessary ... the problem is not changing the file ... the problem for me is TESTING with a file with Cyrillic characters in the name
can you send me (or put here) a music file for ex. with Cyrillic name) saved in a Zip or Tar file
so after extract I can try to solve the problem

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 678
Joined: Sat Sep 12, 2015 2:55 am

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby ksergey2012 » Fri Dec 28, 2018 1:00 am

Dear Philippe! Here is a link to the audio file: https://yadi.sk/d/-LlbBK0qjeI6zg
A link to the video file, I sent you in private messages and E-mail.
ksergey2012
 
Posts: 13
Joined: Wed Dec 26, 2018 5:05 pm

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby father.mande » Fri Dec 28, 2018 1:17 am

Hi,

Hum! no need to use serviio ...
I get the audio file under Windows and copy them to Public share
if I list Public ... I see the file with Cyrillic
BUT if I try to unzip ... name is changed with lot of "????"
If I force the unzip ... the file inside is incoherent name
trace hereafter (so Serviio is not used) ... I have to run more tests changing some settings in A.D.M.
Code: Select all
-rwxrwxrwx    1 guest    nogroup   220.0K Dec 27 18:10 Группа Крови.zip*
root@AS5002TaPhil:/share/Public # cd ../Music/
root@AS5002TaPhil:/share/Music # ls
Divers/ Others/
root@AS5002TaPhil:/share/Music # mkdir test
root@AS5002TaPhil:/share/Music # cd test
root@AS5002TaPhil:/share/Music/test # unzip ../../Public/??????\ ?????.zip
Archive:  ../../Public/Группа Крови.zip
  inflating: ▒▒㯯▒ ▒஢▒.mp3
root@AS5002TaPhil:/share/Music/test # ll
total 232
drwxr-xr-x    2 root     root        4.0K Dec 27 18:14 ./
drwxrwxrwx    5 admin    administ    4.0K Dec 27 18:13 ../
-rw-r--r--    1 root     root      221.7K Dec 27 18:14 ▒▒㯯▒ ▒஢▒.mp3
root@AS5002TaPhil:/share/Music/test #


so A.D.M. is the problem ...

Philippe.
Last edited by father.mande on Fri Dec 28, 2018 1:43 am, edited 1 time in total.
AS5002T / AS202TE / AS1002T
APKG Download : https://www.father-mande.ovh/
In addition to this forum ; NOT to replace it
My Forum specific to my APKG : https://www.father-mande.ovh/phpBB3/
User avatar
father.mande
 
Posts: 678
Joined: Sat Sep 12, 2015 2:55 am

Re: [serviio 1.10.1] require ffmpeg 3 Asustor

Postby ksergey2012 » Fri Dec 28, 2018 1:42 am

I guessed that the problem in ADM, as I said, on NAS Synology there were no problems with the Cyrillic alphabet. Sad ...
ksergey2012
 
Posts: 13
Joined: Wed Dec 26, 2018 5:05 pm

PreviousNext

Return to Serviio

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 2 guests