It is currently Tue Sep 19, 2017 7:37 pm
All times are UTC + 8 hours

[APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Entware-ng is A modern Optware/ipkg replacement ; Entware-ng is package repository for embedded devices. These packages allow you to add new functionality to your device. Most of them taken from OpenWRT, but others are unique.

Entware-ng exist for x86, x86_64 and armhf architecture

Entware-ng also replace astware to use common base for ALL OpenWRT platform

Optware/Ipkg is obsolete, not maintened and not secure ... (abandoned)

Re: [APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Postby father.mande » Sat Jul 08, 2017 2:01 am

Hi KSHH,

don't wait ... just search in Apache and php documentation, then (more difficult) adapt it to Asustor architecture (or perhaps support can help you technically but also to win lot of time by not searching by yourself where are the configuration file to change ) BUT for me the clear best solution is to get another Apache or ligthhttp ... to ensure the compatibility with others Web applications ... (the resources used can be minim ... only thinks is to don't use the same IP port (so change current Apache or new one) ... at end use the default Apache as a proxy to the second one ... so all become transparent ...

Philippe.
AS5002T / AS202TE / AS1002T
APKG Download https://www.father-mande.ovh/
User avatar
father.mande
 
Posts: 439
Joined: Sat Sep 12, 2015 2:55 am

Can I use Entware-ng to install IO::Socket::SSL module?

Postby primusd » Sat Jul 15, 2017 12:25 am

Hi all,

First off, to say - I'm super appreciative of the devs who keep these packages up and running for those of us trying to work around various issues with an otherwise pretty great NAS!!

I'm in need of installing the IO::Socket::SSL module to get a new implementation of Spotify running on my Logitech Media Server. I have some basic *nix command skills but have never gone as far as installing a package manager, etc.

My setup is an AS6104T running 2.6.6 RCF2.

I have searched the forums and found one reference here https://forum.asustor.com/viewtopic.php?f=23&t=6472#p20142, but being so old I did not want to risk installing the provided apk.

Can someone please confirm if I can use Entware-ng to install the IO::Socket::SSL module? If yes, I'm happy to search/learn myself how to install it... I just don't want to risk testing it blind (as I don't have the skills to revert back). That said, I would also welcome any tips for the install as well ;) .

If/when I have the Spotify implementation working, I will post a how-to in the relevant LMS forum https://forum.asustor.com/viewforum.php?f=54 to assist any others facing the same issue.

Thank you in advance!!

David
primusd
 
Posts: 7
Joined: Thu Mar 17, 2016 9:16 am

Re: [APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Postby father.mande » Sat Jul 15, 2017 3:31 pm

Hi,

Entware is a fork for NAS of OpenWRT Opkg package management

So all modules or specific software are not always provide (to be fully compatible on multiple platform and synchronized with OpenWRT feeds ... )

For perl modules ... you need to installed the limited but enough development part (gcc, make, binutils, etc.) in opkg then install CPAN and your modules

a link here : https://github.com/Entware-ng/Entware-n ... rl-modules

If you have missing include ... under each feed (one by platform) you can get a full version of include folder corresponding to all Opkg packages

Philippe.
NB don't forget to update (opkg update) the feed and installed software (opkg upgrade) to be sure to have last Opkg package version ...
AS5002T / AS202TE / AS1002T
APKG Download https://www.father-mande.ovh/
User avatar
father.mande
 
Posts: 439
Joined: Sat Sep 12, 2015 2:55 am

Re: [APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Postby primusd » Tue Jul 18, 2017 12:04 am

father.mande wrote:Hi,

Entware is a fork for NAS of OpenWRT Opkg package management

So all modules or specific software are not always provide (to be fully compatible on multiple platform and synchronized with OpenWRT feeds ... )

For perl modules ... you need to installed the limited but enough development part (gcc, make, binutils, etc.) in opkg then install CPAN and your modules

a link here : https://github.com/Entware-ng/Entware-n ... rl-modules

If you have missing include ... under each feed (one by platform) you can get a full version of include folder corresponding to all Opkg packages

Philippe.
NB don't forget to update (opkg update) the feed and installed software (opkg upgrade) to be sure to have last Opkg package version ...


Thank you Philippe!! I will use this information and link to guide me as I learn how to install the required pieces to get the IO::Socket::SSL module installed.
primusd
 
Posts: 7
Joined: Thu Mar 17, 2016 9:16 am

Re: [APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Postby WTF » Fri Aug 04, 2017 1:31 am

hi

first of all, many many thanks @father for his work and effort, also for all others who make this stuff available and working for us asustor users!!!!!

ok, my plan is to get jdownloader working on my t5104.
i'm a linux noob but not completely inexperienced cause of the terminal under osx and android file system.
so, if at the end i got a working jd on my asustor, i'll post a "noob proofed" manual in the jd thread.

so let's beginn :D
after i downloaded the package 0.97.2 and manually want to install it, i get the message it's already installed which first confused me, cause i never done that before for sure

a look at "/volume1/.@plugins/AppCentral" shows me that enware is already there:
Code: Select all
asportal/        jdownloader/     mail-server/     upnp-server-v2/
download-center/ jre/             python/          web-browser/
entware-ng/     kodi/            remote-center/   xorg/
ffmpeg/          looksgood/       soundsgood/


so, the only conclusion for me is, that enware was installed with jdownloader automatically too!?
[btw, it shows me that mail-server is installed, but i haven't and doesn't show up under installed apps in app central????]

when i now move on to update opkg, it doesn't work
Code: Select all
-sh: opkg: not found

at this point, a noob question: from which directory i can/have2 start the update command?
i've tried it from root, appcentral and enware directory where i always get the not found error.

then i stumbled over this post:
liefde wrote:I noticed that it was a lot better to NOT install python 2.7* from Asustor in the AppCentral, yet install it through entware-ng opkg.
For example to use letsencrypt or seafile it works fine if you do it all in entware-ng! But if you have Python already there from Asustor ADM, it's a horrible mess. You will not get letsencrypt or seafile-server to function.

so, for me as a noob it sounds like that the phyton installation is the reason that i can't update enware, am i'm right?

if so, what's to do?
if i uninstall phyton over the app central, it'll also remove kodi, looks/sounds good, remote and asustor portal...

at this point i need some help plzzzzzzzz :oops:

thanks a lot and kind regards!
AS5104T - ADM 2.7.3 RI21 - 8GB
WTF
 
Posts: 17
Joined: Fri Oct 23, 2015 7:28 am

Re: [APKG Entware-ng] Total replace Astware & Optware include 64 bits version

Postby chewiiie » Mon Aug 21, 2017 1:22 am

primusd wrote:Thank you Philippe!! I will use this information and link to guide me as I learn how to install the required pieces to get the IO::Socket::SSL module installed.

Hi primusd,
I'm also trying to install Spotty in LMS 7.9.1 on an Asustor NAS AS6102T.
Did you manage to install perl module IO::Socket::SSL ? I'm having trouble with it. I installed Entware-ng in App Central, then install gcc, make, perl and a lot of stuff with opkg. Then tried to add the perl module with CPAN but the install fails with the Net::SSLeay dependency installation.

Code: Select all
Running install for module 'Net::SSLeay'
Running make for M/MI/MIKEM/Net-SSLeay-1.81.tar.gz
Checksum for /root/.cpan/sources/authors/id/M/MI/MIKEM/Net-SSLeay-1.81.tar.gz ok

  CPAN.pm: Building M/MI/MIKEM/Net-SSLeay-1.81.tar.gz

Unresolvable missing external dependency.
This package requires a C compiler.
NA: Unable to build distribution on this platform.
No 'Makefile' created'YAML' not installed, will not store persistent state
  MIKEM/Net-SSLeay-1.81.tar.gz
  /usr/local/AppCentral/perl/bin/perl Makefile.PL -- NOT OK
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine prerequisites
chewiiie
 
Posts: 4
Joined: Tue Sep 06, 2016 4:32 am

Previous

Return to Entware

  • You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum
  • Who is online

    Users browsing this forum: No registered users and 2 guests