Page 1 of 1

sqlite3 missing?

PostPosted: Sun Nov 05, 2017 2:02 am
by lachender Hans
After installing BitBucStriim, the webserver on "mynasip:80/bicbucstriim" returns an error 500 (3x [an error occurred while processing this directive] and "Fehlermeldung: (none)" [Fehlermeldung=error message])
As far as I understood BitBucStriim it needs sqlite3. When I login via ssh, I cannot execute the sqlite3 command.

I already tried to install the bbs directory under the web folder manually, which generates the same result.

Re: sqlite3 missing?

PostPosted: Thu Nov 09, 2017 3:12 am
by lachender Hans
This is what I get when I try to access the page. Where can I find logfiles to see what's going wrong?
Code: Select all
[an error occurred while processing this directive][an error occurred while processing this directive]
Serverfehler!

[an error occurred while processing this directive] Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
(none)

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 500
nas
Wed Nov 8 19:57:46 2017
Apache/2.4.25 (Unix) PHP/5.6.30 OpenSSL/1.0.2k


running php index.php in the bitbucstriim directory, I get this output
Code: Select all
PHP Strict Standards:  Declaration of BicBucStriim\SegmentFactory::newInstance() should be compatible with Aura\Session\SegmentFactory::newInstance(Aura\Session\Session $session, $name) in /volume1/Web/bbs/lib/BicBucStriim/segment_factory.php on line 17
PHP Notice:  Undefined index: REQUEST_METHOD in /volume1/Web/bbs/vendor/slim/slim/Slim/Environment.php on line 124
PHP Notice:  Undefined index: REMOTE_ADDR in /volume1/Web/bbs/vendor/slim/slim/Slim/Environment.php on line 127
PHP Notice:  Undefined index: REQUEST_URI in /volume1/Web/bbs/vendor/slim/slim/Slim/Environment.php on line 131
PHP Notice:  Undefined index: SERVER_NAME in /volume1/Web/bbs/vendor/slim/slim/Slim/Environment.php on line 151
PHP Notice:  Undefined index: SERVER_PORT in /volume1/Web/bbs/vendor/slim/slim/Slim/Environment.php on line 154
check_config: Calibre library path not configured.


saving the output of php index.php to an html file, I can see that there are three issues reported by index.php:
(2x There could be a problem)
- Apache web Server?
- Is URL rewrite enabled?
(1s A problem was discovered)
- Is GD version2 (or higher) installed (infobox: The GD image library is necessary for thumbnail generation. GD support for PHP is often contained in a module like php5-gd. Please install or update the module if the check failed)


Here I am totally lost - all kind of help would be appreciated